Desktop redirection problem RRS feed

  • Question

  • Hi,

    In my environment, I configured user settings in such a way that his desktop gets directed to H:\Desktop. During the logon I am mapping the H: drive(\\server1\username) and the mapping working fine.

    The problem here is that, randomly few users are complaining that they are unable to see their desktop icons after they login. I checked the problem and verified that H: drive is mappied and it is available. Manually refreshing the desktop by selecting "right click-> refresh" option on desktop fixing the problem for some users. In some other cases, restarting the explorer fixing the problem.

    Can you anyone help me to figure out what is going wrong here? I suspect that explorer process is failing to redirect the desktop.


    I am not redirecting desktop using GPOs rather I am setting the HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders\Desktop registry key to H:\Desktop. Don't ask me for the reasons, it is a big story.



    Thanks, Sitaram http://techibee.com http://sitaram-pamarthi.com
    Monday, October 25, 2010 10:03 AM


  • Hi,


    Based on my research, I would like to suggest the following:

    Note: In the suggestions, some operations on Registry Keys are included; please perform a full backup first.


    1.      I suspect this is related to instable IconCache or corrupted IconCache, so you can try rebuilding the IconCache:


    Rebuild the IconCache


    1)       Click Start, and open Computer.

    2)       On the Tool bar, click Organize and choose Folder and Search Options.

    3)       Click the View tab, and check to select the Show hidden files and folders option, and click OK.

    4)       Then, enter the following directory:




    5)       Find the IconCache.db file, and rename it as IconCache.db.old.

    6)       Close the window, and restart the computer.


    2.      Please also check the value in the following Registry Key:


    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders\Desktop


    By default, the value should be “%USERPROFILE%\Desktop”, was it also modified?


    3.      Since the “desktop” folder is located on a remote server actually, I suspect there may be some delay when the users logon and load the desktop files and settings. Just for a test, please copy the desktop folder from the server to the local drive and see how long it takes; and modify the desktop setting in Registry Key and make it point to this desktop folder and see if this issue will occur.


    Meanwhile, I think you can try Folder Redirection with Offline Files:


    Folder Redirection Overview


    Best Practices for Folder Redirection in User Data and Settings Management


    Recommendations for Folder Redirection


    Hope it helps.



    Alex Zhao

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Cloud_TS Friday, November 5, 2010 9:36 AM
    Thursday, October 28, 2010 8:52 AM