locked
Windows 10 will not show connected computers RRS feed

  • Question

  • This question was asked in "Microsoft Community" and a reply from Nikhar Khare, Microsoft Community - Moderator
    advised me to ask it here so here goes.       

    I have 4 laptops connected to a WORKGROUP.   Only one shows the other 3 in "Explorer->Network".  Running 'net view' in Powershell on a laptop which is not seeing the others, says that SMBv1 is necessary.   Surely enough, when I enable SMBv1 all is resolved.

    However, SMBv1 is declared obsolete and every recommendation suggested  to make  "Explorer->Network" succeed without it end in failure!

    I have checked "Function Discovery Provider Host" and "Function Discovery Resource Publication" services are set to 'Automatic, Delayed Start.   I've also made sure that 'network discovery' is enabled and all machines have the necessary 'Shares' enabled.

    What is the up-to-date reliable solution please?

    Tuesday, June 2, 2020 8:31 AM

Answers

  • Make sure the router supports SMBv2 or newer, then connect to the share by directly entering the UNC path in explorers adress bar.
    As I also had the problem that my NAS drive is not visible under network, I added the share as a network location:
    How to Add a Network Location to This PC in Windows 10

    You could also create a link to the UNC path and add this to explorers quick access.
    • Marked as answer by oldcelt Friday, June 12, 2020 9:12 AM
    Saturday, June 6, 2020 3:05 AM

All replies

  • Hi ,

    Thanks for your posting here.

    Unfortunately, there is no other up-to-date reliable solution now. 

    As far as I know, for the problem of Network Computers are not Showing Up in Windows 10, the current possible solution is enable SMB 1.0.

    Best Regards,

    Candy


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com   

    Wednesday, June 3, 2020 1:46 AM
  • Enabling SMB1 is not the way to go. It is only required for Windows XP or earlier. All Windows since  Vista use the new network discovery method.

    SMB1 is a very old and very insecure protocol. Microsoft strongly recommends that you do not use it.

    https://www.zdnet.com/article/windows-10-tip-stop-using-the-horribly-insecure-smbv1-protocol/

     In my experience, the best way to find a machine which is not showing up in the Network display is to do a network reset. I do it from the command line netcfg -d but you can also do it from Settings. Reboot the PC afterwards to rebuild the network config.

      You can always find a device by name by searching in the network display using the format \\devicename, even if it does not appear automatically in the display.



    Bill

    Wednesday, June 3, 2020 5:58 AM
  • That's all very well but it's a catch 22 situation.   Microsoft says "Don't use SMB1" but if you don't then the Microsoft LAN doesn't work properly.   Why, in the name of heaven, don't they fix SMB2 so that it works?

    Alternatively, is there an alternative to MS LAN software that's reliable?

    Wednesday, June 3, 2020 12:57 PM
  • I have been having the problem to which this answer was posted since some Windows update last November.  Since I have seen other questions regarding this problem, I assume that there are lots of other Windows 10 users out there who are suffering just as I and my wife are.  We can no longer directly access files on an external hard drive connected by USB cable to our router, can no longer directly access files on each other's computers.

    How can Microsoft allow such a disaster to go unsolved???  We previously used Windows 7 and everything worked fine.  Since we upgraded to Windows 10 we have had problems.  I don't think that we should have to dig into the guts of the settings to accomplish file sharing.

    Occasionally I can find the files on the hard drive and then map that drive, though a \\devicename call, but then it goes away.

    Who can help us?

    Bob

    Friday, June 5, 2020 8:45 PM
  • Make sure the router supports SMBv2 or newer, then connect to the share by directly entering the UNC path in explorers adress bar.
    As I also had the problem that my NAS drive is not visible under network, I added the share as a network location:
    How to Add a Network Location to This PC in Windows 10

    You could also create a link to the UNC path and add this to explorers quick access.
    • Marked as answer by oldcelt Friday, June 12, 2020 9:12 AM
    Saturday, June 6, 2020 3:05 AM
  • Like Bob, I tried mapping network drives and, as in Bob;s experience, they were transient and had always disappeared just when one wanted to make a transfer or simply examine something on another networked machine..  

    I spent hours and days trying to find a reliable solution without success and nobody seems to have a straightforward reliable answer.

    The truth is that SMBv2 is faulty in this respect and needs fixing.   Until that happens, I'm continuing to use SMBv1 regardless of the alleged risks.

    Come on Microsoft, get your fingers out and sort this problem once and for all!

    Saturday, June 6, 2020 8:25 AM
  •   That is your decision. That is why the option is there.


    Bill

    Sunday, June 7, 2020 12:03 AM
  • Hi 

    If you don't want to use smbv1, try to setup your hosts file. It is located to C:\Windows\System32\drivers\etc

    https://support.rackspace.com/how-to/modify-your-hosts-file/


    septviessuivront

    Friday, June 12, 2020 4:38 AM