locked
Timer job issue RRS feed

  • Question

  • we are using MOSS 2007 .we must restart the server every day then only sharepoint  works, other wise it will show the error.

    I think our timer job setting is not working properly.

    How to solve this issue?

    • Moved by Mike Walsh FIN Friday, May 6, 2011 10:44 AM admin q (From:SharePoint - General Question and Answers and Discussion (pre-SharePoint 2010))
    Friday, May 6, 2011 10:36 AM

All replies

  • Hi,

    I have some question here:

    1. How did you know that your timer job setting is not working properly?

    2. First you should check the log file which is located in 12 hive folder and find out the error over there. 

    3. Check the event viewer if there is any signal of error

    Let us know if you find anything in log file or event viewer


    Cheers, Hemendra-MCTS "Yesterday is just a memory,Tomorrow we may never see"
    • Marked as answer by Peng Lei Monday, May 16, 2011 2:35 AM
    • Unmarked as answer by Mike Walsh FIN Thursday, May 26, 2011 9:55 AM
    Friday, May 6, 2011 11:18 AM
    Moderator
  • Following error displayed in error log.

    Can you give me the solution?

     

    CSsoResourceManagerCache cannot find SSO connection string value in the registry!	 
    05/26/2011 06:42:26.56 	SSOSRV.EXE (0x08E4)           	0x0950	SharePoint Portal Server   	SSO              	0	High  	Error code is: -2147418113	 
    05/26/2011 06:42:26.56 	SSOSRV.EXE (0x08E4)           	0x0950	SharePoint Portal Server   	SSO              	0	High  	CSsoResourceManagerCache has set SSO connection string value to be empty ... SSO is not configured any more.	 
    05/26/2011 06:42:26.56 	SSOSRV.EXE (0x08E4)           	0x0950	SharePoint Portal Server   	SSO              	0	High  	Error code is: -2147418113	 
    05/26/2011 06:42:26.56 	SSOSRV.EXE (0x08E4)           	0x0950	SharePoint Portal Server   	SSO              	0	High  	IResourceManager::Refresh() failed	 
    05/26/2011 06:42:26.56 	SSOSRV.EXE (0x08E4)           	0x0950	SharePoint Portal Server   	SSO              	0	High  	Error code is: -2147024809	 
    05/26/2011 06:42:26.56 	SSOSRV.EXE (0x08E4)           	0x0950	SharePoint Portal Server   	SSO              	0	High  	ForceRefreshOfSPSResMgr() failed. This may be ok if SSO has not been configured yet and the run-as service gets an access denied	 
    05/26/2011 06:42:26.56 	SSOSRV.EXE (0x08E4)           	0x0950	SharePoint Portal Server   	SSO              	0	High  	Error code is: -2147024809	 
    05/26/2011 06:42:26.56 	SSOSRV.EXE (0x08E4)           	0x0950	SharePoint Portal Server   	SSO              	0	High  	CSsoResourceManagerCache cannot find SSO connection string value in the registry!	 
    05/26/2011 06:42:26.56 	SSOSRV.EXE (0x08E4)           	0x0950	SharePoint Portal Server   	SSO              	0	High  	Error code is: -2147418113	 
    05/26/2011 06:42:26.56 	SSOSRV.EXE (0x08E4)           	0x0950	SharePoint Portal Server   	SSO              	0	High  	CSsoResourceManagerCache has set SSO connection string value to be empty ... SSO is not configured any more.	 
    05/26/2011 06:42:26.56 	SSOSRV.EXE (0x08E4)           	0x0950	SharePoint Portal Server   	SSO              	0	High  	Error code is: -2147418113	 
    05/26/2011 06:42:26.56 	SSOSRV.EXE (0x08E4)           	0x0950	SharePoint Portal Server   	SSO              	0	High  	CSsoResourceManagerCache::Refresh Failed!	 
    05/26/2011 06:42:26.56 	SSOSRV.EXE (0x08E4)           	0x0950	SharePoint Portal Server   	SSO              	0	High  	Error code is: -2147024809	 
    05/26/2011 06:42:26.56 	SSOSRV.EXE (0x08E4)           	0x0950	SharePoint Portal Server   	SSO              	0	High  	CSsoResourceManager failed to get Connection String from the cache!	 
    05/26/2011 06:42:26.56 	SSOSRV.EXE (0x08E4)           	0x0950	SharePoint Portal Server   	SSO              	0	High  	Error code is: -2147024809	 
    05/26/2011 06:42:26.56 	SSOSRV.EXE (0x08E4)           	0x0950	SharePoint Portal Server   	SSO              	0	High  	IResourceManager::CreateSession() failed, we will call IResourceManager::Refresh() to refresh and try again	 
    05/26/2011 06:42:26.56 	SSOSRV.EXE (0x08E4)           	0x0950	SharePoint Portal Server   	SSO              	0	High  	Error code is: -2147024809	 
    05/26/2011 06:42:26.56 	SSOSRV.EXE (0x08E4)           	0x0950	SharePoint Portal Server   	SSO              	0	High  	CSsoResourceManagerCache cannot find SSO connection string value in the registry!	 
    05/26/2011 06:42:26.56 	SSOSRV.EXE (0x08E4)           	0x0950	SharePoint Portal Server   	SSO              	0	High  	Error code is: -2147418113	 
    05/26/2011 06:42:26.56 	SSOSRV.EXE (0x08E4)           	0x0950	SharePoint Portal Server   	SSO              	0	High  	CSsoResourceManagerCache has set SSO connection string value to be empty ... SSO is not configured any more.	 
    05/26/2011 06:42:26.56 	SSOSRV.EXE (0x08E4)           	0x0950	SharePoint Portal Server   	SSO              	0	High  	Error code is: -2147418113	 
    05/26/2011 06:42:26.56 	SSOSRV.EXE (0x08E4)           	0x0950	SharePoint Portal Server   	SSO              	0	High  	IResourceManager::Refresh() failed	 
    05/26/2011 06:42:26.56 	SSOSRV.EXE (0x08E4)           	0x0950	SharePoint Portal Server   	SSO              	0	High  	Error code is: -2147024809	 
    05/26/2011 06:42:26.56 	SSOSRV.EXE (0x08E4)           	0x0950	SharePoint Portal Server   	SSO              	0	High  	ConnectToSSODBUsingSPSResMgr() failed	 
    05/26/2011 06:42:26.56 	SSOSRV.EXE (0x08E4)           	0x0950	SharePoint Portal Server   	SSO              	0	High  	Error code is: -2147024809	 
    05/26/2011 06:42:26.56 	SSOSRV.EXE (0x08E4)           	0x0950	SharePoint Portal Server   	SSO              	0	High  	IResourceManager::CreateSession() failed and SSO is not configured, so returning SSO_E_SSO_NOT_CONFIGURED	 
    05/26/2011 06:42:26.56 	SSOSRV.EXE (0x08E4)           	0x0950	SharePoint Portal Server   	SSO              	0	High  	Error code is: -2140993974	 
    05/26/2011 06:42:26.56 	SSOSRV.EXE (0x08E4)           	0x0950	SharePoint Portal Server   	SSO              	0	High  	CSSOService::ConnectToSSODB() failed	 
    05/26/2011 06:42:26.56 	SSOSRV.EXE (0x08E4)           	0x0950	SharePoint Portal Server   	SSO              	0	High  	Error code is: -2140993974	 
    05/26/2011 06:42:26.56 	SSOSRV.EXE (0x08E4)           	0x0950	SharePoint Portal Server   	SSO              	0	Medium 	Destroying CCommandEx	 
    05/26/2011 06:42:26.56 	SSOSRV.EXE (0x08E4)           	0x0950	SharePoint Portal Server   	SSO              	0	Medium 	Destroying CSessionEx	 
    05/26/2011 06:42:26.56 	SSOSRV.EXE (0x08E4)           	0x0950	SharePoint Portal Server   	SSO              	0	High  	::GetSSOConfig() failed	 
    05/26/2011 06:42:26.56 	SSOSRV.EXE (0x08E4)           	0x0950	SharePoint Portal Server   	SSO              	0	High  	Error code is: -2140993974	 
    05/26/2011 06:42:26.56 	SSOSRV.EXE (0x08E4)           	0x0950	SharePoint Portal Server   	SSO              	0	High  	CSSOService::RefreshSSOConfigIfStale setting SSO as Not Configured, returning SSO_E_SSO_NOT_CONFIGURED	 
    05/26/2011 06:42:26.56 	SSOSRV.EXE (0x08E4)           	0x0950	SharePoint Portal Server   	SSO              	0	High  	Error code is: -2140993974	 
    05/26/2011 06:42:26.56 	SSOSRV.EXE (0x08E4)           	0x0950	SharePoint Portal Server   	SSO              	0	High  	CSSOService::RefreshSSOConfigIfStale() failed	 
    05/26/2011 06:42:26.56 	SSOSRV.EXE (0x08E4)           	0x0950	SharePoint Portal Server   	SSO              	0	High  	Error code is: -2140993974	 
    

    Thursday, May 26, 2011 5:37 AM
  • HI Jey,

    can you let me know what exactly would be the error if you do not restart the sharepoint server. I mean do you get an error whlie browsing sharepoint site or central admin if so what is the error message. Plese eloborate.

    Thanks,

    Raj

    Thursday, May 26, 2011 10:09 AM
  • Well, as the errors suggest......Do you have SSO configured?

    The only things these messages are showing is the fact that the service SSOSRV.EXE is having an issue and saying that SSO is not configured.

    Do you have a log of when the server goes down?

     

    Thanks,

    Rick

    • Marked as answer by Peng Lei Monday, May 30, 2011 3:12 AM
    • Unmarked as answer by Jeym Thursday, June 9, 2011 6:33 AM
    Thursday, May 26, 2011 2:52 PM
  • HI,

    Have you tried IISRESET or app pool recycling during the issues you face on your server?

    If not I would suggest you to try the same during the time. However to find out the root cause of the issue you are facing I would suggest you to enable verbose mode of logging at the time you face this error.

    How many WFEs are there in your farm? Is this issue happens in all WFEs or in only selected ones? Have you checked the database at the time you face issues? If not I suggest you to do so and check for errors or deadlocks. There is a tool SQL Profiler that will help you a lot in analysis at the database level.

    I hope this will help you out.

    Thanks,

    Rahul Rashu

     

    • Marked as answer by Peng Lei Monday, May 30, 2011 3:12 AM
    • Unmarked as answer by Jeym Thursday, June 9, 2011 6:33 AM
    Saturday, May 28, 2011 11:54 AM
  • Hi Jey,

    follow the  article http://support.microsoft.com/kb/939308 and check if that could help you.

    Thanks,

    Rah

    Wednesday, June 22, 2011 9:00 AM