none
MDT 2013 - Add To Domain RRS feed

  • Question

  • I have provided the appropriate variables in my CS.ini file.  My computer is not joining the domain.  I have a powershell script that I created.  I provided the same variables in the script and it works flawlessly.   It is as follows:

    $strUser = "domain\username"
    $strDomain = "domain"
    $strPass=ConvertTo-SecureString "password -AsPlainText -Force
    $Credentials=New-Object System.Management.Automation.PSCredential $strUser, $strPass
    $strOU="OU"

    Add-Computer -DomainName $strDomain -Credential $Credentials -strOUPath $StrOU

    This works fine callling it from a command line.  I then created a task toward the end of the task sequence and disabled the RecoverDomain task and it works fine.   However, I would like to customize it.  All are default settings except for the OU.  I would like to customize the OU to reflect the MachineObjectOU that I have set in my CS.ini file.  Any pointers would be great.


    Friday, February 19, 2016 7:55 PM

All replies

  • Hi

    What are in the logfiles for domain join??

    My customsettings.ini:

    JoinDomain=INTERN
    DomainAdmin=INTERN\DomainJoin 
    DomainAdminPassword=Password
    MachineObjectOU=ou=Workstations,dc=osddeployment,dc=dk

    Try to remove MachineObjectOU.

    What rights does the user for domain has??

    Kind regards
    Per Larsen
    Twitter: @PerLarsen1975 | Blog: osddeployment.wordpress.com
    If this post is helpful please vote it as Helpful or click Mark for answer.

    Saturday, February 20, 2016 8:50 AM