none
How to change the type of “open file” prompt in Internet Explorer RRS feed

  • Question

  • I have a .Net web application that allows the user the open a Word document which is a macro-based report. This has worked well for years until recently. And now we are starting to have some issues with the opening of the Word doc.

    I've determined that I currently have some PCs that work well, and some that don't. Here are the main differences:

    Working:

    • When clicking on the file link, the IE11 browser shows a prompt on the center of the screen asking the user to "open, save or cancel". Similar to this:
       Good
    • When the user selects "Open", the word file is opened with a yellow message saying "Enable content".
    • When the user clicks on "Enable content", the macro executes and the data is filled correctly.

    Not working:

    • When clicking on the file link, the IE11 browser shows a prompt on the bottom of the screen asking the user to "open, save or cancel". Like this:
       Fail
    • When the user selects "Open", the word file is opened with a yellow message saying "Enable edit".
    • When the user selects "Enable edit", there is a new yellow message saying "Enable content".
    • When the user clicks on "Enable content", the macro does not execute and/or has no data.

    So my questions are, What's the difference in the IE11 setup and how do I change it?

    Company policy is to use IE so I haven't even tested the behavior in other browsers because the website simply doesn't work well on them.

    Tuesday, December 22, 2015 12:43 PM

All replies

  • Hi,

    use the File>Properties menu to determine which IE security zone a site is mapping to. there is an IE security zone setting which determines how "unsafe" files are opened...

    ensure that the client is accepting your company's default security zone settings (click "Reset all zones to default" on the security tab of Internet Options).

    Use the dev tool (f12) to view any (suppressed) error messages. Use the Emulation tab of the dev tool to determine which IE emulation mode is being used and how it was set... IE11 Emulation mode no longer supports vbscript. For testing purposes you can use the dev tools emulation tab to change the emulation mode to a lower IE version to see if it works in an earlier emulation mode.

    Regards.


    Rob^_^

    Wednesday, December 23, 2015 12:31 AM
  • Hi,

    I have received the message regarding to your issue. I would like to know whether these PCs are using different operating system. Could you please tell us what the .net application is? Do you download it or complied by yourself?

    Before we know that, you could try the steps below to fix it.

    1. Use compatibility mode to view the website and open it.

    http://windows.microsoft.com/en-us/internet-explorer/use-compatibility-view#ie=ie-11

    2. Add the website to trusted site. Click "Tools" > "Internet Options" > "security" tab > click "sites". Add the website into it.

    3. Set default program for it. Currently, I haven't known how the application works to open Word document. You could set default programs as the application for ".doc" to test.

    http://windows.microsoft.com/en-us/windows/change-default-programs#1TC=windows-7

    For another possibility, the anti-virus software may prevent this action. You need to disable the anti-virus even Windows Defender because the anti-virus software may take this program as a risky program.

    Also, if you are using the different operating system, we could not exclude the possibility that the application is not compatible with the newer version Windows.

    Best Regards

    Simon  

     


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Wednesday, December 23, 2015 6:00 AM
    Moderator
  • Hi Sergio,

    Also, you could change some settings in your Office Word. You need to add the trusted URL into the Trusted Center of the Word. Could you please tell me your Office version?

    https://support.office.com/en-us/article/Add-remove-or-view-a-trusted-publisher-1c7c871c-632c-408c-8233-c7dd47289a00

    Also, you could choose "Enable all macros" in the picture below due to I have noticed that you mentioned the document is "macros-based".

     

     

    Hope it will be helpful to you.

    Best Regards

    Simon


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Thursday, December 24, 2015 7:41 AM
    Moderator
  • The most important issue right now is the way the file is opened: Center prompt good, yellow bottom prompt bad.

    I've tried changing everything in the security zone settings and then reset back to default, and I still can't change the prompt. Following with F12, I see that as an intranet site it is shown in compatibility view which uses IE5 emulation. I have also tried all emulation values and I always get the bottom yellow prompt, which is not what I need.

    I think this is a security issue but I still have to find out where. This is a corporate environment and as such we get global policy updates from above so something must have changed that we were not notified of.

    Monday, January 4, 2016 10:24 AM
  • I forgot to mention that we use "Disable all macros with notification", which is why I should get the "Enable content" button in Word. In any case, when I try to enable all macros the document executes the macro but with errors. I'm positive that the problem is in IE, not in Word.

    Like I said before, the most important issue right now is the way the file is opened: Center prompt good, yellow bottom prompt bad.

    Monday, January 4, 2016 10:29 AM
  • All PCs use Windows 7, Office 2010. It's a company built ASP.NET website that calls the .Doc file through HTTP. The doc file automatically executes the macro to call a web service to obtain the XML data that it will use to populate itself. When the IE opens the document in the center prompt then it Works perfectly because the file is run by the local Word instance but from the server repository, but when IE opens the yellow bottom prompt then the file is downloaded and run locally and doesn't work.

    Maybe it's an IIS issue? In any case, what I need is for the file to open with a center prompt, not with the yellow bottom prompt.

    I have already tried compatibility view.
    I have already tried fiddling with trusted sites.
    Word is already the default program, but this is not the issue.



    • Edited by Sergio FM Monday, January 4, 2016 10:50 AM
    Monday, January 4, 2016 10:46 AM
  • Hi Sergio,

    Thank you for your reply.

    I am wondering if Windows Defender cause it. I would like to suggest you turn off Windows Defender temporarily to test the issue.

    If it doesn't work, we would like to suggest you use Process Monitor to capture the process about the failed opening to know the exact reason.

    https://technet.microsoft.com/en-us/sysinternals/processmonitor.aspx?f=255&MSPPError=-2147217396

    Wish you have a nice day.

    Best Regards

    Simon


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, January 5, 2016 4:42 AM
    Moderator
  • Hi. Windows Defender is disabled in our corporate network. We use Symantec Endpoint Protection instead, which I have also disabled without any changes in the behavior.
    Tuesday, January 5, 2016 12:30 PM
  • Hi,

    Thank you for your reply.

    Since it still doesn't work, we would like to suggest you open the file manually in temporary folder. When you choose open in the download page, the file will be saved in the temporary folder. Please try to open it in temporary folder for test and tell us the result after you checking.

    You could click "Tools" > “Internet Options" > "General" tab > "Browsing History" column > "Settings" > "View Objects". Then you will see the temporary file path.

    Good luck to fix it.

    Best Regards

    Simon 


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Wednesday, January 6, 2016 2:11 AM
    Moderator
  • Following with F12, I see that as an intranet site it is shown in compatibility view which uses IE5 emulation.

    But what is the difference for the two cases in terms of what is being traced? 

    BTW another pair of comparison traces could be done by using ProcMon.  Filter coarsely at first (e.g. using Operation Begins with Load) to find a divergence and then remove the filter at that point to go backwards to try to find out what causes it.

    Good luck



    Robert Aldwinckle
    ---

    Wednesday, January 6, 2016 9:59 PM
    Answerer
  • Hello again, 

    I'm still looking for a solution to this problem. I found someone with the opposite problem:
    https://community.spiceworks.com/topic/485615-ie11-download-notification-bar-vs-dialog-box-issue

    Unfortunately, his problem is that the notification bar is good for him and the dialog box is bad, so resetting IE means he gets the notification bar again, while I need to get rid of it. But what this does mean for me is that it absolutely must be an IE setting of some sort.

    Any more ideas?


    • Edited by Sergio FM Friday, March 4, 2016 8:23 AM
    Friday, March 4, 2016 8:18 AM
  • I'm still looking for a solution to this problem.

    What do your traces show?  What's different?


    Robert Aldwinckle
    ---

    Sunday, March 6, 2016 4:05 AM
    Answerer
  • I'm still looking for a solution to this problem.

    Did you find the answer? I'm also trying to find solution for a problem that matches your description...
    Tuesday, July 11, 2017 10:47 AM