locked
ATA Gateway service not starting. RRS feed

  • Question

  • Hello All,

    I have 3 Gateway servers running in 2 sites. After this last weekend none of my gateway servers are communicating with the console. I have the same errors in all 3 gateway logs:

    --- End of stack trace from previous location where exception was thrown ---
       at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
       at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
       at Microsoft.Tri.Gateway.Resolution.DirectoryServicesClient.<TryCreateLdapConnectionAsync>d__24.MoveNext() 
    2016-01-18 16:03:44.2555 2632 11  9d4733d1-11a1-46f7-817d-ca662628e57a Error [AsyncResult] System.ServiceModel.Security.MessageSecurityException: An unsecured or incorrectly secured fault was received from the other party. See the inner FaultException for the fault code and detail. ---> System.ServiceModel.FaultException: At least one security token in the message could not be validated.
       --- End of inner exception stack trace ---
       at System.Runtime.AsyncResult.End[TAsyncResult](IAsyncResult result)
       at System.ServiceModel.Channels.ServiceChannel.SendAsyncResult.End(SendAsyncResult result)
       at System.ServiceModel.Channels.ServiceChannel.EndCall(String action, Object[] outs, IAsyncResult result)
       at System.ServiceModel.Channels.ServiceChannelProxy.TaskCreator.<>c__DisplayClass2.<CreateTask>b__1(IAsyncResult asyncResult)
       at System.Threading.Tasks.TaskFactory`1.FromAsyncCoreLogic(IAsyncResult iar, Func`2 endFunction, Action`1 endAction, Task`1 promise, Boolean requiresSynchronization)
    --- End of stack trace from previous location where exception was thrown ---
       at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
       at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
       at Microsoft.Tri.Gateway.Resolution.DirectoryServicesClient.<CreateLdapConnectionAsync>d__25.MoveNext()
    --- End of stack trace from previous location where exception was thrown ---
       at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
       at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
       at Microsoft.Tri.Gateway.Resolution.DirectoryServicesClient.<TryCreateLdapConnectionAsync>d__24.MoveNext() 
    2016-01-18 16:03:44.2868 2632 5   00000000-0000-0000-0000-000000000000 Error [KeyedObjectPool`2] Microsoft.Tri.Infrastructure.ContractException: Contract exception
       at Microsoft.Tri.Infrastructure.Utils.KeyedObjectPool`2..ctor(IReadOnlyCollection`1 keysToItems, Int32 maxSize, CancellationToken cancellationToken, Action`1 itemRemovedCallback)
       at Microsoft.Tri.Gateway.Resolution.DirectoryServicesClient.OnStart()
       at Microsoft.Tri.Infrastructure.Framework.Module.Start()
       at Microsoft.Tri.Infrastructure.Framework.ModuleManager.OnStart()
       at Microsoft.Tri.Infrastructure.Framework.Module.Start()
       at Microsoft.Tri.Infrastructure.Framework.Service.OnStart(String[] args) 

    One thing I found odd about the log was the time stamp. The serves all have the correct time as they get their time from the DC. However the log time stamps are 7 hour ahead. Does anyone have any ideas as to what is going on here?

    Thanks,

    Scott

    Monday, January 18, 2016 4:08 PM

All replies

  • I had to uninstall all of the gateways and reinstall the gateways. My system is working again for now.
    Tuesday, January 19, 2016 3:22 PM
  • Hi,

    I had a similar issue with the Gateway not starting. 

    My fix was to configure the domain connectivity settings again and the service started successfully after that.

    Tuesday, February 9, 2016 12:37 AM