locked
Most Jpegs do not show Thumbnails RRS feed

  • Question

  • When I open My Pictures folder in Windows Explorer I get inconsistent results in terms of seeing thumbnails.  In medium Icon view some of the pictures show as thumbnails and others as Icons.   When I switch to large or extra large icons I see thumbnails for about a second and then they are replaced by generic icons.  This happens in all folders and subfolders for my pictures.    As a matter of fact when I click on Personalization and AERO thems all the themes show black backgrounds in the preview.  When I click on them they show up on my wallpaper but the Theme previews are all black backgrounds.  

    I am running windows 7 ultimate 64-bit on my home computer. 

    Friday, June 10, 2011 12:31 AM

Answers

  • You say they show up for a while then go away?  Sounds like you may have a faulty codec (Shell Extension) installed, and/or that your Explorer Thumbnail Cache is possibly corrupted.

    Some things that might help:

    1.  Review all your codecs with the System Internals AutoRuns application.

    2.  Clear your Thumbnail Cache database via the Disk Cleanup function.  There are many articles online giving more detail on how to do this.

    3.  For the future, configure Windows to avoid saving thumbnail information in Thumbs.db.  This can be done as follows:

    • Click the Start orb
    • Enter gpedit.msc in the search box and hit Enter.
    • Expand User Configuration - Administrative Templates - Windows Components.
    • Click on Windows Explorer.
    • Right-click the entry "Turn off the caching of thumbnails in hidden thumbs.db files" and choose Edit.
    • Enable the setting.

    Note: If you have a version of Windows that does not provide the Group Policy Editor, the change can be done through a registry modification:

    • [HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\ Explorer]
      DisableThumbsDBOnNetworkFolders REG_DWORD 0x00000001

    -Noel

    • Marked as answer by Leo Huang Friday, June 17, 2011 9:01 AM
    Friday, June 10, 2011 8:28 PM