none
Post 1511 to 1607 Upgrade, Outlook Repair Occurs on First Launch

    Question

  • We're testing the 1511 to 1607 upgrade and discovered that after the upgrade when launching Outlook, it goes through a repair process before the user can use it.  If we re-image and open other Office applications first before Outlook, we don't see a repair operation.  It's unique to Outlook and happens when launched in safe mode.

    Are others seeing this?

    Is this expected?  And if so, what's the cause/reasoning behind that?  Can we do anything during OSD to eliminate this?

    Windows 10 1511 to 1607
    Office 2016 Pro Plus MSI (not C2R, not 365)

    Tuesday, March 28, 2017 8:19 PM

All replies

  • Repair an Office application

    S.Sengupta, Windows Insider MVP

    Wednesday, March 29, 2017 12:08 AM
  • If we re-image and open other Office applications first before Outlook, we don't see a repair operation.  It's unique to Outlook and happens when launched in safe mode.

    Are others seeing this?

    Is this expected?  And if so, what's the cause/reasoning behind that?  Can we do anything during OSD to eliminate this?

    Hi ,
    It should not be expected. We have not been reported this kind of issue, you could ask our Outlook forum to confirm that.
    I want to know if we re-image and open Outlook at first, will this issue occur again?
    Windows will migrate our personal date and configuration files during upgrading process. Based on my understanding, there is a possibility that Outlook components are corrupted during the upgrading process. Please check if there is any related error message recorded in setupact.log and Setuperr.log when this issue occurred. Upload them to OneDrive and share us the link if it is possible.

    Best regards


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, March 30, 2017 9:51 AM
    Moderator
  • Hey there Rick_Li - Thanks for the reply!


    I want to know if we re-image and open Outlook at first, will this issue occur again?

    When we go from v1511 to v1607, the repair process happens on the first launch of Outlook.
    If we re-apply v1607 a second time to the same machine alread on v1607, Outlook prompts a repair again.
    On the surface, it appears the repair is triggered by the upgrade process.


    Windows will migrate our personal date and configuration files during upgrading process. Based on my understanding, there is a possibility that Outlook components are corrupted during the upgrading process. Please check if there is any related error message recorded in setupact.log and Setuperr.log when this issue occurred.

    I took a look at the setupact and setuperr logs in Panther and Panther\UnattendGC but it's a little challenging considering there are nearly 500k lines in the log.  I've tried sanitizing the data but there's so much in here: username (samaccountnames), domain names, UNC paths, SID etc.  As such I'm not comfortable posting a link with the raw logs - perhaps I could send you a private link via email?


    • Edited by JuliusPIV Wednesday, April 5, 2017 2:07 PM
    Wednesday, April 5, 2017 1:53 PM
  • Repair an Office application

    S.Sengupta, Windows Insider MVP

    Thanks Sengupta but I'm not asking for how to repair an Office application.

    Wednesday, April 5, 2017 2:08 PM
  • perhaps I could send you a private link via email?


    Hi ,

    It is a public forum. Due to the privacy policy , it is not allowed for us to provide email address. It is not suggested for you to post email address too. Thanks for understanding.

    Best regards


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, April 26, 2017 9:38 AM
    Moderator