Deployment 'ImpersonationMode' Error


  • Hello all,

    I am using SQL 2012 and I am still in the process of building my first cube as I am a newbie. After I have set up my dimension, i tried to deploy it just to know how I am progressing and unfortunately it came out with the following messages:

    Warning    1    AttributeRelationship [Product].[Product ID].[Name_] : The name specified for the attribute relationship differs from the name of the related attribute.        0    0    
    Warning    2    Dimension [Product] : Create hierarchies in non-parent child dimensions.        0    0    
    Error    3    Internal error: The operation terminated unsuccessfully.        0    0    
    Error    4    The datasource, 'Adventure Works2012', contains an ImpersonationMode that is not supported for processing operations.        0    0    
    Error    5    Errors in the high-level relational engine. A connection could not be made to the data source with the DataSourceID of 'Adventure Works2012', Name of 'Adventure Works2012'.        0    0    
    Error    6    Errors in the OLAP storage engine: An error occurred while the dimension, with the ID of 'Product', Name of 'Product' was being processed.        0    0    
    Error    7    Errors in the OLAP storage engine: An error occurred while the 'Name' attribute of the 'Product' dimension from the 'MultidimensionalProject1' database was being processed.        0    0    
    Error    8    Server: The current operation was cancelled because another operation in the transaction failed.        0    0  

    When I 'build' it, it worked fine but the deployment is being problematic; I have tried a number of options suggested in a number of treads on this platform-changing impersonation to 'use service account','credentials of current user' and even going to configuration manager to change from Networkservice to Localsystem but am still not able to deploy.

    Could someone  Please give me any suggestions that you may have and help me out. thanks a lot in advance..


    Saturday, September 28, 2013 2:18 PM


  • Hi Charles,

    Firstly, if you set "Use the Service Account" option for the impersonation setting, please ensure the service account have sufficient permission access to your data source. In addition, we can directly use a specific user name and password(Please also ensure the account have sufficient permssion access to the data source) for the impersonation settng.

    For more information, please see:
    Set Impersonation Options:

    Best Regards,

    Elvis Long
    TechNet Community Support

    Monday, September 30, 2013 3:04 AM