none
Project Publish job fails at same percent every time! RRS feed

  • Question

  • When I am publishing a project, the "Project Publish" job fails at 24% without fail every time.  I have tried saving an offline copy, uploading it to our dev instance and then re uploading it to production (this usually works on our corrupted schedules).  We have also tried the importing from xml workaround.  I find it very bizarre that it is happening at the same percentage everytime.  I would be greatly appreciative if someone could point me in the right direction to investigate from the server or project perspective.  We are just starting to look into defragmenting our database...  We are unsure if this would help or not.  Thanks!
    Wednesday, July 11, 2012 6:07 PM

All replies

  • Hi Bill,

    Did you have the same issue when importing this plan to the dev environment? Have you checked the ULS logs? This post might help investigate the issue:

    http://pwmather.wordpress.com/2011/11/12/investigating-projectserver-and-sharepoint-errors-ps2007-sp2007-moss-ps2010-sp2010/

    Thanks

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com

    Wednesday, July 11, 2012 6:55 PM
    Moderator
  • We are not having this issue when importing into dev.
    Wednesday, July 11, 2012 7:24 PM
  • Ok, you will need to check the queue and ULS logs to get the error details, post back and hopefully we can help.

    Thanks

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com

    Wednesday, July 11, 2012 7:25 PM
    Moderator
    • GeneralQueueJobFailed (26000) - ProjectPublish.FullPublishDeleteMessage. Details: id='26000' name='GeneralQueueJobFailed' uid='1f29baf1-4f05-4ed0-a453-757042bc2e84' JobUID='884b1067-7da8-4547-a7e4-2926b4dbf6c4' ComputerName='XXX' GroupType='ProjectPublish' MessageType='FullPublishDeleteMessage' MessageId='48' Stage=''. For more details, check the ULS logs on machine XXX for entries with JobUID 884b1067-7da8-4547-a7e4-2926b4dbf6c4

    Here are the ULS logs:

    07/11/2012 14:27:53.74  w3wp.exe (0x166C)                        0x114C SharePoint Foundation          Monitoring                     nasq Medium   Entering monitored scope (Request (GET:https://servername/pwa/xxx/_layouts/PWA/Common/QueueErrorText.aspx?JobGuid=884b1067-7da8-4547-a7e4-2926b4dbf6c4&IsDlg=1)) 

    07/11/2012 14:27:53.74  w3wp.exe (0x166C)                        0x114C SharePoint Foundation          Logging Correlation Data       xmnv Medium   Name=Request (GET:https://server:443/pwa/xxx/_layouts/PWA/Common/QueueErrorText.aspx?JobGuid=884b1067-7da8-4547-a7e4-2926b4dbf6c4&IsDlg=1) f434ae83-64f8-449e-a2fc-efb64c213f90

    07/11/2012 14:27:54.71  w3wp.exe (0x02BC)                        0x13C8 Project Server                 Queue                          8tfj Medium   PWA:https://server/PWA/XXX, ServiceApp:Project Server, User:xxx, PSI: [QUEUE] [PSI] GetJobCompletionState(884b1067-7da8-4547-a7e4-2926b4dbf6c4, out errorString) f434ae83-64f8-449e-a2fc-efb64c213f90

    07/11/2012 14:27:56.44  w3wp.exe (0x166C)                        0x114C SharePoint Foundation          Monitoring                     b4ly Medium   Leaving Monitored Scope (Request (GET:https://server:443/pwa/xxx/_layouts/PWA/Common/QueueErrorText.aspx?JobGuid=884b1067-7da8-4547-a7e4-2926b4dbf6c4&IsDlg=1)). Execution Time=2704.08082591503 f434ae83-64f8-449e-a2fc-efb64c213f90

    07/11/2012 14:59:01.16  w3wp.exe (0x02BC)                        0x2324 Project Server                 Queue                          8tfj Medium   PWA:https://server/PWA/XXX, ServiceApp:Project Server, User:XXX PSI: [QUEUE] [PSI] GetJobCompletionState(884b1067-7da8-4547-a7e4-2926b4dbf6c4, out errorString) 59873123-e587-446e-ae41-fac9ddc962d0

      .

    Wednesday, July 11, 2012 8:10 PM
  • Hey Bill,

    Was this project ever published before? If so, it may be that there's a problem with the published copy.

    Go into Server Settings, Delete Enterprise Objects and delete the project ONLY from the published store. Ensure you select the right radio button.

    Then attempt to republish the project.

    I've had this happen with a project recently and still not sure what happened.

    Thanks!

    Treb Gatte

    Thursday, July 12, 2012 3:12 AM
    Moderator