locked
"Welcome" screen takes too long when OFF domain RRS feed

  • Question

  • Hi there,

    In our company there are a few users that work on laptops.  These laptops have been joined to the domain.

    When these users login to their laptops while at work, connected to domain, login screen takes almost no time.

    When these users login from home, after putting in their credentials they are stuck for almost a minute (or more) on the "Welcome" screen before they get to their desktop.

    From my understanding, since these laptops are domain joined, they always look for an authentication server before granting access. Since the authentication server is not available when they are at home, it takes around 30 seconds for the "look up" to give up before resorting to cached credential. 

    Is there any way to eliminate this?

    I have tried editing the Local Policy on their laptops - but that did not have any affect. (One thing to note, these users are set as local profiles and not roaming)

    * enabled and set to 0 : Computer Configuration > Administrative Templates > System > User Profiles > Set Maximum wait time for the network if a user has a roaming user profile or remote home directory

    * disabled : Computer Configuration > Administrative Templates > System > Logon > Always wait for the network at computer startup and logon




    • Edited by Multra Wednesday, June 5, 2013 5:05 PM
    Wednesday, June 5, 2013 5:05 PM

Answers

  • Hi,

     

    In order to clarify the issue clearly, I would like to ask the following questions:

     

    Are there big files in the roaming profile? Will it take a long time if the you copy the profile to the client?

     

    Do all the Windows 7 clients and Windows 7 users meet this issue? Please check how it works if putting a clean installed Windows 7 computer to this domain and logon.

     

    This issue can be caused by several factors. I suggest refer to the following suggestions to troubleshoot:

     

    1. please refer to the following KB article to test the issue:

     

    The Welcome screen may be displayed for 30 seconds during the logon process after you set a solid color as the desktop background in Windows 7 or in Windows Server 2008 R2

     

    2. Please check the Group Policy:

     

    a. Go to Start, type Group Policy in the Search Box and then click Edit group policy.

    b. Expand the following item from the left pane:

     

       Computer Configuration -> Administrative Templates -> System -> Logon

     

    c. Double click "Always wait for network at computer startup and logon" setting on the right pane, choose Disable and then click OK.

    d. Expand the following item from the left pane:

     

       Computer Configuration -> Administrative Templates -> System -> User Profiles

    e. Double click "Delete cached copies of roaming profiles" setting on the right pane, choose Disable and then click OK.

     

    Please exit Group Policy Editor and check the result.

     

    3. Please boot the computer in Clean Boot for a test.

     

    Also, I suggest you contact the IT support to check the server settings.

     

    Regards,


    Vincent Wang
    TechNet Community Support

    Friday, June 7, 2013 6:42 AM

All replies

  • Hi,

     

    In order to clarify the issue clearly, I would like to ask the following questions:

     

    Are there big files in the roaming profile? Will it take a long time if the you copy the profile to the client?

     

    Do all the Windows 7 clients and Windows 7 users meet this issue? Please check how it works if putting a clean installed Windows 7 computer to this domain and logon.

     

    This issue can be caused by several factors. I suggest refer to the following suggestions to troubleshoot:

     

    1. please refer to the following KB article to test the issue:

     

    The Welcome screen may be displayed for 30 seconds during the logon process after you set a solid color as the desktop background in Windows 7 or in Windows Server 2008 R2

     

    2. Please check the Group Policy:

     

    a. Go to Start, type Group Policy in the Search Box and then click Edit group policy.

    b. Expand the following item from the left pane:

     

       Computer Configuration -> Administrative Templates -> System -> Logon

     

    c. Double click "Always wait for network at computer startup and logon" setting on the right pane, choose Disable and then click OK.

    d. Expand the following item from the left pane:

     

       Computer Configuration -> Administrative Templates -> System -> User Profiles

    e. Double click "Delete cached copies of roaming profiles" setting on the right pane, choose Disable and then click OK.

     

    Please exit Group Policy Editor and check the result.

     

    3. Please boot the computer in Clean Boot for a test.

     

    Also, I suggest you contact the IT support to check the server settings.

     

    Regards,


    Vincent Wang
    TechNet Community Support

    Friday, June 7, 2013 6:42 AM
  • Thanks Vincent,

    Sorry for the long delay.

    To answer your questions:

    This is not a roaming profile, it is local.

    it appears that all users that are not physically connected to network are experiencing this "Welcome" delay. However, if they were to physically connected to our network, the "Welcome" screen is not an issue. I have tried clean boot but it appears as if the computer (when not connected to domain) keep looking for the domain controller to authenticate.

    All computers are joined to the domain.

    I read through he KB you referenced - I do not have the background as solid.

    Also, I tried setting the Group Policy settings you suggested, with no luck:(

    Any suggestions what could be done on the domain controller server in  domain policy perhaps?

    Thursday, June 20, 2013 9:12 PM
  • any other ideas?

    Thank you,

    Wednesday, July 17, 2013 12:08 AM