DPM 2012 Reports Error 3012 RRS feed

  • Question

  • Hello,

    I have a DPM 2012 which has been upgraded from DPM 2010. Previously I had reports working correctly, but now from the console, when I click on any default report I get this message:

    "DPM cannot perform this action because no valid property settings have been detected for this report"

    Error ID: 3012I have followed the steps at to reinstall DPM, but it still fails. If I access the reports directly using a browser pointing to http://[server]/ReportServer_MSDPM2012 I see some reports, but I'm not sure if are the same as the ones published at the console.

    Any idea of where to start looking to get this solved?


    Monday, September 17, 2012 12:27 PM

All replies

  • Hello

    I had a similar issue but with SCCM and the way i fixed it was to login to the brower and then change the datasource on each report. This is quite pain staking, hopefully a "global" fix will help.

    If you open SQL reporting services is it pointing to the old DPM server? 

    Open SQL Server reporting Manager
    Under Reporting Services Configuration Connection windows, CHange Report Server Instance to MSDPM2012

    Monday, September 17, 2012 3:55 PM
  • Hi

    I've checked and the report server instance is MSDPM2012. In fact, the old MSDPM2010 is no longuer there.

    I've checked also the report's config and all are pointing to a "/DPMReports/DPMReporterDataSource" datasource which is setup to use the MSDPM2012 instance. In fact, if I execute the report directly from SQL Reporting I do get valid data (but I don't know how to give parameters to those reports). The problem only arises when trying to access the reports from the DPM console, both local and remote.

    Also, If I just click again on the report I can generate it from the console, but all parameters (granilarity, period, etc) are greyed out and I can't give any parameter...


    Tuesday, September 18, 2012 12:24 PM
  • did you solve your Problem?

    Seidl Michael | | |

    Monday, September 15, 2014 5:53 AM