locked
Content DB is not showing up old sites after restoration on SharePoint 2007 RRS feed

  • Question

  • I followed in below steps, but nothing is coming out of the site.

         To restore the content db as a different name

    a.        Create a new Web App as a test

    b.       Central Admin->Application Management->Create or extend Web App->Create New Web App.

    c.        Remove Content Database from your new web app.

    d.       Associate restored DB with new Web App

    e.       Central Admin->Application Management->SharePoint Web Application Management->Content Databases->

    f.         use STSADM to add restored DB to this web app

                                    c:\program files\common files\microsoft shared\web server extentions\12\bin

                                    run this command from there.

                                    stsadm -o addcontentdb -url http://yourwebapp:port -databasename yourcontentdb -databaseserver yoursqlserver

                                  


    Santosh Singh

    Thursday, July 28, 2016 5:38 PM

All replies

  • Hi Santosh,

    yes the same restored name. It should work.

    https://alkalony.wordpress.com/2009/08/25/add-existing-content-database-to-a-site-collection-using-stsadm/

    https://alkalony.wordpress.com/2009/08/25/add-existing-content-database-to-a-site-collection-using-stsadm/


    Please remember to click 'Mark as Answer' on the answer if it helps you

    Thursday, July 28, 2016 6:30 PM
  • Hi Santosh

    What was the output of the stsadm -o addcontentdb ? Also, what is the output of stsadm -o enumsites? Can you try to addcontentdb with -assignnewdatabaseid parameter and then let us know if it helps.


    Thanks
    Mohit


    • Edited by mohit.goyal Thursday, July 28, 2016 6:33 PM
    Thursday, July 28, 2016 6:32 PM
  • Hi Mohit,

    stsadm -o addcontentdb

    Output of this was completed successfully no error.

    stsadm -o enumsites

    It shows three sites, but these sites are something which we are not looking for. Everything is going very clean, no error any where. Not sure why there is nothing coming up.

    Hi Lakshmanan, still checking on your documents.


    Santosh Singh

    Thursday, July 28, 2016 7:44 PM
  • Hi Santosh,

    Did you try attaching the content database to the old web app?

    Regards,

    Simran

    Thursday, July 28, 2016 8:07 PM
  • Hi Santosh

    Have you tried adding contentdb with new id and then observe results?


    Thanks
    Mohit

    Friday, July 29, 2016 4:38 AM
  • Hi Lakshmanan, it didn't work for me.

    Simran- Old is prod farm and I can't do that there.

    Mohit- I have tried adding contentdb with new name and id too.

    Not sure what exactly going on..


    Santosh Singh

    Friday, July 29, 2016 6:09 PM
  • Hi Santosh

    Since attached database shows 3 sites, i wont assume there is something wrong with database restore or schema. How many sites are there in the original database? Also make sure, new web application has different public url and corresponding managed paths are in place.


    Thanks
    Mohit


    • Edited by mohit.goyal Saturday, July 30, 2016 5:32 AM
    Saturday, July 30, 2016 5:31 AM
  • There are 9 sites on prod database.

    Santosh Singh

    Saturday, July 30, 2016 12:00 PM
  • Hi Santosh

    Do you have corresponding managed paths in place?


    Thanks
    Mohit

    Saturday, July 30, 2016 2:06 PM
  • Hi  All,

    Sorry for late response.

    I have lately found which I should have 1st thing though, that sharepoint version got  updated with cu update on test\UAT server and prod was with just SP2, like:

    UAT

    Version: 12.0.0.6535

    Prod

    Version: 12.0.0.6421

    Also, config database was on SQL Server 2005 and content databases were on SQL Server 2008 R2.

    We had big challenges downgrading UAT as of now, where we needed to restore and attach DB to new web application.

    Hopefully you agree that we don't have option now to recover data too.

    If you all  agree we can close this thread, thanks a ton for yours all support on this!!


    Santosh Singh

    Tuesday, August 9, 2016 2:10 PM