none
Has Anyone Any Advice On Getting Visio Viewer 2003 or 2007 Working on Windows Vista 64-Bit with Internet Exporer 8?

    Question

  • Has Anyone Any Advice On Getting Visio Viewer 2003 or 2007 Working on Windows Vista 64-Bit with Internet Exporer 8?

    My boss has given me a Visio document created in Visio 2002.  (That version number is according to him.  I'm unaware of a way of verifying that from the file itself.)  Although I have Office Professional 2007 installed on my PC, I do not have Visio.    I installed Visio Viewer 2007 from the Microsoft Download center.  After installing, I tried opening that VSD document.  No luck.  Internet Explorer opens but blocks the content.  When I choose, "Allow Blocked Content", the document does not open and a "broken image" icon displays in the browser window.

    I then thought maybe I needed an update.  So I used Microsoft Update and sure enough there was a service pack for Visio Viewer 2007.   I installed Visio Viewer SP2 using Microsoft Update.  No help.  Same results.  (Note: My PC was up-to-date with all other Microsoft Updates.)

    I then searched for help at the Microsoft site.  Even though Visio 2002 has never been installed on this PC, I tried the steps in http://support.microsoft.com/kb/926948.  That is, I tried uninstalling Visio Viewer 2007 and installing the 2003 version instead.  No help.  The result is the same.  I tried modifying the registry as described.  Same result. 

    I could find no other advice at microsoft.com.

    Please help. 

    Other Information:
    Office Professional 2007 installed and it is working normally with all updates as of 10/19/2009
    Windows Vista Business 64-Bit with all updates as of 10/19/2009
    Internet Explorer 8 with any updates as of 10/19/2009
    I tried rebooting several times
    Each time Visio Viewer was installed by the Administrator account. 
    It does not help to open the file with a the Administrator or my Normal User account
    Tuesday, October 20, 2009 2:36 AM

Answers

  • I have the exact same behavior:  Windows 7 Pro (32 bit) with IE8 (all updates as of 26 Oct. 2009), Visio Viewer 2007 w/SP2.   I get the same red X broken image icon.

    ========================================

    UPDATE:  I have fixed the problem.
    After installing Visio Viewer 2007 and SP2 for Visio Viewer 2007, install (re-install) KB973709.
    After that update is re-installed, it works properly for me.

    ========================================
    • Proposed as answer by CCI_Dave Tuesday, October 27, 2009 2:11 PM
    • Marked as answer by David Wolters Wednesday, June 22, 2011 3:46 PM
    Tuesday, October 27, 2009 2:02 PM

All replies

  • I have, what looks like, the same issue. The only difference is that whe I installed the plugin a few weeks ago it did display visio docs in IE7. I am not sure what the user has done but now it does not work. After allowing the blocked content, we get the broken image icon. I have disabled all non essential add-ons but no result.

    Cheers,

    csimg
    Tuesday, October 20, 2009 12:53 PM
  • Does anyone have a Vista or XP computer with all of the Microsoft Security Updates installed where Visio Viewer isn't broken?
    If not, there is probably a problem update.

    Tuesday, October 20, 2009 10:04 PM
  • I have the exact same behavior:  Windows 7 Pro (32 bit) with IE8 (all updates as of 26 Oct. 2009), Visio Viewer 2007 w/SP2.   I get the same red X broken image icon.

    ========================================

    UPDATE:  I have fixed the problem.
    After installing Visio Viewer 2007 and SP2 for Visio Viewer 2007, install (re-install) KB973709.
    After that update is re-installed, it works properly for me.

    ========================================
    • Proposed as answer by CCI_Dave Tuesday, October 27, 2009 2:11 PM
    • Marked as answer by David Wolters Wednesday, June 22, 2011 3:46 PM
    Tuesday, October 27, 2009 2:02 PM
  • I followed this advice and the user was able to open Visio documents using the 2007 Viewer.  We are using XPSP2 with IE7 so the ActiveX security dropdown information bar still appears, but after clicking yes, the Visio document displays normally again.    Thank you CCI_Dave!
    Thursday, November 05, 2009 8:40 PM
  • This hint helps me and save me a lot of time
    • Proposed as answer by legendmboro Tuesday, November 10, 2009 8:07 PM
    Tuesday, November 10, 2009 8:07 PM
  • After reading this I dug deeper into IE security settings.  Running Vista with IE 8.  Had same issue previously stated.  Noticed in the bottom of IE window it said I had Restricted Site settings.  Double clicked on it.  Settings were set at HIGH.  I went in Custom Level and clicked all the Active X ones that I could find and chose "Prompt".  Saved settings and went out.  Refreshed the page and problem solved.  Now need to see where security should be since it is warning of security risks.
    • Proposed as answer by maltballs101 Saturday, November 14, 2009 4:22 PM
    Saturday, November 14, 2009 4:21 PM
  • After several hours of looking for the solution, this is the one that worked. I wish MS had it on their proposed solution.

    Thanks!
    Thursday, November 19, 2009 10:33 PM
  • If you remove KB973525 this will fix the problem. I had the problem myself and this was the fix.
    Wednesday, December 09, 2009 4:52 AM
  • CCI_Dave thanks! I spent lots of time to figure it out... It works! 2 mins and done!
    Monday, January 18, 2010 6:55 PM
  • Thanks Dave, this saved me a lot of time!
    Friday, May 14, 2010 1:30 AM
  • Thanks, Dave!  Worked like a champ.  Windows 7 64bit with IE8.
    Thursday, December 02, 2010 3:53 PM
    • Edited by Kodiyan Sunday, April 29, 2012 10:41 PM
    Tuesday, June 21, 2011 7:17 PM