none
Hyper-V Nodes Flap when Adding a new VLAN

    Question

  • I followed the recommended guide for creating NIC teaming and VLAN from this post.
    https://blogs.technet.microsoft.com/keithmayer/2012/11/20/vlan-tricks-with-nics-teaming-hyper-v-in-windows-server-2012/

    It is a very simple setup on the switch

    interface port 1:3
            description "GSPRDHV01"
            switchport mode trunk
            exit

    interface port 2:3
            description "GSPRDHV01"
            switchport mode trunk
            exit

    ----------------------------------

    Everytime I create a brand new VLAN on the Switches (which has similar commands to Cisco) and Apply the configuration for e.g. VLAN 192, the Hyper-V Nodes has a high rate of timeouts, However the VM's are not affected, just the Hyper-V Nodes

    (Which causes terrible connection to my DR Site for Hyper-V replica)

    Pinging HyperVNode5.lm.local [10.9.224.55] with 32 bytes of data:

    Reply from 10.9.224.55: bytes=32 time=5ms TTL=123
    Reply from 10.9.224.55: bytes=32 time=6ms TTL=123
    Request timed out.
    Reply from 10.9.224.55: bytes=32 time=6ms TTL=123
    Reply from 10.9.224.55: bytes=32 time=5ms TTL=123
    Request timed out.
    Reply from 10.9.224.55: bytes=32 time=5ms TTL=123
    Request timed out.
    Request timed out.
    Reply from 10.9.224.55: bytes=32 time=5ms TTL=123
    Reply from 10.9.224.55: bytes=32 time=5ms TTL=123

    So in a nutshell

    1. Pings from Internally with one another is fine
    2. Pings to virtual machine hosted on the Node are fine
    3. Pings from outside the WAN into the Node - FAILS
    4. I suspect the Issue lies on the LACP between the Switch and the Gateway but that is stab in the dark.

    What am I doing wrong here :((( ???


    Sunday, January 22, 2017 11:53 PM

All replies

  • I forgot to mention, that I also have LACP Configured from the Switch into the Router Gateway

    Juniper SRX

    }
    ge-0/0/1 {
    gigether-options {
    802.3ad ae0;
    }
    }
    ge-0/0/2 {
    gigether-options {
    802.3ad ae0;
    }
    ae0 {
    aggregated-ether-options {
    lacp {
    active;
    }
    }
    unit 0 {
    family inet {
    address 10.98.204.141/30;
    address 10.102.0.2/29 {
    primary;

    Switch

    interface port 1:47
    lacp mode active
    lacp key 12000

    interface port 2:47
    lacp mode passive
    lacp key 12000
    !
    vlan 102
    name "Gateway"
    !
    interface port 2:47
    description "WAN2"
    switchport access vlan 102
    exit
    !
    interface port 1:47
    description "WAN1"
    switchport access vlan 102
    exit
    !
    interface ip 102
    ip address 10.102.0.1 255.255.255.248
    vlan 102
    enable
    exit
    !

    Monday, January 23, 2017 12:06 AM
  • Hi Xenty,

    >>Everytime I create a brand new VLAN on the Switches (which has similar commands to Cisco) and Apply the configuration for e.g. VLAN 192, the Hyper-V Nodes has a high rate of timeouts,

    Does the phenomenon only last for a few minutes or always the same?

    Have you tried to update the NIC driver?

    According to the ping results, I suppose the configuration on the server is correct.

    >>I suspect the Issue lies on the LACP between the Switch and the Gateway but that is stab in the dark

    You may consult the technical support of the network devices for help.

    Best Regards,

    Leo


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, January 23, 2017 3:08 AM
    Moderator
  • it lasts forever, I am unable to identify why this is happening, no errors or flapping logs anywhere....
    Not sure if the configuration is correct or not, need another pair of eyes to check if this is correct...

    Monday, January 23, 2017 3:51 AM
  • Hi Xenty,

    This forum is for Hyper-V, I suggest you post in network forums  for better help about the issues of network configurations.

    Best Regards,

    Leo


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, January 23, 2017 7:00 AM
    Moderator
  • Hi,
    Are there any updates on the issue?
    You could mark the reply as answer if it is helpful.
    Best Regards,
    Leo

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, February 7, 2017 2:10 AM
    Moderator