none
Export to Excel Error (Project Server 2010) RRS feed

  • Question

  • Hi there,

    I have a problem with the ressource availability chart. When I open the Ressource Center and check some ressources to view their availibility, I get the chart and the details table. Now I want to export this to excel (Excel 2010) and get the File Download dialog. If I click Save I get this error: "Unable to download ResAvailability.aspx from project.mydomain.com". If I click Open Excel asks for my credentials and don´t accept these, after a few tries a message comes up: "Could not open https://project.mydomain.com/blabla/ResAvailability.aspx". After closing a second message asserts the path is not correct, the file is used by another program or the workbookname already exists.

    I don´t know what to do know, has anyone an idea how to get this working?

    Best regards

    Sascha

    Wednesday, August 11, 2010 12:31 PM

Answers

  • Hi Sacha,

    I found a documented workaround - but my first attempt didn't work so wasted a few cycles.  The KB at http://support.microsoft.com/kb/323308 - Internet Explorer file downloads over SSL do not work with the cache control headers - does apply to this issue.  The workaround given for IE 8 (which I am using) is at the foot of that KB:

    Internet Explorer 7 and Internet Explorer 8

    To resolve this issue in Internet Explorer 7 and in Internet Explorer 8, follow these steps:

    1. Start Registry Editor.
    2. For a per-user setting, locate the following registry key:
      HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings
      For a per-computer setting, locate the following registry key:
      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings
    3. On the Edit menu, click Add Value.
    4. To override the directive for HTTPS connections, add the following registry value:
      "BypassSSLNoCacheCheck"=Dword:00000001
      To override the directive for HTTP connections, add the following registry value:
      "BypassHTTPNoCacheCheck"=Dword:00000001
    5. Quit Registry Editor.

    In my testing the per-computer settings did not work - but the per-user ones did.  See the KB, and other related KB's this one refers to for more context, but basically the issue is reading the saved local files that are downloaded via SSL.

    Best regards,

    Brian.


    Blog | Facebook | Twitter | Posting is provided "AS IS" with no warranties, and confers no rights.
    Project Server TechCenter | Project Developer Center | Project Server Help | Project Product Page
    Wednesday, August 18, 2010 3:33 PM
    Owner

All replies

  • Hi Sascha,

    This may be IE settings stopping this opening.  What zone is PWA in, and what settings do you have for the Downloads section in this zone?  I am also aware of some issues with SSL and reading cached temporary internet files which can block Office application downloads - http://support.microsoft.com/kb/323308 but this doesn't feel like the same issue.

    Best regards,

    Brian


    Blog | Facebook | Twitter | Posting is provided "AS IS" with no warranties, and confers no rights.
    Project Server TechCenter | Project Developer Center | Project Server Help | Project Product Page
    Wednesday, August 11, 2010 9:29 PM
    Owner
  • Hi Brian,

    sorry, I forgot to mention that my PWA site is in the local intranet zone and all Download settings are enabled. I tried the registry fixes described in the KB, because the error message sounds similar :) but that didn´t change anything, same errors.

    Additional Info:

    The Project Server 2010 is installed on SharePoint Server 2010 on Win Server 2008 R2 with IIS 7.5 using hostheader project.mydomain.com.

    Edit:

    I took a look in the IIS Logs and the problem seems that Project Server wants to give me the File over http on port 80, that results in 3 times error 401 and after that 404, because no http is configured.

    With this I think it´s a configuration thing on Project Server but where?

    Best regards,

    Sascha

    Thursday, August 12, 2010 6:09 AM
  • Hi Sacha,

    I'm wondering if Alternate Access Mappings aren't there for the path Excel is trying to open from - but not sure why it would be trying port 80 if the site was 443.  I'll see if I can repro.

    Best regards,

    Brian.


    Blog | Facebook | Twitter | Posting is provided "AS IS" with no warranties, and confers no rights.
    Project Server TechCenter | Project Developer Center | Project Server Help | Project Product Page
    Thursday, August 12, 2010 5:42 PM
    Owner
  • AAMs are configured correctly, on Central Admin side the PWA application is also shown with the correct URL (https://project.mydomain.com/pwa)
    Friday, August 13, 2010 9:37 AM
  • Strange - I am sure I replied on Friday Sacha....  It will probably be on some other thread.  I have a repro when opening from https://fqdn/pwa so will now try and find a solution...

    Best regards,

    Brian.


    Blog | Facebook | Twitter | Posting is provided "AS IS" with no warranties, and confers no rights.
    Project Server TechCenter | Project Developer Center | Project Server Help | Project Product Page
    Monday, August 16, 2010 11:23 PM
    Owner
  • Ah thanks, I hope it isn´t a very big thing :)
    Tuesday, August 17, 2010 5:45 AM
  • Hi Sacha,

    I found a documented workaround - but my first attempt didn't work so wasted a few cycles.  The KB at http://support.microsoft.com/kb/323308 - Internet Explorer file downloads over SSL do not work with the cache control headers - does apply to this issue.  The workaround given for IE 8 (which I am using) is at the foot of that KB:

    Internet Explorer 7 and Internet Explorer 8

    To resolve this issue in Internet Explorer 7 and in Internet Explorer 8, follow these steps:

    1. Start Registry Editor.
    2. For a per-user setting, locate the following registry key:
      HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings
      For a per-computer setting, locate the following registry key:
      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings
    3. On the Edit menu, click Add Value.
    4. To override the directive for HTTPS connections, add the following registry value:
      "BypassSSLNoCacheCheck"=Dword:00000001
      To override the directive for HTTP connections, add the following registry value:
      "BypassHTTPNoCacheCheck"=Dword:00000001
    5. Quit Registry Editor.

    In my testing the per-computer settings did not work - but the per-user ones did.  See the KB, and other related KB's this one refers to for more context, but basically the issue is reading the saved local files that are downloaded via SSL.

    Best regards,

    Brian.


    Blog | Facebook | Twitter | Posting is provided "AS IS" with no warranties, and confers no rights.
    Project Server TechCenter | Project Developer Center | Project Server Help | Project Product Page
    Wednesday, August 18, 2010 3:33 PM
    Owner
  • Thank you very much for your research! The per-computer settings didn´t work for me either, per-user works fine :)

    Best regards

    Sascha

    Wednesday, August 18, 2010 5:40 PM
  • Hi

    We have a customer on W7 SP1 (downgraded to IE8), Office 2010 SP2. They are getting this error opening ResAvailability.aspx but otherwise downloading / exporting works normally.

    Applying the Registry Value above does not resolve the issue (either per-computer or per-user) - could anyone suggest why or suggest further diagnostic steps?

    Thanks for any assistance

    Paul

    Friday, October 4, 2013 3:02 PM