none
Exception starting workflow while creating new project RRS feed

  • Question

  • We created a new SharePoint Designer based workflow and published it to Project Online.

    Later we created new EPT and associated the above mentioned workflow to it.

    Now whenever we tried creating a new project based on this EPT, it fails with an error as mentioned below:

    "Your new EPT has been created successfully, but failed to publish and will not be listed in the Project Error".

    Looking at the queue jobs, I see below errors. Does anyone how to solve this issue?

    General
    • Exception Starting Workflow: Workflow _c78ab50f-a884-47d0-98bb-a9e6e5eab058_, for scope _/spo/b2645c43-2431-4498-aa01-367736a9461e/822d4328-2ebd-41fd-b9df-51a1cc138781/88697637-7217-40cc-b4db-be9e0cf8582e_, was not found. HTTP headers received from the server - ActivityId: 959408f6-002a-4b62-8368-997e74f55174. NodeId: . Scope: . Client ActivityId : d84a129c-99cc-6054-2a55-5ec692cb26fe.. Trace: at Microsoft.Workflow.Client.ClientHelpers.SendRequest[T](HttpWebRequest request, T content) at Microsoft.Workflow.Client.WorkflowManager.StartInternal(String workflowName, WorkflowStartParameters startParameters) at Microsoft.SharePoint.WorkflowServices.FabricWorkflowManagementClient.StartInstance(String serviceGroupName, String workflowName, String monitoringParam, String activationKey, IDictionary`2 payload) at Microsoft.SharePoint.WorkflowServices.FabricWorkflowInstanceProvider.StartWorkflow(WorkflowSubscription subscription, IDictionary`2 payload) at Microsoft.Office.Project.Server.BusinessLayer.Workflow.StartWorkflow(Guid projectGuid, Guid enterpriseProjectTypeUid, Boolean isNewProject, Guid previousEntepriseProjectTypeUid, Boolean skipStage, Guid stageToSkipTo):
      • WorkflowExceptionStartingWorkflow (35115). Details: id='35115' name='WorkflowExceptionStartingWorkflow' uid='925896db-84a6-e211-915a-00155d855c0e'.
    • Error:
      • WorkflowCannotStartWorkflow (35100). Details: id='35100' name='WorkflowCannotStartWorkflow' uid='935896db-84a6-e211-915a-00155d855c0e'.
    • Queue:
      • GeneralQueueJobFailed (26000) - WorkflowStartWorkflow.WorkflowStartWorkflowMessage. Details: id='26000' name='GeneralQueueJobFailed' uid='945896db-84a6-e211-915a-00155d855c0e' JobUID='9f1a80d7-84a6-e211-9b9d-00155d85170c' ComputerName='b5274f0d-31e4-406a-9540-8bc9ee3f62f1' GroupType='WorkflowStartWorkflow' MessageType='WorkflowStartWorkflowMessage' MessageId='1' Stage='' CorrelationUID='d84a129c-99cc-6054-2a55-5ec692cb26fe'. For more details, check the ULS logs on machine b5274f0d-31e4-406a-9540-8bc9ee3f62f1 for entries with JobUID 9f1a80d7-84a6-e211-9b9d-00155d85170c.
    
    
    <input accesskey="c" id="CancelButton" style="padding:7px 10px;border:1px solid rgb(171, 171, 171);color:#444444;font-family:'Segoe UI', Segoe, Tahoma, Helvetica, Arial, sans-serif;font-size:11px;margin-left:10px;vertical-align:middle;min-width:6em;background-color:#fdfdfd;" type="button" value="Close" />
    Tuesday, April 16, 2013 11:39 AM

Answers

All replies

  • Hi Jogeshkumar Makwana, we are currently investigating a very similar issue that is affecting a few other tenants.  I will need more information from you and might be best to take this offline.  You can contact me at brian.smith@microsoft.com - or if that gets stripped out of my post use the e-mail blog author link http://blogs.msdn.com/brismith.  I will be needing your Project Online tenant Url.

    Sorry for the inconvenience and we hope to get this addressed shortly.

    Best regards,

    Brian. 


    Blog | Facebook | Twitter | Posting is provided "AS IS" with no warranties, and confers no rights.
    Project Server TechCenter | Project Developer Center | Project Server Help | Project Product Page

    Tuesday, April 16, 2013 2:19 PM
    Owner
  • Has there been any update on this? Since today I have it too. I was able to create projects with simple workflows yesterday, but not today?

    I get this:

    General
    • Exception Starting Workflow: Workflow _ee038ab6-e3e1-4103-9c9f-eb1e34051e03_, for scope _/spo/68c4496a-d2a8-44af-9ff1-cbe0128a80a2/9c9ff6c2-baac-4268-9698-15f0e991bd2a/82440e58-df26-4089-ade6-6f1bc4644c3b_, was not found. HTTP headers received from the server - ActivityId: 07317e81-c57d-4eb2-888c-0d17451a35f9. NodeId: . Scope: . Client ActivityId : 08a8209c-7064-f0ac-d588-023a72c8ddd0.. Trace:    at Microsoft.Workflow.Client.ClientHelpers.SendRequest[T](HttpWebRequest request, T content)   at Microsoft.Workflow.Client.WorkflowManager.StartInternal(String workflowName, WorkflowStartParameters startParameters)   at Microsoft.SharePoint.WorkflowServices.FabricWorkflowManagementClient.StartInstance(String serviceGroupName, String workflowName, String monitoringParam, String activationKey, IDictionary`2 payload)   at Microsoft.SharePoint.WorkflowServices.FabricWorkflowInstanceProvider.StartWorkflow(WorkflowSubscription subscription, IDictionary`2 payload)   at Microsoft.Office.Project.Server.BusinessLayer.Workflow.StartWorkflow(Guid projectGuid, Guid enterpriseProjectTypeUid, Boolean isNewProject, Guid previousEntepriseProjectTypeUid, Boolean skipStage, Guid stageToSkipTo):
      • WorkflowExceptionStartingWorkflow (35115). Details: id='35115' name='WorkflowExceptionStartingWorkflow' uid='6a415759-96c9-e211-8076-00155d987b12'.
    • Error:
      • WorkflowCannotStartWorkflow (35100). Details: id='35100' name='WorkflowCannotStartWorkflow' uid='6b415759-96c9-e211-8076-00155d987b12'.
    • Queue:
      • GeneralQueueJobFailed (26000) - WorkflowStartWorkflow.WorkflowStartWorkflowMessage. Details: id='26000' name='GeneralQueueJobFailed' uid='6c415759-96c9-e211-8076-00155d987b12' JobUID='b2af9253-96c9-e211-b137-00155d987314' ComputerName='09c6345c-04e8-4611-9fe7-b45e66936f28' GroupType='WorkflowStartWorkflow' MessageType='WorkflowStartWorkflowMessage' MessageId='1' Stage='' CorrelationUID='08a8209c-7064-f0ac-d588-023a72c8ddd0'. For more details, check the ULS logs on machine 09c6345c-04e8-4611-9fe7-b45e66936f28 for entries with JobUID b2af9253-96c9-e211-b137-00155d987314.
    
    
                 <input accesskey="o" id="ctl00_ctl00_PlaceHolderMain_idOkButton" name="ctl00$ctl00$PlaceHolderMain$idOkButton" style="display:none;" type="button" value="OK" />             <input accesskey="c" id="CancelButton" type="button" value="Close" />          


     

     

    Friday, May 31, 2013 2:09 AM
  • Hi,

    I received the same error. The only difference is that i use project server 2013 not project online.

    I got this error today:

     

    Exception Starting Workflow: The scope _/SharePoint/default/f37b5a6b-8e39-4d21-a8ac-98ede3695bf4/9020d98f-c26c-4c03-816a-67b611c89827_ has no workflows under it. HTTP headers received from the server - ActivityId: 669f35b6-bc48-488b-97a1-e6a270a8c16d. NodeId: INTVSPAPP2. Scope: /SharePoint/default/f37b5a6b-8e39-4d21-a8ac-98ede3695bf4/9020d98f-c26c-4c03-816a-67b611c89827. Client ActivityId : 73042b9c-e7c8-3071-3753-418130569b34.. Trace: at Microsoft.Workflow.Client.ClientHelpers.SendRequest[T](HttpWebRequest request, T content) at Microsoft.Workflow.Client.WorkflowManager.StartInternal(String workflowName, WorkflowStartParameters startParameters) at Microsoft.SharePoint.WorkflowServices.FabricWorkflowManagementClient.StartInstance(String serviceGroupName, String workflowName, String monitoringParam, String activationKey, IDictionary`2 payload) at Microsoft.SharePoint.WorkflowServices.FabricWorkflowInstanceProvider.StartWorkflow(WorkflowSubscription subscription, IDictionary`2 payload) at Microsoft.Office.Project.Server.BusinessLayer.Workflow.StartWorkflow(Guid projectGuid, Guid enterpriseProjectTypeUid, Boolean isNewProject, Guid previousEntepriseProjectTypeUid, Boolean skipStage, Guid stageToSkipTo):

     WorkflowExceptionStartingWorkflow

    <dir><dir>

    (35115). Részletek: id='35115' name='WorkflowExceptionStartingWorkflow' uid='7704cdfa-e1e2-e211-93fe-00155dfb8fe9'.

    </dir></dir>

    Error:

    <dir><dir>

    WorkflowCannotStartWorkflow

    </dir></dir>
    <dir><dir>

    (35100). Részletek: id='35100' name='WorkflowCannotStartWorkflow' uid='7804cdfa-e1e2-e211-93fe-00155dfb8fe9'.

    </dir></dir>

    Queue:

    <dir><dir>

    GeneralQueueJobFailed

    </dir></dir>
    <dir><dir>

    (26000) - WorkflowStartWorkflow.WorkflowStartWorkflowMessage. Részletek: id='26000' name='GeneralQueueJobFailed' uid='7904cdfa-e1e2-e211-93fe-00155dfb8fe9' JobUID='bac5e7f9-e1e2-e211-9402-00155dfb493e' ComputerName='bc3276c9-1f5b-4e85-8895-630e714de654' GroupType='WorkflowStartWorkflow' MessageType='WorkflowStartWorkflowMessage' MessageId='1' Stage='' CorrelationUID='73042b9c-e7c8-3071-3753-418130569b34'. További részleteket a(z) bc3276c9-1f5b-4e85-8895-630e714de654 gép általános naplózási szolgáltatásának naplóiban talál a JobUID bac5e7f9-e1e2-e211-9402-00155dfb493e bejegyzéseinél

    </dir>
    </dir>
    Tuesday, July 2, 2013 6:44 AM
  • Hi,

    I just came across this post here looking for a solution. But I figured it out and want to share it with you.

    I had that error message with a Project Server 2013 on prem installation. In my case the issue occurred after I tried to apply the March PU to Project and the CU to Workflow Manager. But the Workflow Farm was configured before the Workflow Manager CU was applied.

    Resolution:

    • Deinstalled Workflow Manager, Workflow Client, Service Bus, Windows Fabric and deleted all WF and SB databases -> farm was removed completely from the SharePoint Installation
    • Applied March PU to Project/SharePoint farm
    • Installed Workflow Manager with all Dependencies, applied CU for Service Bus and Workflow Manager
    • Configured Workflow farm

    No my workflows are running fine again. According to TechNet deinstalling Workflow Manager is the only way to remove an existing workflow farm

    Regards,
    Markus

    Tuesday, August 13, 2013 8:58 PM
    Moderator
  • Hi,

    We need to know the resolution if it has been resolved.

    Thank you in advance.


    Tanzim Akhtar

    Monday, September 16, 2013 12:32 PM
  • Hello,

    I restarted the Workflow Backend Service and the above mentioned problem was resolved.

    Following is what I did:

    1. Run CMD runas Administrator
    2. Type "net stop workflowbackendservice" without quotes
    3. After stopping the service successfully, type "net start workflowbackendservice" without quotes
    4. Create a new project with the workflow associated EPT and it created the project successfully and not Queue errors.

    Regards

    Tanzim


    Tanzim Akhtar

    Tuesday, September 17, 2013 1:05 PM
  • Hi, 

    Was there ever a resolution to this issue?  I am currently facing the same issue.  Workflow was working just yesterday.  Restarted the app & web front ends.  Republished the workflow. Reassigned it to EPTs.  Not finding any helpful next steps or resolutions.  

    Friday, September 26, 2014 7:05 PM
  • Hi all,

    I just experienced this on a Project Online instance.  In my case, the cause <appears> to be using a Default value in a custom field.  The field was set up as a choice list with a default value.  When I updated the values instead of accepting the default, it worked ok.  If I left the values, it failed.  I then reset the Custom Field to have no default value and when I created a new project, with no update to that field it worked ok.

    Regards,

    Ian

    Friday, May 27, 2016 3:40 AM