none
Hyper-V Manager on Windows 10 (domain) doesn't display Hyper-V settings of remote 2016 host (workgroup)

    Question

  • I followed the instructions on this page technet.microsoft.com/en-us/windows-server-docs/compute/hyper-v/manage/remotely-manage-hyper-v-hosts#connect-to-a-windows-2016-or-windows-10-remote-host-outside-your-domain-or-with-no-domain.

    I'm connecting to a 2016 Hyper-V core host (workgroup) from a Windows 10 pro client (domain).

    I am able to manage the 2016 Hyper-V server with powershell from the Windows 10 client. (Enter-PSSession)

    I can see/manage the Hyper-V server in Server Manager on the Windows 10 client.

    If I right-click the Hyper-V server in Server Manager and select Hyper-V Manager, it launches an empty Hyper-V Manager.

    If I "Connect to Server…" and enter invalid credentials, I do receive an error "You do not have the required permission to complete this task. Contact the administrator of the authorization policy for the computer".

    If I "Connect to Server…" and enter valid credentials, I receive no feedback, the window remains blank and nothing happens.

    This was working from a local user account on the windows 10 PC before I joined it to a domain, it doesn't work regardless of whether I'm logged into the windows 10 machine as a local user or a domain user.

    Any troubleshooting tips would be greatly appreciated.

    Wednesday, April 05, 2017 8:33 PM

All replies

  • I have set the TrustedHosts as you suggested (I tried fqdn and wildcards).

    When I right-click server and select Hyper-v has the same results (Hyper-V manager displays no hosts).


    • Edited by unclespeedo Wednesday, April 05, 2017 8:53 PM
    Wednesday, April 05, 2017 8:53 PM
  • Hi unclespeedo,

    Just to check if you got any progress with your issue? If still not, you may open a case with MS for more professional help:

    https://support.microsoft.com/en-us/gp/support-options-for-business

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, April 20, 2017 7:49 AM
    Moderator
  • Hello did you get anywhere with this? Have tried all steps you've detailed and my scenario is exactly as you described - attempting to connect through Hyper-V Manager as any user just does nothing, no feedback at all. Have tried logging in to domain joined PC as local user but same thing happens. Any help much appreciated.
    Monday, November 27, 2017 5:07 PM