locked
Spell check not working on Outlook.com RRS feed

  • Question

  • Hi

    Using Windows 10 Ent x64, have IE 11 installed.  Spellchecker is working on all sites with outlook.com being the exception.

    gone into settings and turned on the items under typing.

    tried under inprivate browsing and still not working.

    reset IE and again it makes no difference.

    Any idea what else I could try?

    thanks

    Jason

    Monday, April 25, 2016 12:40 PM

Answers

  • Managed to fix this.

    Was browsing the network tab on F12 tools and noticed 5 errors, all were items that had failed to run, to do with office and ending in .js

    So I installed Java from java.com and the spell checker in outlook.com started working again. 

    Super odd seeing as none of the other machines here have Java installed.

    fixed now though.

    Monday, May 23, 2016 1:19 PM

All replies

  • Hi,

    assuming you mean that at outlook.com, the spell-checker does not appear to be working when you create new message or edit an existing one. That is you do not see mis-spelt words in your language underlined..

    Could you please provide a screen shot of the context menu options that appear when you right click on a misspelt word.... the spell checking context menu only appears on misspelt words, not on blank spaces.

    To make sure that you have installed the language pack (includes the spell-checking dictionaries)

    Start>Settings>Time & Language>Region and Language

    Select the Language that you want to use spell-check with and click the Options button to display the options and optional downloads (spell checker dictionary/speech) for that language. Click the button to download the full Language pack for that language and keeping the settings dialog open wait until the download has completely finished..... you may have to restart your computer for the full changes to take affect.

    Regards.

    Questions regarding Internet Explorer 8, 9 and 10 and Internet Explorer 11 for the IT Pro Audience (system administrators, help desk support). Topics covered are: Installation, Deployment, Configuration, Security, Group Policy, Management questions. If you are a consumer looking for answers or to raise a question, it's highly recommended you head on over to http://answers.microsoft.com/en-us


    Rob^_^

    • Proposed as answer by Tony_Tao Tuesday, April 26, 2016 11:49 AM
    • Unproposed as answer by jason.denness Wednesday, April 27, 2016 8:54 AM
    Monday, April 25, 2016 11:51 PM
  • As Rob mentioned, please try it.

    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, April 26, 2016 11:49 AM
  • here is the requested screen shot.  I checked the language settings and it is set correctly.  Spell check it working on other websites ok, just outlook.com

    Wednesday, April 27, 2016 8:53 AM
  • Hi,

    your screen shot looks like you have either live.com or outlook.com in Compatibility view or your system administrators have mistakenly put outlook.com in their enterprise mode lists.

    Press f12 to display the Developer tool... on the Emulation tab it shows how and which emulation mode IE is using to display that web page...

    It should show Document Mode 10 via x-ua meta...

    I expect that your computer will say Document Mode 7 via Compatibility View list or Enterprise Mode lists.

    Regards.

    Questions regarding Internet Explorer 8, 9 and 10 and Internet Explorer 11 for the IT Pro Audience. Topics covered are: Installation, Deployment, Configuration, Security, Group Policy, Management questions. If you are a consumer looking for answers or to raise a question, it's highly recommended you head on over to http://answers.microsoft.com/en-us


    Rob^_^

    Thursday, April 28, 2016 12:47 AM
  • Hi Rob

    I have checked and there are no sites in the compatibility view.

    I have looked at the emulation tab and document mode 11 (default) via x-ua-compatible meta tag was set

    I changed it to mode 10 just to test, the page refreshed but still didn't work.

    thanks

    Jason

    Thursday, April 28, 2016 12:52 PM
  • Hi Jason,

    I found the answer..... spell check is not available in the new message dialog when 'Edit as HTML' is selected from the 'Options' menu.

    First compose your message in plain text, then select the Options>Edit in HTML menu to add HTML formatting to your text.... Email accept user preferences for email formatting so if you include HTML markup there is no guarantee that the recipients will use in.... viz hyperlinks may be changed to plain text and be un clickable.

    Regards.

    Questions regarding Internet Explorer 8, 9 and 10 and Internet Explorer 11 for the IT Pro Audience. Topics covered are: Installation, Deployment, Configuration, Security, Group Policy, Management questions. If you are a consumer looking for answers or to raise a question, it's highly recommended you head on over to http://answers.microsoft.com/en-us


    Rob^_^

    Friday, April 29, 2016 2:36 AM
  • Hi Rob

    Your screen shot doesn't look the same as what I see, there is no spell check button as you have above. I type a message with mistakes and changed between Plain text and html, no spellchecker in either case.

    thanks

    Jason

    Friday, April 29, 2016 7:58 AM
  • that's from windows 10/IE11 on the compose new message web page at outlook.com under my account....

    "Spellchecker is working on all sites with outlook.com being the exception." -

    You may get a better explanation from the outlook.com support... my outlook account may have additional features that your's does not.

    Since you

    Regards.

    Questions regarding Internet Explorer 8, 9 and 10 and Internet Explorer 11 for the IT Pro Audience. Topics covered are: Installation, Deployment, Configuration, Security, Group Policy, Management questions. If you are a consumer looking for answers or to raise a question, it's highly recommended you head on over to http://answers.microsoft.com/en-us


    Rob^_^


    Saturday, April 30, 2016 4:30 AM
  • So this is a dead end then? no fix for this issue?
    Monday, May 2, 2016 7:07 AM
  • Hi Jason,

    it appears that it involves YOUR account with outlook.com...

    see http://windows.microsoft.com/en-US/hotmail/ad-free-hotmail-and-outlook

    this forum is for

    Questions regarding Internet Explorer 8, 9 and 10 and Internet Explorer 11 for the IT Pro Audience. Topics covered are: Installation, Deployment, Configuration, Security, Group Policy, Management questions. If you are a consumer looking for answers or to raise a question, it's highly recommended you head on over to http://answers.microsoft.com/en-us


    Rob^_^


    Tuesday, May 3, 2016 1:21 AM
  • Ummmmm why have you given me a link for add free outlook.com?  what does that have to do with spell checker not working?

    I have gone through the support for outlook.com and office 365 support.  both support technicians have said it is a fault on IE11 and directed me to this support forum to get help with a resolution.

    Thursday, May 5, 2016 7:39 AM
  • Hi,

    your own words....

    "Spellchecker is working on all sites with outlook.com being the exception."

    it works fine on my account (The outlook.com spell checker).

    I expect outlook.com uses a server based spell checker, not the browsers', and that they have premium services, hence I provided the link explaining the different features of Outlook.com subscriptions or maybe you need also a recent version of Office installed on your computer..

    The outlook.com help (Tools icon>Help)

    please see http://windows.microsoft.com/en-au/windows/outlook/basics#basics-spell-check

    Regards.


    Rob^_^

    Friday, May 6, 2016 2:19 AM
  • Latest office is installed, which is irrelevant seeing as I am not using office, According to outlook.com support AND office 365 support it uses the spellcheck built into IE.

    Other users here have the same setup as myself and it works on that PC.

    thanks for your help

    Friday, May 6, 2016 7:43 AM
  • According to outlook.com support AND office 365 support it uses the spellcheck built into IE.

    It would probably help to know what that means exactly.  E.g. I just noticed I had the same symptom on IE11 on Win8.2 RT and apparently fixed it simply by toggling the AutoCorrect and AutoCheck settings.   In the case of AutoCorrect I keep that off but supposedly AutoCheck has always been on.

    Previously when this issue came up I noticed that there was some HTML involved which could be exposed by using the Developer Tools. 

    https://social.technet.microsoft.com/Forums/ie/en-US/1e0215d1-da68-4a5b-a2cd-2dbf34029c67/cant-really-post-to-the-forums#fa47be01-4af7-4a41-928b-1b333ecd0800

    <quote>

    <body spellcheck="true">

    </quote>

    However, I can also remember seeing something about a Dictionary support in the Manage Add-ons tool.  It's not there any more but somehow I still get a Spell check?  Etc.

    As usual no functional spec or implementation clues are given, so reverse engineering is the order of the day if you really want to know what is supposed to be happening or help work around something that is happening that you don't like.

    BTW Search Settings on Win RT seems to be broken.  AutoCorrect should be found but I was only able to find the settings by entering Win-w Typing.  Maybe Cortana or Win-i will be more helpful in W10.

    Heh.  W10 Search (Win-s) does find AutoCorrect.  It matches as soon as I have typed Auto.  Apparently I had both unchecked.  Toggling them had no immediate effect on the HTML that Outlook.com had already generated.  Strangely though, in the Subject field I found  spellcheck="True" but in the body field it was False.  In neither case could I get a squiggly red line under a misspelt word.  I may try again later.  Right now W10 seems to be its usual quirky self, so I really have no idea whether what I am seeing is due to what I am trying to change or due to the quirks.

    BTW it would probably also help to know whether you are using IE, Edge, or Pinned IE.  But I just pinned Outlook.com and (should I be surprised?) that hung the tab (after I tried using it after it had been converted to a pinned web app).  Again, I imagine it would be better to try again later and as always YMMV.

     

    HTH



    Robert Aldwinckle
    ---

    Friday, May 6, 2016 1:26 PM
    Answerer
  • Managed to fix this.

    Was browsing the network tab on F12 tools and noticed 5 errors, all were items that had failed to run, to do with office and ending in .js

    So I installed Java from java.com and the spell checker in outlook.com started working again. 

    Super odd seeing as none of the other machines here have Java installed.

    fixed now though.

    Monday, May 23, 2016 1:19 PM