locked
autodiscover.xml for POP3 & IMAP RRS feed

  • Question

  • We have just created an autodiscover.xml file to auto-configure POP3 / IMAP clients for our hosting services

    I have two queries about our config which is working, but needs a little tweaking.

    1: Is it possible to have outlook prompt whether the user wishes to use POP3 or IMAP during an Autodiscover automated setup?

    2: How do we specify that outlook should use the full email address as the username? We have setup <DomainRequired>on</DomainRequired>, but this does not seem to be doing the trick.

    Here is our autodiscover.xml

    <?xml version="1.0" encoding="utf-8" ?>
    <Autodiscover xmlns="http://schemas.microsoft.com/exchange/autodiscover/responseschema/2006">
    <Response xmlns="http://schemas.microsoft.com/exchange/autodiscover/outlook/responseschema/2006a">
    <Account>
    <AccountType>email</AccountType>
    <Action>settings</Action>
    <Protocol>
    <Type>POP3</Type>
    <Server>mail.domain.com</Server>
    <Port>995</Port>
    <DomainRequired>on</DomainRequired>
    <SPA>off</SPA>
    <SSL>on</SSL>
    <AuthRequired>on</AuthRequired>
    </Protocol>
    <Protocol>
    <Type>IMAP</Type>
    <Server>mail.domain.com</Server>
    <Port>993</Port>
    <DomainRequired>on</DomainRequired>
    <SPA>off</SPA>
    <SSL>on</SSL>
    <AuthRequired>on</AuthRequired>
    </Protocol>
    <Protocol>
    <Type>SMTP</Type>
    <Server>mail.domain.com</Server>
    <Port>25</Port>
    <DomainRequired>off</DomainRequired>
    <SPA>off</SPA>
    <Encryption>TLS</Encryption>
    <AuthRequired>on</AuthRequired>
    <UsePOPAuth>on</UsePOPAuth>
    <SMTPLast>on</SMTPLast>
    </Protocol>
    </Account>
    </Response>
    </Autodiscover>

    Monday, June 30, 2014 12:42 AM

Answers

  • Hi,

    According to your description, I understand that you want to auto-configure the outlook clients for IMAP/POP3 and SMTP. The following Autodiscover XML file achieve that the mail service provider enables users to log on by using both the POP3 protocol and the IMAP protocol, but prefers that users use the POP3 protocol, the POP3 settings should be listed first in the Autodiscover file:

    <?xml version="1.0" encoding="utf-8" ?>

    <Autodiscover xmlns="http://schemas.microsoft.com/exchange/autodiscover/responseschema/2006">

    <Response xmlns="http://schemas.microsoft.com/exchange/autodiscover/outlook/responseschema/2006a">

    <Account>

    <AccountType>email</AccountType>

    <Action>settings</Action>

    <Protocol>

    <Type>POP3</Type>

    <Server>mail.contoso.com</Server>

    <Port>995</Port>

    <DomainRequired>on</DomainRequired>

    <SPA>off</SPA>

    <SSL>on</SSL>

    <AuthRequired>on</AuthRequired>

    </Protocol>

    <Protocol>

    <Type>IMAP</Type>

    <Server>mail.contoso.com</Server>

    <Port>993</Port>

    <DomainRequired>on</DomainRequired>

    <SPA>off</SPA>

    <SSL>on</SSL>

    <AuthRequired>on</AuthRequired>

    </Protocol>

    <Protocol>

    <Type>SMTP</Type>

    <Server>mail.contoso.com</Server>

    <Port>587</Port>

    <DomainRequired>off</DomainRequired>

    <SPA>off</SPA>

    <SSL>on</SSL>

    <AuthRequired>on</AuthRequired>

    <UsePOPAuth>on</UsePOPAuth>

    <SMTPLast>on</SMTPLast>

    </Protocol>

    </Account>

    </Response>

    </Autodiscover>

    For more information about Autodiscover in automatically configuring user accounts, please refer to:

    http://technet.microsoft.com/en-us/library/cc511507.aspx

    Hope it helps.

    Regards,


    Winnie Liang
    TechNet Community Support

    Wednesday, July 2, 2014 3:28 AM