none
Restore to Shares of an Scale Out Fileserver

    Question

  • Hy,

    today i tried to restore a Server to an Scale Out FileServer (SOFS).

    (DPM2016)

    When i restore i had to select a Network Folder as Backup Target.

    Here it opens a Windows where i see Servers, Objects and Virtual Machines with an Backup Agent.

    When i select my SOFS an press <plus> i get no Targets to restore.

    The same for my FS-Cluster, no Targets to restore.

    When i select my File-Server Nodes, i see the local disks but as Shares not the SOFS Shares.

    What i have to do, that i can Restore to the Shares of my Scale Oute Filesever?

    In Agents of DPM i see only my 2 File-Server Nodes. When i select install Agent, i see not my SOFS object, but the Fileserver-Cluster. When i select the Fileserver Cluster to install it beginns to install, stopps at 1%. is this the Propblem?

    Volker


    Volker Busch

    Sunday, April 22, 2018 7:51 AM

All replies

  • Hi Volker,

    Protecting VMs stored on ReFS-based SOFS clusters

    DPM 2016 can back up VMs deployed on ReFS-based SOFS clusters.

    To protect VMs on SOFS clusters, add the following machine accounts to the backup operator groups and share permissions.

    • If protecting a highly available (HA) VM, provide the machine account name of the host cluster and cluster nodes, and DPM server.
    • If protecting a non-HA VM, provide the machine name of the Hyper-V host and the DPM server.

    To add the machine accounts to the backup operator groups, run the following steps for each node in the SOFS cluster:

    1. Open the command prompt, and type, lusrmgr.msc to open Local Users and Groups.
    2. In the Local Users and Groups dialog, click Groups.
    3. In the list of groups, right-click Backup Operators and select Properties.

      The Backup Operators Properties dialog opens.
    4. In the Backup Operators Properties dialog, click Add.
    5. In the Select Users, Computers, Services Accounts, or Groups dialog, click Object Types. The Object Types dialog opens.
    6. In the Object Types dialog, select Computers and click OK. The Object Types dialog closes.
    7. In the Select Users, Computers, Service Accounts, or Groups dialog, enter the name of the server or cluster, and click Check Names.
    8. Once you have identified the computers, restart the node.

    Giving permissions to the share

    1. On a server where the SOFS/SMB share is hosted, open Server Manager > File and Storage Services > Shares.
    2. Right click the VM storage share, and then click Properties.
    3. In the Properties dialog, on the left navigation menu, click Permissions.
    4. Click Customize permissions to open the Advanced Security Settings dialog.
    5. On the Permissions tab, click Add.
    6. Click Select a Principal.
    7. In the Select User, Computer, Services Account, or Group dialog, click Object Types.
    8. In the Object Types dialog, select Computers, and click OK.
    9. In the Select User, Computer, Service Account, or Group dialog, enter the name of the Hyper-V node or cluster name you want to have permission.
    10. Click Check Names to resolve the name, and click OK.
    11. In the Permission Entry for Share dialog, select Full Control, and click OK.
    12. In the Advanced Security Settings for Share dialog, click the Share tab and repeat steps 6-11 for the Share tab instead of the Permissions tab.
    13. When you are finished adding permissions for the servers, click Apply.


    This prepares the VMs on SOFS shares for the backup process.

    More information about DPM 2016
    https://technet.microsoft.com/en-us/system-center-docs/dpm/get-started/what-s-new-in-dpm-in-system-center-2016

    Kind regards,
    Leon


    Don't forget to visit my blog The System Center Blog

    Wednesday, May 9, 2018 12:00 PM
  • The Shares are normal NTFS Volumes.

    The Permissions an the SOFS Nodes and Shares are set.

    On a local Harddisk of an sofs node i can restore. In the Shares of an <sofs node> i dont see the Shares of the sofs. (I Think this is normal)

    When i press the plus on the sofs object OR the FS-Cluster Object, the Shares of the sofs dont come to select.

    The plus sign is then removed, an no <Shares> or <Volumes> are shown.

    This is the Problem..

    Kind regards Volker


    Volker Busch

    Friday, May 11, 2018 7:34 AM