locked
Error message when you try to install the ASP.NET feature in IIS 7.0: "An error has occurred" RRS feed

  • Question

  •  

    I get following error on trying to install IIS 7.0 on 32 bit Vista ultimate machine.

     

    "An error has occurred. Not all of the features were successfully changed."

     

     I have already tried following steps

    • Followed KB 929772. Did not worked for me
    • Uninstalled .net 1.1, .net 2.0 and .net 3.0.   Did not worked
    • Erased inetsrv and inetpub directory .  Did not worked  

     

    Please help

    Thanks

    Akshay Kalia

     

    Friday, January 11, 2008 11:16 PM

Answers

All replies

  •  

    Hi Akshay,

     

    Thank you for the post.

     

    First please try the suggestions in KB929772 again.

    http://support.microsoft.com/?id=929772

     

    If the issue still occurs, let’s turn off Windows Process Activation Service.

     

    1. Click Start, and then click Control Panel.

    2. Double-click Programs and Features.

    3. Click Turn Windows features on or off.

     

    Note: If you are prompted for an administrator password or for a confirmation, type the password, or click Continue.

     

    4. Click to clear the Windows Process Activation Service check box, and then click OK.

    5. Click Restart Now to restart the computer.

     

    Can we install IIS 7.0 now?

     

    In addition, I have included the detailed steps about how to install IIS 7.0 below for your reference:

    http://www.iis.net//articles/view.aspx/IIS7/Deploy-an-IIS7-Server/Installing-IIS7/Install-IIS7-on-Vista

     

    Please Note: Since the website is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

     

    Hope it helps.

     

    Best regards,

    Tim Quan

    Microsoft Online Community Support

    Monday, January 14, 2008 5:51 AM
    Moderator
  •  

    Hi Tim

    Thanks for the suggestions but i have already done the above steps many times but same results every time. I and I do not see any ASP filters on IIS manager screen.

     

    http://www.iis.net//articles/view.aspx/IIS7/Deploy-an-IIS7-Server/Installing-IIS7/Install-IIS7-on-Vista : I am following the exact procedure told here

     

    Monday, January 14, 2008 4:22 PM
  • Hi,

              Even I am getting the same error ,Please tell me whats the dilemma??I also tried all above ,but in vain.

    Tuesday, January 22, 2008 4:34 AM
  • Hi praggy,

     

    Thank you for the post.

     

    If the issue persists, please refer to the following thread:

     

    http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=2785888&SiteID=17

     

    Hope it helps.

     

    Best regards,

    Tim Quan

    Microsoft Online Community Support

     

    Tuesday, February 5, 2008 9:29 AM
    Moderator
  • Tim,

    This link cannot be the answer to this post!  This link goes to a thread of VERY UNHAPPY posters.  I am having this exact issue.  I cannot add features, regardless of which one I choose, I always get the same error, "An Error has occurred. Not all of the features were successfully changed."

    Is there any update on this issue?
    Thursday, March 26, 2009 8:56 PM