locked
Long Boot Times 10min (Windows Firewall) RRS feed

  • Question

  • I have been experiencing very long Windows boot times, around 10-15min. After extensive research and testing I have found the cause of the long boot times. Surprisingly it's Windows Firewall Service, once disabled the boot time drops from 15min to around 2-3min. It seems like Windows Firewall Service is scanning the whole hard drive, for what I don't know. Another interesting fact is that if the service is started manually a few minutes after reboot, it doesn't cause the HDD to work for 15 min.

    Is anybody else experiencing this problem, are there any ways to fix this problem?

    Sunday, June 9, 2013 9:00 AM

Answers

All replies

  • Hi cybercritic,

    How do you know Windows firewall service take too long time? Please try to disable Windows firewall service then confirm the situation.

    Meanwhile, I suggest you use clean boot to troubleshoot:

    http://support.microsoft.com/kb/929135

    Best regards,

    Karen Hu

    Tuesday, June 11, 2013 1:18 AM
  • When I disable Windows Firewall Service, boot takes 3min, when it's enabled it takes 10-15min.
    Tuesday, June 11, 2013 6:15 AM
  • Hi cybercritic,

    You could disable it from the msconfig. Then set it as “Automatic(Delayed Start)”:

    1. type “Service.msc” into the search inbox of start button;

    2. locate the “windows firewall” service, double click it;

    3. on the “General” tab, “Startup type” list , select ““Automatic(Delayed Start)”.

    Best regards,

    Karen Hu

    Thursday, June 13, 2013 9:03 AM
  • I tried that, but Windows Firewall Service can not be set to "Delayed Start", it gives the following error:

    The delayed auto-start flag could not be set.
    
    Error 87: The parameter is incorrect.

    Thursday, June 13, 2013 9:06 AM
  • Hi cybercritic,

    Please try to following "fix it":

    http://support.microsoft.com/mats/windows_firewall_diagnostic/

    Best regards,

    Karen Hu

    • Marked as answer by Cloud_TS Wednesday, July 3, 2013 1:28 AM
    Friday, June 14, 2013 9:41 AM