none
Windows 2012 R2 RDS - Remote Gateway Manager is temporarily unavailable RRS feed

  • Question

  • Hi,

    I have a question about my current setup:

    1 - Gateway and Web access server (serverA)
    1 - Connection Broker and License server (serverB)
    1 - Session host server (serverC)

    When I open a browser to access the web access url, there is a prompt for me to login. Once I login I see my published apps, however when i click on one of the published apps, another Remote App prompt pops up and asks for me to login to ServerB. I try to login but it says my "Remote Gateway Manager is temporarily unavailable".

    I have opened up port 443 to my serverA and applied the SSL certificate I purchased externally to all the server machines.

    What am I doing wrong? Why is it prompting me to login to ServerB?

    Thanks,
    John

    Friday, July 15, 2016 12:22 AM

Answers

All replies

  • Hi John,

    Firstly, please ensure that RD Gateway service is running on server A and TCP port 443 are not blocked, you may disable firewall temporarily to test.

    Secondly, please install RD Gateway related hotfixes within this article below:

    Available Updates for Remote Desktop Services in Windows Server 2012 R2

    https://support.microsoft.com/en-us/kb/2933664

    In addition, it’s normal that it’s prompting you to log onto Server B as it’s the Connection Broker which the collection name points to.

    Best Regards,

    Amy


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, July 15, 2016 9:32 AM
    Moderator
  • Hi Amy,

    Thanks for the reply. The following is running:

    •  Gateway service is running on server A
    •  Port 443 is open on Server A.
    •  Applied all the windows updates.

    I am able to get to RD Web Access through the internet and use the RD client to access my remote app. However when I try to use my browser to get to RD WebAccess, I see the remote apps, but if I double-click the connection broker prompt pops up and enter in my password, the "Remote Gateway Manager is temporarily unavailable" error appears. Any ideas on what I am missing?

    Thanks,

    John

    Saturday, July 16, 2016 12:24 AM
  • Hi John,

    In order to further analyze the issue, please use Network Monitor to verify whether RDP traffic reaches the RD Gateway Server.

    In addition, split DNS needs to be configured internally to resolve RD Connection and Gateway’s public FQDN.

    Best Regards,

    Amy


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, July 18, 2016 8:59 AM
    Moderator
  • Hi,

    It does not look like RDP traffic reaches the RD Gateway server. However, if I uncheck 'Bypass RD Gateway server for local addresses', I am able to reach the Remote Apps. Is unchecking this item something that is not recommended?

    I am also receiving a certificate error saying a mismatched address when type in the URL. I purchased the cert externally (rds.jgtest.co.uk) and I am using it for all of the servers. When I created the RD Gateway role I used that cert as the FQDN entry, is it an issue where my gateway server name is not the same name as the certificate name?

    Thanks,

    John
    Thursday, July 21, 2016 4:37 AM
  • Hi , have you specified a gateway in Server Manager RDS management?

    You have to have a gateway specified so that the icons in the RDWeb page get updated and point to the gateway server.

    Thursday, July 21, 2016 6:44 AM
  • Hi,

    Yes, I have the gateway role and the FQDN name matching the certificate name, although this name does not match the server name.

    Thanks

    Friday, July 22, 2016 12:25 AM
  • It does not look like RDP traffic reaches the RD Gateway server.

    Hi John,

    Please ensure that the RD Gateway server is publically accessible by port forwarding or registering public IP address and FQDN for the server itself.

    Regarding certificate configuration, here is a related article below might be useful to you:

    Certificate Requirements for Windows 2008 R2 and Windows 2012 Remote Desktop Services

    https://blogs.technet.microsoft.com/askperf/2014/01/24/certificate-requirements-for-windows-2008-r2-and-windows-2012-remote-desktop-services/

    Best Regards,

    Amy


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, July 27, 2016 10:44 AM
    Moderator