locked
Problem receiving attachments from some domains RRS feed

  • Question

  • Hi

    I have a odd problem, i cannot receive attachments from some domains such as Hotmail.com. Having said that i can receive small attachments up to about 200kb from the same domain. We have deployed Exchange 2007 SPK1 Two Hub transport servers and a CCR-cluster but no Edge transport server. Most domains have no problems sending large attachments, this only effects some domians.

    I have checked transport settings, organization level, send/receive connectors and mailbox all are set to 30 mb. I also have Mcafee groupshield for exchange installed on Hub Transport servers also with the right attachment settings. I also tried disabling this but to no avail.

    This only started to occur when i finally removed the last exchange 2003 server from our domain, everything else works perfectly, but for this odd problem. When mail is sent from problem domains with attachments it never arrives (without attachments is fine), and the sender will eventually receive the following:

    Your message did not reach some or all of the intended recipients.

          Subject:            FW: email

          Sent: 28/04/2010 08:00

     

    The following recipient(s) cannot be reached:

          user@Domain on 30/04/2010 08:16

                Could not deliver the message in the time limit specified.

    Please retry or contact your administrator.

                <domain #4.4.7>

    or usually the NDR is regarding delayed messages. I have also checked we are not on any blacklist, i have also created a new send connector, to rule out content filter i have tried also to exclude the hotmail.dom domain.

    Anyone seen or experienced this before, much appreciated.

    Khal.

    Sunday, May 9, 2010 9:13 PM

Answers

  • Hi Khals

    I noticed BDAT command in the end of session

    BDAT is part of ESMTP protocol - while Ex2007 supports ESMTP, it does not support BDAT due to vulnerabilities that would crash smtp server (back in Exchange 2000 days).  You can see all the ESMTP commands Exchange 2007 supports by telnet to the box and execute EHLO.  While only very small number of domains still use BDAT , it is not neccessary to make any changes to Exchange 2007.

    to solve this issue, you need to disabled the ESMTP verbs BinaryMime and Chunking The Exchange Shell commands to do this are:

    Set-ReceiveConnector -Identity "nameofconnector" -BinaryMimeEnabled $False
    Set-ReceiveConnector -Identity "nameofconnector" -Chunking $False

    Note BinaryMimeEnabled must be done before Chunking

    Mahmoud Sabry

    • Marked as answer by Khals Tuesday, May 11, 2010 9:45 AM
    Tuesday, May 11, 2010 7:49 AM

All replies

  • Hi khal ,

    Base on error message it say due to the time limit specified. So i will suspect when hotmail try to deliver emails to you , due to time constraint connection lost . So few possibilties here:

    1) Receive connector timeout.

    Set-ReceiveConnector <Connector-Name> -ConnectionInactiveTimeout <days.hours:minutes:seconds>

    2)Poor bandwidth .

    3)Any firewall / routers / antispam appliances will cut off the connection timing one ?

    Thanks

    Monday, May 10, 2010 1:00 AM
  • Dear Khals

    by default, connection time out for receive connector is set to 10 min, if the message delivery between the sender server and receiver Server took more than this time, the session will be timed out, if you have poor bandawidth this case may happen with large messages

    to get the connection time out for receive connectors, use the following Cmdlet

    Get-ReceiveConnector | fl identity,ConnectionTimeout

    to modify this value for all of your receive connectors, use the following Cmdlet

    Get-ReceiveConnector | Set-ReceiveConnector -ConnectionTimeout  dd.hh:mm:ss ,

    where d = days, h = hours, m = minutes, and s = seconds

     

    i think after this modifications, you can receive large emails

     

     

    Monday, May 10, 2010 11:55 AM
  • cskhor, thanks for the reply.

    I have changed the ConnectionTimeoutSetting but the problem remains, i can send from other domains such as Yahoo.co.uk and many others i cannot see what difference is with hotmail.co.uk, when i send emails from yahoo for example with large attachments they arrive to our exchange very quickly.

    Hotmail messages with attachments larger than about 200kb dont arrive at all?

    We have a Watchguard firewall and its not that as we have another mail server (not exchange) and large hotmail attachments arrive to that without a problem, this is something specific to exchange.

    Anything else i can try?

    thanks

    Monday, May 10, 2010 12:42 PM
  • Hi Mahmoud

    Thanks for your reply. I have made the changes you suggested but still no change. The problem is not with emails with large attachments but with emails with large attachments from some domains only such as Hotmail.co.uk i have made no modification to process emails from this domain any differently on exchange so i cannot see why emails with slightly larger (even 1mb) attachments do not arrive. I have included my transport settings and max receive connector settings if it helps, please let me know if there is anything else i may try. Thanks.

    ClearCategories                : True
    GenerateCopyOfDSNFor           : {5.4.8, 5.4.6, 5.4.4, 5.2.4, 5.2.0, 5.1.4}
    InternalSMTPServers            : {}
    JournalingReportNdrTo          : <>
    MaxDumpsterSizePerStorageGroup : 25MB
    MaxDumpsterTime                : 7.00:00:00
    MaxReceiveSize                 : 30000KB
    MaxRecipientEnvelopeLimit      : 6000
    MaxSendSize                    : 30000KB
    TLSReceiveDomainSecureList     : {}
    TLSSendDomainSecureList        : {}
    VerifySecureSubmitEnabled      : False
    VoicemailJournalingEnabled     : True
    Xexch50Enabled                 : True

    ------------------------------------------------------------------/  -------------------------------------

    MaxInboundConnection                    : 5000
    MaxInboundConnectionPerSource           : unlimited
    MaxInboundConnectionPercentagePerSource : 100
    MaxHeaderSize                           : 64KB
    MaxHopCount                             : 30
    MaxLocalHopCount                        : 8
    MaxLogonFailures                        : 3
    MaxMessageSize                          : 30000KB
    MaxProtocolErrors                       : 5
    MaxRecipientsPerMessage                 : 5000

    MaxInboundConnection                    : 5000
    MaxInboundConnectionPerSource           : 100
    MaxInboundConnectionPercentagePerSource : 2
    MaxHeaderSize                           : 64KB
    MaxHopCount                             : 30
    MaxLocalHopCount                        : 8
    MaxLogonFailures                        : 3
    MaxMessageSize                          : 30000KB
    MaxProtocolErrors                       : 5
    MaxRecipientsPerMessage                 : 200

    MaxInboundConnection                    : 5000
    MaxInboundConnectionPerSource           : unlimited
    MaxInboundConnectionPercentagePerSource : 100
    MaxHeaderSize                           : 64KB
    MaxHopCount                             : 30
    MaxLocalHopCount                        : 8
    MaxLogonFailures                        : 3
    MaxMessageSize                          : 30000KB
    MaxProtocolErrors                       : 5
    MaxRecipientsPerMessage                 : 5000

    MaxInboundConnection                    : 5000
    MaxInboundConnectionPerSource           : 100
    MaxInboundConnectionPercentagePerSource : 2
    MaxHeaderSize                           : 64KB
    MaxHopCount                             : 30
    MaxLocalHopCount                        : 8
    MaxLogonFailures                        : 3
    MaxMessageSize                          : 30000KB
    MaxProtocolErrors                       : 5
    MaxRecipientsPerMessage                 : 200

    MaxInboundConnection                    : 5000
    MaxInboundConnectionPerSource           : 20
    MaxInboundConnectionPercentagePerSource : 2
    MaxHeaderSize                           : 64KB
    MaxHopCount                             : 30
    MaxLocalHopCount                        : 8
    MaxLogonFailures                        : 3
    MaxMessageSize                          : 35000KB
    MaxProtocolErrors                       : 5
    MaxRecipientsPerMessage                 : 200

    Khal.

     

    Monday, May 10, 2010 1:02 PM
  • Dear Khal

    what is the ConnectionTimeout for the receive connectors?

    enable receive connector logging and try send email again from hotmail and give us the part of the log that is dedicated for this session, so that we can look in the time it takes to deliver the message to your server and the reason the the session not completed

     

    you can enable receive connector logging from receive connector properties, set logging level to verbos

     

    the default path for this log is C:\Program Files\Microsoft\Exchange Server\TransportRoles\Logs\ProtocolLog\SmtpReceive

    Monday, May 10, 2010 3:23 PM
  • Hi Mahmoud

    again many thanks for your response, and apologies this message may have gotten too large.

    the ConnectionTimeout was increased from 10mins to 20mins, see output below

    Identity          : LHGGATEWAY\Default LHGGATEWAY
    ConnectionTimeout : 00:20:00

    Identity          : LHGGATEWAY\Client LHGGATEWAY
    ConnectionTimeout : 00:20:00

    Identity          : LHGHUB\Default LHGHUB
    ConnectionTimeout : 00:20:00

    Identity          : LHGHUB\Client LHGHUB
    ConnectionTimeout : 00:20:00

    Identity          : LHGHUB\Internet
    ConnectionTimeout : 00:20:00

    i have added the receive connector logs below, there seem to be three parts relevant to my hotmail message:

    I am not experienced with reading these logs but one difference i noticed with emails with large attachments from hotmail and others that are received correctly is that, the ones received correctly have a continuous stream of "250 2.6.0 CHUNK received OK, <some number> octets" whereas the hotmail emails do not? please see below.

    Part1

    2010-05-10T21:25:18.081Z,LHGHUB\Internet,08CCBD92C208AEF8,0,10.1.1.62:25,65.55.90.100:39211,+,,
    2010-05-10T21:25:18.081Z,LHGHUB\Internet,08CCBD92C208AEF8,1,10.1.1.62:25,65.55.90.100:39211,*,SMTPSubmit SMTPAcceptAnySender SMTPAcceptAuthoritativeDomainSender AcceptRoutingHeaders,Set Session Permissions
    2010-05-10T21:25:18.081Z,LHGHUB\Internet,08CCBD92C208AEF8,2,10.1.1.62:25,65.55.90.100:39211,>,"220 mailserver.lighthousegroup.plc.uk Microsoft ESMTP MAIL Service ready at Mon, 10 May 2010 22:25:17 +0100",
    2010-05-10T21:25:18.206Z,LHGHUB\Internet,08CCBD92C208AEF8,3,10.1.1.62:25,65.55.90.100:39211,<,EHLO snt0-omc2-s25.snt0.hotmail.com,
    2010-05-10T21:25:18.206Z,LHGHUB\Internet,08CCBD92C208AEF8,4,10.1.1.62:25,65.55.90.100:39211,>,250-mailserver.lighthousegroup.plc.uk Hello [65.55.90.100],
    2010-05-10T21:25:18.206Z,LHGHUB\Internet,08CCBD92C208AEF8,5,10.1.1.62:25,65.55.90.100:39211,>,250-SIZE 35840000,
    2010-05-10T21:25:18.206Z,LHGHUB\Internet,08CCBD92C208AEF8,6,10.1.1.62:25,65.55.90.100:39211,>,250-PIPELINING,
    2010-05-10T21:25:18.206Z,LHGHUB\Internet,08CCBD92C208AEF8,7,10.1.1.62:25,65.55.90.100:39211,>,250-DSN,
    2010-05-10T21:25:18.206Z,LHGHUB\Internet,08CCBD92C208AEF8,8,10.1.1.62:25,65.55.90.100:39211,>,250-ENHANCEDSTATUSCODES,
    2010-05-10T21:25:18.206Z,LHGHUB\Internet,08CCBD92C208AEF8,9,10.1.1.62:25,65.55.90.100:39211,>,250-AUTH,
    2010-05-10T21:25:18.206Z,LHGHUB\Internet,08CCBD92C208AEF8,10,10.1.1.62:25,65.55.90.100:39211,>,250-8BITMIME,
    2010-05-10T21:25:18.206Z,LHGHUB\Internet,08CCBD92C208AEF8,11,10.1.1.62:25,65.55.90.100:39211,>,250-BINARYMIME,
    2010-05-10T21:25:18.206Z,LHGHUB\Internet,08CCBD92C208AEF8,12,10.1.1.62:25,65.55.90.100:39211,>,250 CHUNKING,
    2010-05-10T21:25:18.331Z,LHGHUB\Internet,08CCBD92C208AEF8,13,10.1.1.62:25,65.55.90.100:39211,<,MAIL FROM: <khals@hotmail.co.uk> SIZE=752963,
    2010-05-10T21:25:18.331Z,LHGHUB\Internet,08CCBD92C208AEF8,14,10.1.1.62:25,65.55.90.100:39211,*,08CCBD92C208AEF8;2010-05-10T21:25:18.081Z;1,receiving message
    2010-05-10T21:25:18.331Z,LHGHUB\Internet,08CCBD92C208AEF8,15,10.1.1.62:25,65.55.90.100:39211,>,250 2.1.0 Sender OK,
    2010-05-10T21:25:18.456Z,LHGHUB\Internet,08CCBD92C208AEF8,16,10.1.1.62:25,65.55.90.100:39211,<,RCPT TO: <khalid.sarab@lighthousegroup.plc.uk>,
    2010-05-10T21:25:18.456Z,LHGHUB\Internet,08CCBD92C208AEF8,17,10.1.1.62:25,65.55.90.100:39211,>,250 2.1.5 Recipient OK,
    2010-05-10T21:25:18.597Z,LHGHUB\Internet,08CCBD92C208AEF8,18,10.1.1.62:25,65.55.90.100:39211,<,BDAT 2826,
    2010-05-10T21:25:21.191Z,LHGHUB\Internet,08CCBD92C208AEF9,0,10.1.1.62:25,65.55.90.145:38282,+,,

    Part2

    2010-05-10T21:25:32.566Z,LHGHUB\Internet,08CCBD92C208AEFB,0,10.1.1.62:25,65.55.90.97:10210,+,,
    2010-05-10T21:25:32.566Z,LHGHUB\Internet,08CCBD92C208AEFB,1,10.1.1.62:25,65.55.90.97:10210,*,SMTPSubmit SMTPAcceptAnySender SMTPAcceptAuthoritativeDomainSender AcceptRoutingHeaders,Set Session Permissions
    2010-05-10T21:25:32.566Z,LHGHUB\Internet,08CCBD92C208AEFB,2,10.1.1.62:25,65.55.90.97:10210,>,"220 mailserver.lighthousegroup.plc.uk Microsoft ESMTP MAIL Service ready at Mon, 10 May 2010 22:25:32 +0100",
    2010-05-10T21:25:32.691Z,LHGHUB\Internet,08CCBD92C208AEFB,3,10.1.1.62:25,65.55.90.97:10210,<,EHLO snt0-omc2-s22.snt0.hotmail.com,
    2010-05-10T21:25:32.691Z,LHGHUB\Internet,08CCBD92C208AEFB,4,10.1.1.62:25,65.55.90.97:10210,>,250-mailserver.lighthousegroup.plc.uk Hello [65.55.90.97],
    2010-05-10T21:25:32.691Z,LHGHUB\Internet,08CCBD92C208AEFB,5,10.1.1.62:25,65.55.90.97:10210,>,250-SIZE 35840000,
    2010-05-10T21:25:32.691Z,LHGHUB\Internet,08CCBD92C208AEFB,6,10.1.1.62:25,65.55.90.97:10210,>,250-PIPELINING,
    2010-05-10T21:25:32.691Z,LHGHUB\Internet,08CCBD92C208AEFB,7,10.1.1.62:25,65.55.90.97:10210,>,250-DSN,
    2010-05-10T21:25:32.691Z,LHGHUB\Internet,08CCBD92C208AEFB,8,10.1.1.62:25,65.55.90.97:10210,>,250-ENHANCEDSTATUSCODES,
    2010-05-10T21:25:32.691Z,LHGHUB\Internet,08CCBD92C208AEFB,9,10.1.1.62:25,65.55.90.97:10210,>,250-AUTH,
    2010-05-10T21:25:32.691Z,LHGHUB\Internet,08CCBD92C208AEFB,10,10.1.1.62:25,65.55.90.97:10210,>,250-8BITMIME,
    2010-05-10T21:25:32.691Z,LHGHUB\Internet,08CCBD92C208AEFB,11,10.1.1.62:25,65.55.90.97:10210,>,250-BINARYMIME,
    2010-05-10T21:25:32.691Z,LHGHUB\Internet,08CCBD92C208AEFB,12,10.1.1.62:25,65.55.90.97:10210,>,250 CHUNKING,
    2010-05-10T21:25:32.816Z,LHGHUB\Internet,08CCBD92C208AEFB,13,10.1.1.62:25,65.55.90.97:10210,<,MAIL FROM: <khals@hotmail.co.uk> SIZE=1832111,
    2010-05-10T21:25:32.816Z,LHGHUB\Internet,08CCBD92C208AEFB,14,10.1.1.62:25,65.55.90.97:10210,*,08CCBD92C208AEFB;2010-05-10T21:25:32.566Z;1,receiving message
    2010-05-10T21:25:32.816Z,LHGHUB\Internet,08CCBD92C208AEFB,15,10.1.1.62:25,65.55.90.97:10210,>,250 2.1.0 Sender OK,
    2010-05-10T21:25:32.925Z,LHGHUB\Internet,08CCBD92C208AEFB,16,10.1.1.62:25,65.55.90.97:10210,<,RCPT TO: <khalid.sarab@lighthousegroup.plc.uk>,
    2010-05-10T21:25:32.925Z,LHGHUB\Internet,08CCBD92C208AEFB,17,10.1.1.62:25,65.55.90.97:10210,>,250 2.1.5 Recipient OK,
    2010-05-10T21:25:33.066Z,LHGHUB\Internet,08CCBD92C208AEFB,18,10.1.1.62:25,65.55.90.97:10210,<,BDAT 1619,
    2010-05-10T21:25:33.597Z,LHGHUB\Internet,08CCBD92C208AEF8,23,10.1.1.62:25,65.55.90.100:39211,>,"250 2.6.0 CHUNK received OK, 2964 octets",
    2010-05-10T21:25:33.597Z,LHGHUB\Internet,08CCBD92C208AEF8,24,10.1.1.62:25,65.55.90.100:39211,<,BDAT 3042,
    2010-05-10T21:25:34.956Z,LHGHUB\Internet,08CCBD92C208AEFC,0,10.1.1.62:25,96.10.169.122:24068,+,

    2010-05-10T21:25:32.566Z,LHGHUB\Internet,08CCBD92C208AEFB,0,10.1.1.62:25,65.55.90.97:10210,+,,
    2010-05-10T21:25:32.566Z,LHGHUB\Internet,08CCBD92C208AEFB,1,10.1.1.62:25,65.55.90.97:10210,*,SMTPSubmit SMTPAcceptAnySender SMTPAcceptAuthoritativeDomainSender AcceptRoutingHeaders,Set Session Permissions
    2010-05-10T21:25:32.566Z,LHGHUB\Internet,08CCBD92C208AEFB,2,10.1.1.62:25,65.55.90.97:10210,>,"220 mailserver.lighthousegroup.plc.uk Microsoft ESMTP MAIL Service ready at Mon, 10 May 2010 22:25:32 +0100",
    2010-05-10T21:25:32.691Z,LHGHUB\Internet,08CCBD92C208AEFB,3,10.1.1.62:25,65.55.90.97:10210,<,EHLO snt0-omc2-s22.snt0.hotmail.com,
    2010-05-10T21:25:32.691Z,LHGHUB\Internet,08CCBD92C208AEFB,4,10.1.1.62:25,65.55.90.97:10210,>,250-mailserver.lighthousegroup.plc.uk Hello [65.55.90.97],
    2010-05-10T21:25:32.691Z,LHGHUB\Internet,08CCBD92C208AEFB,5,10.1.1.62:25,65.55.90.97:10210,>,250-SIZE 35840000,
    2010-05-10T21:25:32.691Z,LHGHUB\Internet,08CCBD92C208AEFB,6,10.1.1.62:25,65.55.90.97:10210,>,250-PIPELINING,
    2010-05-10T21:25:32.691Z,LHGHUB\Internet,08CCBD92C208AEFB,7,10.1.1.62:25,65.55.90.97:10210,>,250-DSN,
    2010-05-10T21:25:32.691Z,LHGHUB\Internet,08CCBD92C208AEFB,8,10.1.1.62:25,65.55.90.97:10210,>,250-ENHANCEDSTATUSCODES,
    2010-05-10T21:25:32.691Z,LHGHUB\Internet,08CCBD92C208AEFB,9,10.1.1.62:25,65.55.90.97:10210,>,250-AUTH,
    2010-05-10T21:25:32.691Z,LHGHUB\Internet,08CCBD92C208AEFB,10,10.1.1.62:25,65.55.90.97:10210,>,250-8BITMIME,
    2010-05-10T21:25:32.691Z,LHGHUB\Internet,08CCBD92C208AEFB,11,10.1.1.62:25,65.55.90.97:10210,>,250-BINARYMIME,
    2010-05-10T21:25:32.691Z,LHGHUB\Internet,08CCBD92C208AEFB,12,10.1.1.62:25,65.55.90.97:10210,>,250 CHUNKING,
    2010-05-10T21:25:32.816Z,LHGHUB\Internet,08CCBD92C208AEFB,13,10.1.1.62:25,65.55.90.97:10210,<,MAIL FROM: <khals@hotmail.co.uk> SIZE=1832111,
    2010-05-10T21:25:32.816Z,LHGHUB\Internet,08CCBD92C208AEFB,14,10.1.1.62:25,65.55.90.97:10210,*,08CCBD92C208AEFB;2010-05-10T21:25:32.566Z;1,receiving message
    2010-05-10T21:25:32.816Z,LHGHUB\Internet,08CCBD92C208AEFB,15,10.1.1.62:25,65.55.90.97:10210,>,250 2.1.0 Sender OK,
    2010-05-10T21:25:32.925Z,LHGHUB\Internet,08CCBD92C208AEFB,16,10.1.1.62:25,65.55.90.97:10210,<,RCPT TO: <khalid.sarab@lighthousegroup.plc.uk>,
    2010-05-10T21:25:32.925Z,LHGHUB\Internet,08CCBD92C208AEFB,17,10.1.1.62:25,65.55.90.97:10210,>,250 2.1.5 Recipient OK,
    2010-05-10T21:25:33.066Z,LHGHUB\Internet,08CCBD92C208AEFB,18,10.1.1.62:25,65.55.90.97:10210,<,BDAT 1619,
    2010-05-10T21:25:33.597Z,LHGHUB\Internet,08CCBD92C208AEF8,23,10.1.1.62:25,65.55.90.100:39211,>,"250 2.6.0 CHUNK received OK, 2964 octets",
    2010-05-10T21:25:33.597Z,LHGHUB\Internet,08CCBD92C208AEF8,24,10.1.1.62:25,65.55.90.100:39211,<,BDAT 3042,
    2010-05-10T21:25:34.956Z,LHGHUB\Internet,08CCBD92C208AEFC,0,10.1.1.62:25,96.10.169.122:24068,+,

    Part3

    2010-05-10T21:29:23.361Z,LHGHUB\Internet,08CCBD92C208AF12,0,10.1.1.62:25,65.54.61.97:2402,+,,
    2010-05-10T21:29:23.361Z,LHGHUB\Internet,08CCBD92C208AF12,1,10.1.1.62:25,65.54.61.97:2402,*,SMTPSubmit SMTPAcceptAnySender SMTPAcceptAuthoritativeDomainSender AcceptRoutingHeaders,Set Session Permissions
    2010-05-10T21:29:23.361Z,LHGHUB\Internet,08CCBD92C208AF12,2,10.1.1.62:25,65.54.61.97:2402,>,"220 mailserver.lighthousegroup.plc.uk Microsoft ESMTP MAIL Service ready at Mon, 10 May 2010 22:29:23 +0100",
    2010-05-10T21:29:23.470Z,LHGHUB\Internet,08CCBD92C208AF12,3,10.1.1.62:25,65.54.61.97:2402,<,EHLO snt0-omc2-s46.snt0.hotmail.com,
    2010-05-10T21:29:23.470Z,LHGHUB\Internet,08CCBD92C208AF12,4,10.1.1.62:25,65.54.61.97:2402,>,250-mailserver.lighthousegroup.plc.uk Hello [65.54.61.97],
    2010-05-10T21:29:23.470Z,LHGHUB\Internet,08CCBD92C208AF12,5,10.1.1.62:25,65.54.61.97:2402,>,250-SIZE 35840000,
    2010-05-10T21:29:23.470Z,LHGHUB\Internet,08CCBD92C208AF12,6,10.1.1.62:25,65.54.61.97:2402,>,250-PIPELINING,
    2010-05-10T21:29:23.470Z,LHGHUB\Internet,08CCBD92C208AF12,7,10.1.1.62:25,65.54.61.97:2402,>,250-DSN,
    2010-05-10T21:29:23.470Z,LHGHUB\Internet,08CCBD92C208AF12,8,10.1.1.62:25,65.54.61.97:2402,>,250-ENHANCEDSTATUSCODES,
    2010-05-10T21:29:23.470Z,LHGHUB\Internet,08CCBD92C208AF12,9,10.1.1.62:25,65.54.61.97:2402,>,250-AUTH,
    2010-05-10T21:29:23.470Z,LHGHUB\Internet,08CCBD92C208AF12,10,10.1.1.62:25,65.54.61.97:2402,>,250-8BITMIME,
    2010-05-10T21:29:23.470Z,LHGHUB\Internet,08CCBD92C208AF12,11,10.1.1.62:25,65.54.61.97:2402,>,250-BINARYMIME,
    2010-05-10T21:29:23.470Z,LHGHUB\Internet,08CCBD92C208AF12,12,10.1.1.62:25,65.54.61.97:2402,>,250 CHUNKING,
    2010-05-10T21:29:23.595Z,LHGHUB\Internet,08CCBD92C208AEF8,115,10.1.1.62:25,65.55.90.100:39211,>,"250 2.6.0 CHUNK received OK, 3042 octets",
    2010-05-10T21:29:23.595Z,LHGHUB\Internet,08CCBD92C208AEF8,116,10.1.1.62:25,65.55.90.100:39211,<,BDAT 2964,
    2010-05-10T21:29:23.595Z,LHGHUB\Internet,08CCBD92C208AF12,13,10.1.1.62:25,65.54.61.97:2402,<,MAIL FROM: <khals@hotmail.co.uk> SIZE=1787124,
    2010-05-10T21:29:23.595Z,LHGHUB\Internet,08CCBD92C208AF12,14,10.1.1.62:25,65.54.61.97:2402,*,08CCBD92C208AF12;2010-05-10T21:29:23.361Z;1,receiving message
    2010-05-10T21:29:23.595Z,LHGHUB\Internet,08CCBD92C208AF12,15,10.1.1.62:25,65.54.61.97:2402,>,250 2.1.0 Sender OK,
    2010-05-10T21:29:23.720Z,LHGHUB\Internet,08CCBD92C208AF12,16,10.1.1.62:25,65.54.61.97:2402,<,RCPT TO: <khalid.sarab@lighthousegroup.plc.uk>,
    2010-05-10T21:29:23.720Z,LHGHUB\Internet,08CCBD92C208AF12,17,10.1.1.62:25,65.54.61.97:2402,>,250 2.1.5 Recipient OK,
    2010-05-10T21:29:24.205Z,LHGHUB\Internet,08CCBD92C208AF12,18,10.1.1.62:25,65.54.61.97:2402,<,BDAT 2855,
    2010-05-10T21:29:24.798Z,LHGHUB\Internet,08CCBD92C208AF13,0,10.1.1.62:25,168.95.4.123:42011,+,,

    Thanks.

    Monday, May 10, 2010 10:21 PM
  • Hi khal ,

    Your smtp max size was set between = 30000kb - 350000kb for some connecters. From your logs , one of the problematics email size was

    2010-05-10T21:25:32.691Z,LHGHUB\Internet,08CCBD92C208AEFB,3,10.1.1.62:25,65.55.90.97:10210,<,EHLO snt0-omc2-s22.snt0.hotmail.com,
    2010-05-10T21:25:32.691Z,LHGHUB\Internet,08CCBD92C208AEFB,4,10.1.1.62:25,65.55.90.97:10210,>,250-mailserver.lighthousegroup.plc.uk Hello [65.55.90.97],
    2010-05-10T21:25:32.691Z,LHGHUB\Internet,08CCBD92C208AEFB,5,10.1.1.62:25,65.55.90.97:10210,>,250-SIZE 35840000,

    It already exceed the limit. You might want to increase your limit for "LHGHUB\Internet" to 40000kb then try with the same attachement again.

     

    thanks

     

     

     

     

    Tuesday, May 11, 2010 1:06 AM
  • Hi Khals

    I noticed BDAT command in the end of session

    BDAT is part of ESMTP protocol - while Ex2007 supports ESMTP, it does not support BDAT due to vulnerabilities that would crash smtp server (back in Exchange 2000 days).  You can see all the ESMTP commands Exchange 2007 supports by telnet to the box and execute EHLO.  While only very small number of domains still use BDAT , it is not neccessary to make any changes to Exchange 2007.

    to solve this issue, you need to disabled the ESMTP verbs BinaryMime and Chunking The Exchange Shell commands to do this are:

    Set-ReceiveConnector -Identity "nameofconnector" -BinaryMimeEnabled $False
    Set-ReceiveConnector -Identity "nameofconnector" -Chunking $False

    Note BinaryMimeEnabled must be done before Chunking

    Mahmoud Sabry

    • Marked as answer by Khals Tuesday, May 11, 2010 9:45 AM
    Tuesday, May 11, 2010 7:49 AM
  • Hi Mahmoud

    That's done it!!

    Many, many thanks for helping me out with this problem, i have been at it for days now and was getting very frustrated. Doing the above and shortly all emails from my previous attempts came flooding through. One final question you mentioned vulnerabilities in BDAT, does it mean with my existing config there is a greater risk now to our exchange server?

    Many thanks again

    best regards

    Khal

    Tuesday, May 11, 2010 9:45 AM
  • Thanks for your help cskhor, the solution was provided by Mahmoud, thanks again for your attempts in this matter.

    best regards

    Khal.

    Tuesday, May 11, 2010 9:48 AM
  • Also thanks from me Mahmoud.  Was having exactly same issue with Exchange 2010 on SBS 2011.  Emails with attachments either very slow (small attachments) or not arriving at all (larger attachments)........but not from all senders.  Emails without attachments were no problem.  Made the changes recommended, problem solved immediately!
    Saturday, August 24, 2013 12:49 AM
  • Worked for me too.

    Any other ESMTP verbs we should disable?

    Wednesday, October 9, 2013 9:02 PM
  • Hi Mahmoud, 

    I tried your suggestions but I still have problems in receiving big attachments from certain domains (such as gmail, and Office 365 servers as well as hotmail and live domains). I've seen in the receive connector log a change in the smtp commands, but the output changed from

    <,BDAT 65536,
    >,"250 2.6.0 CHUNK received OK, 65536 octets",
    <,BDAT 15907065 LAST,

    to 

    ,>,250 2.1.5 Recipient OK,
    ,<,DATA,
    ,>,354 Start mail input; end with <CRLF>.<CRLF>,

    but still, no email in my inbox.

    I run my exchange 2007 SP3 server behind a TMG 2010 server, where I noticed for the SMTP application filter the possibility to change the max size of each SMTP command...on another forum I found something related to the header size but this is not my field of expertise.

    Many thanks in advance for any suggestion.

    Thanks

    Saturday, July 22, 2017 12:19 AM