locked
server 2008 won't shutdown or restart RRS feed

  • Question

  • system just hangs at "please wait for the terminal services configuration" on a blue screen
    not running terminal services on the server as anything other than being able to remote desktop in,ie:not publishing a terminal server
    just ias, iis, nps wsus ona vanilla 2008 enterprise
    very annoying and potentially dangerous as have to physically cut power which causes potential file issues on reboot
    any ideas please
    Tuesday, August 4, 2009 4:12 AM

Answers

  • Hi,

     

    Please understand that to troubleshoot this issue, we may need to perform debugging. However, in this forum, we do not provide debugging support. If you would like to perform debugging, please contact Microsoft Customer Support Service (CSS).

     

    To obtain the phone numbers for specific technology request, please refer to the website listed below:

    http://support.microsoft.com/default.aspx?scid=fh;EN-US;PHONENUMBERS

     

    If you are outside the US, please refer to http://support.microsoft.com for regional support phone numbers.

     

    Tim Quan - MSFT

     

     

    • Marked as answer by Tim Quan Friday, August 7, 2009 4:29 AM
    Friday, August 7, 2009 4:29 AM

All replies

  • Hi

    Sometimes Windows gets itself in a huff and won't shut down properly for some reason. You try to shutdown your system and nothing happens for a while, and then a dialog appears telling you that a task won't shut down and you can press End Now if you want to end it now, or you can wait for Windows to try and end it itself. Well you can avoid that hassle by making a simple registry tweak (but remember to backup your registry before editing it!). Here's how:

    1. Open Regedit and navigate to HKU\.Default\Control Panel\Desktop

    2. Double-click on AutoEndTasks

    3. Change the value from 0 to 1

    4. Reboot your machine

    Now hung processes will end automatically when you try to shutdown or reboot your machine. One caveat: a hung process means something is wrong, and anytime you kill a hung process (whether manually or automatically) you risk possible data loss.

    Deva

    Tuesday, August 4, 2009 6:37 AM
  • Have you enabled ASR feature in the server 2008.
    under system properties check for the automatic restart is enabled or not.

    Configure  DUMP as follows:

    How to select memory dump file options

    Three types of memory dump files can be generated. Select one before you manually trigger the dump file. To do this, follow these steps:
    1. Right-click My Computer, and then click Properties.
    2. Click the Advanced tab, and then click the Startup and Recovery button.
    3. Click Write Debugging Information, and then click to select either Complete Memory Dump, Kernel Memory Dump, or Small Memory Dump.

    Refer below link
    http://support.microsoft.com/kb/244139

    http://support.microsoft.com/kb/254649

    Steps to clean boot:

     

    1. Click Start->Run...-> type msconfig and press Enter

    2. Click Services tab and select Hide All Microsoft Services and Disable All third party Services.

    3. Click Startup tab and Disable All startup items

    4. Click OK and choose Restart

    5. After reboot, check whether the problem still occurs

    Tuesday, August 4, 2009 1:03 PM
  • Try unistall terminal services from teh server.

    Wednesday, August 5, 2009 2:27 PM
  • yes ASR is on but this appears as system is closing so not sure why that applies,Terminal services role is not installed,will have to try the dump file
    Wednesday, August 5, 2009 11:01 PM
  • Hi,

     

    Please understand that to troubleshoot this issue, we may need to perform debugging. However, in this forum, we do not provide debugging support. If you would like to perform debugging, please contact Microsoft Customer Support Service (CSS).

     

    To obtain the phone numbers for specific technology request, please refer to the website listed below:

    http://support.microsoft.com/default.aspx?scid=fh;EN-US;PHONENUMBERS

     

    If you are outside the US, please refer to http://support.microsoft.com for regional support phone numbers.

     

    Tim Quan - MSFT

     

     

    • Marked as answer by Tim Quan Friday, August 7, 2009 4:29 AM
    Friday, August 7, 2009 4:29 AM
  • Hi. Any news in this case?

    I have also now a 2008 server with the same issue.
    It's a VMWare ESX guest running DHCP, DNS, AD and WDS/MDT.

    It started doing this after a hotfix or a powerloss. Not sure what came first.
    Thursday, September 17, 2009 7:57 AM
  • I am receiving the same error on a MS Virtual on a host Running 2008 Hyper-V. When user is RDPed into the server and they go to restart it the screen will show "Please wait for the terminal services configuration"... and the boot him out. When I go to the console it is stuck on that screen and it has neither logged his session out or rebooted. Any help is appeaciated.
    Wednesday, February 17, 2010 4:59 PM
  • FWIW, this just happened to one of my clients on a 2008 SBS server during this week's patch Tuesday updates.  The power button was the only way to shut it down.
    Thursday, June 10, 2010 2:13 PM
  •  

     

    Hi,

     

    Please understand that to troubleshoot this issue, we may need to perform debugging. However, in this forum, we do not provide debugging support. If you would like to perform debugging, please contact Microsoft Customer Support Service (CSS).

     

    To obtain the phone numbers for specific technology request, please refer to the website listed below:

    http://support.microsoft.com/default.aspx?scid=fh;EN-US;PHONENUMBERS

     

    If you are outside the US, please refer to http://support.microsoft.com for regional support phone numbers.

     

    Tim Quan - MSFT

     

     

    What a completely useless solution.
    rob
    Monday, April 4, 2011 3:35 PM
  • Did you find the answer?  I just started to have exactly the same issue and need help.

    Friday, October 12, 2012 8:47 PM
  • Any luck with the answer?  I am facing the same issue.
    Friday, October 12, 2012 8:53 PM