locked
USB 2.0 PCI Hub with Windows 2000 RRS feed

  • Question


  • In a computer running W2K with SP4, I have tried many methods and drivers to get this hub working. The current driver version, via Hardware / Device Manager is Microsoft 19/06/2003 V.5.0.2195.6717.

    The Hub is recognised, but as soon as I plug any device into it such as external USB 2.0 hard drive or a mouse the computer goes haywire. The My Computer window takes forever to scan the computer and I cannot access the USB drive. If I use Internet Explorer, the mouse plugged into a USB 1.1 connector becomes erratic.

    The Safely Remove Hardware allows me to remove the USB drive and the computer returns to normal.

    I searched Knowledge Base but the method I found was incorrect and didn't help.

    Note that the external USB drive works well in the internal USB 1.1 hub that I have also fitted. Removing this hub makes no difference to the USB 2.0 problem.

    The PCI hub is from PC World with the make of PC Line and uses a VIA VT6212L chip. I have contacted PC World but their advice did not help.

    Any help would be greatfully received so that I can use the USB 2.0 speed instead of USB 1.1.

    I was advised to come here by a moderator on Microsoft Answers Forums but I still cannot find a Windows 2000 'place' - sorry.

    Tuesday, September 8, 2009 10:24 AM

All replies

  • Have you tried the following:

    1. Applied the latest version of your BIOS
    2. Tried another PCI slot
    3. Tried the USB card in another PC
    4. Tried another USB card, this is the most expensive option.  However a few people have had problems with the VT6121 chip on older machines.
    -Ken | http://ken.wagnerfamily.co.uk
    Tuesday, September 8, 2009 7:42 PM