none
MDT 2013 - ramdisk error RRS feed

  • Question

  • We are having a recent issue with imaging any HP computer (our Lenovos work without a problem) where as soon as you try to boot the machine from a bootable usb device; we receive a black screen with the following error:

    Windows failed to start.  A recent hardware or software change might be the cause.  To fix the problem:

    Status: 0xc0000017

    Info: There isn't enough memory available to create a ramdisk device.

    We are using MDT 2013 update 2 and ADK 10.1.14393.0 on a Windows Server 2012 R2.

    We've been able to image without any problems until now and nothing has changed recently - other than the occasional windows update.

    A few of the HP computers we are trying to image are HP 6200 Pro SFF and HP ProDesk 600 G2 SFF with 4-8 GB of Ram installed.

    I have tried repairing MDT/ADK install on the server and completely regenerated the boot images as well.

    Any advice or help would be greatly appreciated!

    Monday, February 13, 2017 8:23 PM

All replies

  • I would check your BIOS settings. Make sure it is set to UEFI only. 

    OR

    Open up your DeploymentShare, click the Windows PE Tab, select the platform, click the General tab and you will see a combo box named "Scratch space size". Change this then regenerate your media.

    Tuesday, February 14, 2017 1:28 PM
  • Thank you for your reply!

    Not all of the HP's we use are UEFI.

    The scratch space size was at 128 and I have changed it to 256 then completely regenerated the boot images, but no dice.

    I have also went through all of the drivers and removed any obsolete/duplicates.

    Thursday, February 16, 2017 2:55 PM
  • I found a workaround where we used the LiteTouchPE_x86.iso instead of the x64 and it worked...

    I can only assume that it is due to the fact that our LiteTouchPE_x64.iso is fairly large (2.67GB) and that's where the "memory" error was coming from.  Now I just need to figure out how to reduce the size of it...

    Thursday, February 23, 2017 8:17 PM
  • OMG, yes your litetouchPE_x64.iso is large (didn't notice this earlier). it should less than 512MB

    Please check the drivers and ensure that you are *ONLY* copying down the drivers *REQUIRED* to boot into WinPE. Create a WinPE driver selection profile if necessary.


    Keith Garner - Principal Consultant [owner] - http://DeploymentLive.com

    Thursday, February 23, 2017 10:41 PM
    Moderator
  • Ha yep, that was it.  We have a selection profile just for WinPE drivers, but it looks like ALL drivers were selected inadvertently.  
    Monday, February 27, 2017 3:52 PM
  • I am having this problem with a few HP desktops as well. How did you reduce the size? When I tried only doing network and mass storage drivers some of my images for laptops were failing. These laptops (x360 130 g2) have no built in Ethernet adapter and I have to use a usb-c network adapter for mdt WinPE boot to connect to my deployment share
    • Edited by Johnsonc881 Saturday, October 6, 2018 2:24 AM
    Saturday, October 6, 2018 2:14 AM
  • I have this issue in Lenovo P50 - W10x64.

    I changed to:

    - Secure boot enabled

    -UEFI only

    -Load default settings in BIOS

    I have a task sequence in SCCM that run Partition disk - UEFI for it.

    Thank u!

    Wednesday, March 27, 2019 10:51 PM