locked
Sequencing Quickbooks 2012 RRS feed

  • Question

  • A web search makes it look like I may be the first to tread QB2012 waters with App-V 4.6 SP1; if you know of a recipe, please let me know. Otherwise...

    I started with this: http://social.technet.microsoft.com/Forums/en-US/appvgeneralsequencing/thread/794bad8b-e8f1-4c25-b664-942b6bc21661

    But quickly found that QB2012 Setup.exe will not run from Sequencer 4.6 SP1. No errors, no nothing. Just a background cursor for a few seconds and I'm left staring indefinitely at the Sequencer window.

    I've also tried running Setup far enough to extract the installer files to their temp location. When I try to run those (Setup.exe or Quickbooks.msi) from Sequencer (or outside of it), it complains it can't find the 3rd party prereqs and terminates.

    But...

    I have found that I can run the Sequencer up to the point where it (fails to) start Setup.exe, and then run the un-extracted D:\Setup.exe straight off the CD from OUTSIDE the Sequencer, installing to the folder on Q: that Sequencer creates. Then, Setup completes in blissful ignorance of the Sequencing violence about to be wreaked upon it.

    When I then tell the Sequencer "I'm finished installing". It creates a 1.5GB package that at least appears to include the various QB2012 programs. I can also run them from the Feature Block panel.

    Haven't gotten far enough to test the package; in fact I need to package it again before I can, using what I learned this time.

    But before wasting a lot more time on this, will I be missing anything by launching Setup outside of the Sequencer?

    If so, any tricks I can try to get Setup to run from within the Sequencer?

    If I can make it work, I'll definitely post it to the Recipe forum.


    • Edited by JRV529088 Sunday, December 25, 2011 5:56 AM
    Sunday, December 25, 2011 4:28 AM

All replies

  • Hello,

    Try using the latest sequencer (http://social.technet.microsoft.com/Forums/en-US/appvclients/thread/d9ebed09-511b-4929-a190-3548a1576934).

    If that doesn't work - perhaps you can explain how you followed the recipe?


    Nicke Källén | The Knack| Twitter: @Znackattack
    Sunday, December 25, 2011 8:51 PM
  • I know it has been a while since you posted this, but I am having problems myself... same issue as yours.  Did you resolve it and how if you don't mind giving me some information.
    Tuesday, May 8, 2012 5:29 AM
  • Hello,

    I have (over the last 3 weeks) produced 12 packages for QB 2012 using Pro and Premier editions and not even remotely experiencing anything as to what you describe?
    What are you guys doing?

    Nicke Källén | The Knack| Twitter: @Znackattack

    Tuesday, May 8, 2012 11:19 AM
  • I burned a LOT of time on this and never did get QB to work after sequencing with App-V.

    I also tried ThinApp, InstallAware Virtualization, and one other whose name I can't recall. I worked with IV's support for a while but they ultimately admitted, IV wasn't designed for apps as large as QB.

    ThinApp was the only one that produced a usable result. It was almost perfect, and very fast and easy. But it had one major problem: Outlook integration through the bubble did not work, which meant users couldn't e-mail invoices (among other things). That was a deal-killer, here

    It probably would have worked if Outlook was in the bubble with QB, or in its own, linked bubble. But virtualizing OL with ThinApp is about as easy as virtualizing QB with App-V. I tried every recipe I could find without success, and noted with interest that for every recipe proclaiming that "THIS IS THE SECRET TO VIRTUALIZING OFFICE WITH THINAPP--NO, REALLY, IT IS!" there were 100 follow-up posts saying it didn't work! Besides which, I HAVE to have Outlook installed on the physical OS, and was concerned about the problems that it might cause to also have it in the bubble.

    Finally ran across a post in one of many threads from VMWare support saying that it was possible to virt OL with ThinApp, but you needed to open a support incident. That's where I through in the towel; I figured if it was so arcane that a human needed to lead you through it, there was no way I could use it in production. (It's bad enough with App-V!)

    So, the short answer is, no, I never solved it. And, aside from the publisher of the recipe I cited in my OP, and apparently Znack, below, I never found anyone else who had done it either. And I posted in a LOT of forums and did a LOT of web searches, because this has a very meaningful impact on our business plan.

    I figured out how to publish RemoteApps hosted on a VDI machine via RDWEB, and for QB tenants, we're going to do that, instead.

    Tuesday, May 8, 2012 6:00 PM
  • Hi Znack

    I have not tried it with App-V 4.6 SP1 HF5, which, I think, is the now-current version, but with HF4, the process I used was as described here:

    http://blogs.technet.com/b/appv/archive/2011/05/18/how-to-sequence-quickbooks-2011-using-microsoft-app-v-4-6.aspx

    It's the only App-V QB recipe I've found. My only substitutions were to use the VC++ & MSXML furnished with QB 2012, and of course, QB2012 Premier and App-V 4.6 SP1 HF4.

    I haven't looked to see if there are newer recipes in the last 3 months. Tried lots of variations with that one recipe over untold hours. Toward the bitter end, I actually got a package I could run. But (like many others), the QB window flashed past, then closed. That's when I had to move on.

    My reply to Srdjic, above, describes my non-App-V attempts; bottom line is that ThinApp ALMOST worked--and quite easily, in fact--except for the Outlook integration.

    As to what I did, I have pages of notes on my App-V adventures. But far too much to post. And every word irrelevant because none of it worked. I'm happy to try again, however, because it will be a lot cheaper than my fallback. Which makes the pertinant question this one:

    What did you do?


    • Edited by JRV529088 Tuesday, May 8, 2012 6:44 PM
    Tuesday, May 8, 2012 6:43 PM
  • Hello,

    That guide worked flawlessly for me... I followed the steps to the letter and never deviated from them in anyway.

    I even had a junior technician just run through the rest of the packages because we considered them easy, and he repeated the process (just follow the steps).

    I am a bit surprised that you attempted it with App-V 4.6 SP1 HF4 - does that also contain updates sequencer bits?


    Nicke Källén | The Knack| Twitter: @Znackattack

    Wednesday, May 9, 2012 7:12 AM
  • Hi Znack

    HF4, IIRC, does not update the sequencer. But the symptoms do not make clear whether it's a sequencer or client issue, or both. In any event, why would I NOT try it with the latest available HF's installed...wherever they go?

    Based on your results, I may update to HF5 or whatever's current and make one more pass at it, but a I have couple of specific questions:

    1. Were you able to launch QB Setup from the Run button in the Sequencer, or did you have to run it outside of the sequencer? (IME, QB 2012 Setup fails to run from Sequencer, a batch file, VBScript, or an AutoIt script. No error message, no nothing. Setup terminates itself quietly and immediately. This appears to be one of several ways Intuit has sabotaged automated deployment.) I don't know if running it from the Sequencer is important, but if it is, that might account for my problems.

    2. Have you tested this scenario with virtualized QB: Generate an Invoice, then use QB's Outlook integration to e-mail it through the bubble, with OL2010 installed physically on the host? This was ThinApp's only failure.

    Thursday, May 17, 2012 4:56 AM
  • Hello,

    I just made a video - didn't even take 10 minutes and even realized there were some excess steps.

    http://www.youtube.com/watch?v=YC4ysqU-QuE&feature=youtu.be

    I haven't been able to test that scenario (2) - I can't see why it shouldn't work. If it doesn't - there is probably some minor tweaking to it.


    Nicke Källén | The Knack| Twitter: @Znackattack


    • Edited by znack Friday, May 18, 2012 6:54 PM
    Friday, May 18, 2012 6:54 PM
  • Thanks, Znack.

    1. Agreed about step 7, though I've done it with and without. With ThinApp, QB ran without step 7 (or its ThinApp equivalent). But from all appearances, I did what you did.

    2. You have successfully run virtualized QB on an App-V client, correct? I've sequenced it lots of times. Runs just fine on the Sequencer. Running it on the client has been the problem. Same problem reported by "JD" and "Jacob" in the comments on the recipe, in fact.

    3. BTW the monitoring service that the script launches is part of the QB server, and is relevant only if the database file is hosted on the machine running QB. You should omit that if you're installing the QB client only (as I am). It needs to run on the machine that hosts the database.

    Further, though, if the machine is hosting a QB data file for multiple users, the QB server should be physically installed, in which case the service will already be running. In that regard, I believe the recipe is wrong.

    But I've done it both ways; that is not the problem, here.


    • Edited by JRV529088 Friday, May 18, 2012 7:50 PM
    Friday, May 18, 2012 7:47 PM
  • Hello,

    That package runs perfectly fine on the client - I can record that video to....

    App-V is never recommended to host server applications - so if hosting it for multiple users, a dedicated server would be recommended. Obviously - you could investigate Server App-V for that.

    The recipe seems right - if you would deploy it to a single user hosting the database. I guess that your scenario isn't the same as Microsoft posted intended scenario, or my video.


    Nicke Källén | The Knack| Twitter: @Znackattack

    Friday, May 18, 2012 7:58 PM
  • Thanks; don't need a video; just need to verify that it's been tested.

    Forget the server issue; you're not getting what I was saying, but it's beside the point so it doesn't matter. I'm not virtualizing the QB server or hosting the data file locally. I'm running Setup with the same option as you: "I'll be using QuickBooks on this computer." I should not have brought it up.

    Back on topic:

    What is the OS you've successfully tested the package with? I'd like to see if I can reproduce your results. I need to use it with App-V 4.6 SP1 HF5 for RDS on WS2008 R2 SP1 RDSH, but so far, that's the only client I've tried it with.

    Friday, May 18, 2012 10:09 PM
  • Hello,

    Windows 7 SP1 x86 and Windows 2008 R2 SP1 RDSH

    It was actually intended for 2008 r2 - so all testing have been performed on this platform


    Nicke Källén | The Knack| Twitter: @Znackattack

    Saturday, May 19, 2012 7:39 AM
  • Then I've already tried your configuration. And I've done it from 2 different sequencers: WS2008 R2 SP1 domain member & W7 x64 SP1 workgroup member. I guess I'll build a brand new sequencer and give it one last try.

    One other question occurs to me, though I think I'm grasping at straws now:

    Step 1 & 2 of the recipe has us gather extracted setup files from AppData and copy them elsewhere, but the only thing it says to do with them is to grab inetclnt.dll. If that's all we need from those folders (and we've both found we don't even need inetclnt.dll), seems silly for him to tell us we need to keep a complete copy of the folders elsewhere. Unless I misinterpreted the instructions.

    That makes me wonder if you did anything else with these extracted folders? Like run Setup from them? Here, I just ran Setup from a network copy of the CD.

    Saturday, May 19, 2012 2:35 PM
  • Hello,

    Wow - you missed a lot of the instructions. Have you really followed them? It would seem impossible without using the extracted files as step 4 and 7 directly relates to them.

    To avoid copying lots of excessive stuff - I only use the extracted media (and to avoid having the extraction occur while monitoring). Something which should be seen when installing both the additional Visual C++ components directly from the extracted media and starting the setup.exe.

    Did you watch the video?


    Nicke Källén | The Knack| Twitter: @Znackattack

    Sunday, May 20, 2012 2:45 PM
  • It just hit me. You, the recipe author, and I, made a huge--and incorrect--assumption: That we all start with the same setup media. In your case, a one-file download. In my case, a CD.

    There's nothing to extract with the CD; prereqs are all present and ready to install. That's why the author's well-intended instructions, and your rant, made no sense.

    What now seems clear is that (a) I'm sequencing correctly and (b) the problem is environmental and won't be solved on a message board. Therefore, my best bet is an MS support incident because I need someone that knows App-V internals.

    Sunday, May 20, 2012 6:25 PM
  • Hello,

    Well, the PRO-edition was downloaded from their homepage and everything was extracted as per the instructions in the recipe. However, the Premier-edition was sequenced from the CD - which we extracted as per the instructions from the recipe aswell.

    Your conclusion has me more confused ?


    Nicke Källén | The Knack| Twitter: @Znackattack

    Sunday, May 20, 2012 6:32 PM
  • There's nothing to extract on the CD, as it isn't compressed into one file.

    The pre-setup files the recipe calls for are:

    • [CD]:\QBOOKS\INETCLNT.DLL
    • [CD]:\ThirdParty\CRT9\*.*
    • [CD]:\Qbooks\MSXML.MSI

    Obviously, CABs and MSIs are being extracted during Setup, but there's nothing in the recipe or your video that indicates that ANY interaction with extractions beyond extracting the downloaded .EXE is required. That's why I found the recipe confusing, until I remembered today that QB is also available as a one-file download from Intuit, and THAT was what you extracted.

    Not sure what confuses you. It took 15 posts to learn that with the same procedure, software, OS, and App-V versions, you and I are seeing COMPLETELY different results. That's very useful info, because I had given up on App-V months ago, and it means the problem is environmental. But it's far from solved, and if I'm going to use App-V, I can't spend a lot more time on it.

    Thanks for your help.

    Sunday, May 20, 2012 9:59 PM
  • Hi Znack

    2. Have you tested this scenario with virtualized QB: Generate an Invoice, then use QB's Outlook integration to e-mail it through the bubble, with OL2010 installed physically on the host? This was ThinApp's only failure.

    Have confirmed the above on a x86 and x64 - works without issues

    Nicke Källén | The Knack| Twitter: @Znackattack


    • Edited by znack Tuesday, May 29, 2012 6:40 PM
    Tuesday, May 29, 2012 6:39 PM