locked
MP could not write out CCM setting to WMI. Possible cause: MP didn't get installed properly. Solution: Ensure MP setup succeeded; if not, reinstall MP RRS feed

  • Question

  • SMS_MP_CONTROL_MANAGER received START notification.    SMS_MP_CONTROL_MANAGER    6/21/2016 2:02:07 PM    3192 (0x0C78)
    MPStart(): Registered for Notifications.    SMS_MP_CONTROL_MANAGER    6/21/2016 2:02:07 PM    3192 (0x0C78)
    CMPControlManager::ReadConfigurationSettings(): m_pWmi->GetObject() failed - 0x80041010    SMS_MP_CONTROL_MANAGER    6/21/2016 2:02:07 PM    3192 (0x0C78)
    CMPControlManager::ReadConfigurationSettings(): Periodic Interval is 1800000    SMS_MP_CONTROL_MANAGER    6/21/2016 2:02:07 PM    3192 (0x0C78)
    CMPControlManager::ReadConfigurationSettings(): WINS Interval is 14400000    SMS_MP_CONTROL_MANAGER    6/21/2016 2:02:07 PM    3192 (0x0C78)
    MPStart(): ReadConfigurationSettings() returned 0x80041010.    SMS_MP_CONTROL_MANAGER    6/21/2016 2:02:07 PM    3192 (0x0C78)
    Querying MPHealthCheckIntervalInSeconds registry value returned a status of 2.    SMS_MP_CONTROL_MANAGER    6/21/2016 2:02:07 PM    3192 (0x0C78)
    Querying MPHealthCheckTimeoutInSeconds registry value returned a status of 2.    SMS_MP_CONTROL_MANAGER    6/21/2016 2:02:07 PM    3192 (0x0C78)
    Querying MPHealthCheckStatusMessageIntervalInSeconds registry value returned a status of 2.    SMS_MP_CONTROL_MANAGER    6/21/2016 2:02:07 PM    3192 (0x0C78)
    Querying NLBNodeAvailabilityState registry value returned a status of 2.    SMS_MP_CONTROL_MANAGER    6/21/2016 2:02:08 PM    3192 (0x0C78)
    MPStart(): Read all MP Settings.    SMS_MP_CONTROL_MANAGER    6/21/2016 2:02:08 PM    3192 (0x0C78)
    MPStart(): SSL disabled.    SMS_MP_CONTROL_MANAGER    6/21/2016 2:02:08 PM    3192 (0x0C78)
    CMPControlManager::WriteToCCMSettings(): WMI Connection established.    SMS_MP_CONTROL_MANAGER    6/21/2016 2:02:08 PM    3192 (0x0C78)
    CMPControlManager::WriteToCCMSettings(): pWmi->GetObject() failed - 0x80041002    SMS_MP_CONTROL_MANAGER    6/21/2016 2:02:08 PM    3192 (0x0C78)
    STATMSG: ID=5432 SEV=E LEV=M SOURCE="SMS Server" COMP="SMS_MP_CONTROL_MANAGER" SYS=APIL-SCCM.xxx.com SITE=APL PID=6308 TID=3192 GMTDATE=Tue Jun 21 08:32:08.008 2016 ISTR0="" ISTR1="" ISTR2="" ISTR3="" ISTR4="" ISTR5="" ISTR6="" ISTR7="" ISTR8="" ISTR9="" NUMATTRS=0    SMS_MP_CONTROL_MANAGER    6/21/2016 2:02:08 PM    3192 (0x0C78)
    MPStart(): WriteToCCMSettings() failed - 0x80041002    SMS_MP_CONTROL_MANAGER    6/21/2016 2:02:08 PM    3192 (0x0C78)
    SMS_MP_CONTROL_MANAGER failed to start with 0x80041002    SMS_MP_CONTROL_MANAGER    6/21/2016 2:02:08 PM    3192 (0x0C78)

    Please help me with this issue

    Step tried :

    All clients went inactive

    I tried reinstalling MP

    Cliet starting reporting however after few days again went inactive.

    Tuesday, June 21, 2016 8:45 AM

Answers

  • Hi,

        When you re-install the MP role, have you tried to monitor the installation process by examining the MPSetup.log and mpMSI.log on your site server?

        https://technet.microsoft.com/en-us/library/hh427342.aspx

        Also you could follow the troubleshoot steps described in this blog:

        http://www.systemcentercentral.com/mp-could-not-write-out-ccm-setting-to-wmi-error-in-system-center-2012-r2-configuration-manager/

    Best regards,

    Jimmy


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, June 22, 2016 2:41 PM

All replies

  • Hi,

        When you re-install the MP role, have you tried to monitor the installation process by examining the MPSetup.log and mpMSI.log on your site server?

        https://technet.microsoft.com/en-us/library/hh427342.aspx

        Also you could follow the troubleshoot steps described in this blog:

        http://www.systemcentercentral.com/mp-could-not-write-out-ccm-setting-to-wmi-error-in-system-center-2012-r2-configuration-manager/

    Best regards,

    Jimmy


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, June 22, 2016 2:41 PM
  • Mp setup log says MP installed successfully
    Tuesday, July 12, 2016 10:58 AM