none
Deployment Workbench unattend.xml RRS feed

  • Question

  • I am having problems with pushing a new image with Deployment Workbench. Everything seems to come over correctly except the computer name doesn't change to what I type in. I know the problem should reside in the unattend.xml so I go to the task sequence and try to open the unattend.xml and get a Operation failed to complete. Any help would be greatly appreciated.
    Thursday, March 3, 2011 4:43 PM

Answers

  • Hi,

     

    The issue should related with your unattend file.

     

    You can use WAIK to edit unattend file to change PC name, the pass for computer name is under

    Components>Microsoft-Windows-Shell-Setup>Computer name

    You have to add the entire Shell Setup Pass into your answer file, and the computer name, along with several other things will be an option on the right panel, when Shell Setup is highlighted in the main panel. 

     

     

    And the unattend file should like this:

     

    <settings pass="specialize">
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <ComputerName>_COMPUTERNAME_REPLACE_</ComputerName>
                <RegisteredOwner>SomePerson</RegisteredOwner>
                <RegisteredOrganization>SomeOrg</RegisteredOrganization>
                <TimeZone>Pacific Standard Time</TimeZone>
            </component>
        </settings>

     

     

    Hope that helps.

     

    Regards,

    Leo   Huang


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, March 7, 2011 8:55 AM
    Moderator