none
WinCPICStartup fails with WCPICSYSNOTREADY (0xF003) RRS feed

  • Question

  • Hi Community,

    We are trying to setup a HIS server with IP DLC peer connection. Everything seems normal and SNA manager shows that we are connected. However, we cannot send any messages from our program (C#, P/Invoke to wcpic32.dll) because the very first WinCPICStartup returns code 0xF003 (defined in wincpic.h as WCPICSYSNOTREADY, /* Underlying subsystem not started */).

    Our IP DLC link service is connected. SNA service and connection are active. Local and remote LU, appc mode, cpic symbolic names, users - all configured.

    What are we missing? We cannot find any information what could be the cause of this error code.

    We tried HIS versions from 2006 to 2016 (with latest updates as of Feb 2017), and tried different windows server versions from 2008 to 2016, both 32 and 64 bit.

    Thanks

    Sunday, February 26, 2017 10:47 PM

All replies

  • One idea is to search on your server to see if there are any other versions of wcpic32.dll on the box. Some terminal emulators also include the appc dll's and if the path to those dll's occur in the environment PATH before the HIS version of the dll's, then you can encounter this error. If you find other copies of wcpic32.dll, then you may need to change your PATH.
    Friday, March 3, 2017 9:01 PM
    Owner
  • Are there any other possibilities? I am seeing the same behavior and there are no other wcpic32.dlls on my machine other than the 32 and 64 bit versions in the Host Integration Server directories.
    Wednesday, June 14, 2017 6:26 AM
  • You mention this is with a C# program using pInvoke.  Sometimes this sort of issue could happen if the c# program is not compiled with the correct settings.  Please try compiling for an x64 system and go to the Project properties - select the "Build" tab on the left side, for the Platform target make sure the "Prefer 32-bit" option is unchecked.
    Friday, June 16, 2017 2:30 AM
    Owner