locked
DFS replication failed RRS feed

  • Question

  • hi, we have simple setup. A server in UK and branch office server in US, both are server 2008 r2 std, both sites are connected through site-to-site VPN. i setup DFS on the UK server which is giving me this error "The DFS Replication service failed to replicate the replicated folder at local path D:\foldername because the local path is not the fully qualified path name of an existing, accessible local folder. " can some one please guide me in right direction. thanks 
    Tuesday, June 21, 2011 8:41 AM

Answers

  • Hi,

    After doing some research, it seems that third party disk encryption software will cause the issue, that it mounts volumes long after the OS has booted and DFSR has started running. So you may test if if the DFSR will work if you wait enough time.

    Also you can have a try to delete and recreate DFSR group if the issue did not occur directly after create the group.

    If issue still exists, you can test to stop DFSR service, renamed database GUID (x:\System Volume information\dfsr) from elevated command prompt,


    TechNet Subscriber Support in forum |If you have any feedback on our support, please contact tnmff@microsoft.com.
    • Marked as answer by AskJaiCom Tuesday, July 5, 2011 10:12 AM
    Wednesday, June 29, 2011 7:09 AM
  • got it. it seems working now. will confirm tomorrow morning with the solution. thanks 

    the answer is, deleted the replication group, deleted the DFSprivate folder from the folders setup for replication, recreated the replication groups. working like a charm. cheers for the help Shaon. 

    • Edited by AskJaiCom Tuesday, July 5, 2011 10:12 AM answer
    • Marked as answer by AskJaiCom Tuesday, July 5, 2011 10:12 AM
    Monday, July 4, 2011 4:33 PM

All replies

  • i changed the value as suggested, waiting for the replication to occur. 
    Tuesday, June 21, 2011 3:26 PM
  • hi i got this message in the events on memeber server but replication is not happening. "The DFS Replication service successfully established an inbound connection with partner SERVER01 for replication group Groupname. "

    still the same error on primary server "The DFS Replication service failed to replicate the replicated folder at local path D:\foldername because the local path is not the fully qualified path name of an existing, accessible local folder."

    I have done the suggested changes without any luck. 

    Thursday, June 23, 2011 9:59 AM
  • Hi,

    Whether you renamed the Drive D, or whether it is a mapped drive instead of a local drive?

    Please have a test to crreate a test folder on another local drive, create replication with the branch office to see if same issue persists.


    TechNet Subscriber Support in forum |If you have any feedback on our support, please contact tnmff@microsoft.com.
    Friday, June 24, 2011 8:00 AM
  • hi Shaon, you are right. i tested creating a folder on C drive on both the servers which is working fine. so now what should i do about this error? the drive is not mapped drive, it is local which is on RAID-5. i cannot rename it now as all the folders on the drive have been shared. thanks
    Monday, June 27, 2011 11:02 PM
  • Hi,

    After doing some research, it seems that third party disk encryption software will cause the issue, that it mounts volumes long after the OS has booted and DFSR has started running. So you may test if if the DFSR will work if you wait enough time.

    Also you can have a try to delete and recreate DFSR group if the issue did not occur directly after create the group.

    If issue still exists, you can test to stop DFSR service, renamed database GUID (x:\System Volume information\dfsr) from elevated command prompt,


    TechNet Subscriber Support in forum |If you have any feedback on our support, please contact tnmff@microsoft.com.
    • Marked as answer by AskJaiCom Tuesday, July 5, 2011 10:12 AM
    Wednesday, June 29, 2011 7:09 AM
  • hi Shaon, i tried removing the replication group and recreated it with no luck. good sign is if i setup other folders from same drive they working a treat. there is definitely some thing wrong with the folders am trying to setup. i can see the DFSrprivate in those two folders in my backup application but i could not see that if i go into the drive itself. when you said renamed database GUID (x:\System Volume information\dfsr), what does that mean? i didnt get you. thanks 

    Monday, July 4, 2011 11:07 AM
  • got it. it seems working now. will confirm tomorrow morning with the solution. thanks 

    the answer is, deleted the replication group, deleted the DFSprivate folder from the folders setup for replication, recreated the replication groups. working like a charm. cheers for the help Shaon. 

    • Edited by AskJaiCom Tuesday, July 5, 2011 10:12 AM answer
    • Marked as answer by AskJaiCom Tuesday, July 5, 2011 10:12 AM
    Monday, July 4, 2011 4:33 PM