locked
Cannot connect to the Service Manager portal WCF service - Error when opening SM Portal RRS feed

  • Question

  • Greetings,

    I have tried everything I can think of to resolve this issue and I have tried all suggestions I have found on Technet.

    Basically, I had the SM Portal working on a test VM.  I am ready to use it in production but it is not working.  I deleted my test VM and built a new one.  On it, I have SharePoint 2010 Foundation and the SM Portal installed.  I have a valid self-signed cert.  the FQDN is correct (hqsrva24.dds.local) in both SharePoint and also in IIS.  I also made sure under Application Settings on the SM Portal IIS site points to the FQDN of the SCSMWebContentServer.

    So what happens when I go to the SM Portal (https://hqsrva24.dds.local:444/SMPortal) is it prompts me for a logon, which i put in and the site comes up.  But at that point the Silverlight portion is not loaded and I immediately get prompted for a logon.  I have tried several different logons, all of which have full access to the site in Sharepoint.  Eventually I get the error in red at the bottom of the screen "Cannot connect to the Service Manager portal WCF service"

    If I try to access the Web Content Server service on its own (https://hqsrva24.dds.local/Servicehost/services/DataAccessService.svc), I get a prompt to logon and none of my logons work.  i eventually get an unauthorized error. However; If I log into the server which SM Portal is on and go to https://localhost/Servicehost/services/DataAccessService.svc, I get no prompt to login and I get a "Metapublishing for this service is currently disabled."

    I'm out of ideas at this point, barring completely starting over (not just the SM portal but all of the Service Manager Suite).

    Tuesday, March 24, 2015 5:08 PM

Answers

  • I figured it out!

    I had made SPNs for both HTTP and HTTPS services.  I removed the HTTP SPNs and now it is working!

    • Marked as answer by Yan Li_ Wednesday, April 1, 2015 2:11 AM
    Friday, March 27, 2015 4:30 PM

All replies

  • UPDATE - So I can access the portal via Chrome and it works!

    But for some reason in IE, I continue to get the repeated logon prompt to connect to hqsrva24:443 and it eventually failes..

    Wednesday, March 25, 2015 4:07 PM
  • You added the URL of the portal to the Trusted Websites in IE?

    Andreas Baumgarten | H&D International Group

    Wednesday, March 25, 2015 6:35 PM
  • yep i did..

    Wednesday, March 25, 2015 6:48 PM
  • Ok so it was working in Chrome, but now in Chrome it is also getting the WCF error...  All I did was restart the portal server.

    Wednesday, March 25, 2015 7:19 PM
  • Man I've had this problem so many times and its almost always a different solution. Are you sure that either the Domain Users group or NT Authority\Authenticated Users have permissions to the site and service. remember the the two prompts are authenticating different things: the Sharepoint site and the application site (silverlight). Make sure users have permission in both SCSM and in Sharepoint. 

    - Slow is smooth and smooth is fast.


    • Edited by Pete Barbuto Wednesday, March 25, 2015 8:11 PM typo city mind your manners
    Wednesday, March 25, 2015 8:07 PM
  • Do you mean the folder permissions via IIS?

    And in Sharepoint, I assumed that the Service manager installer already allowed authenticated users?

    Hmm..

    Wednesday, March 25, 2015 9:49 PM
  • Oh I have already granted the accounts I am using Full Access within Sharepoint.  I see what you meant.  But since the Web Content Server is not in SP, where would I change those permissions?

    Wednesday, March 25, 2015 10:35 PM
  • I figured it out!

    I had made SPNs for both HTTP and HTTPS services.  I removed the HTTP SPNs and now it is working!

    • Marked as answer by Yan Li_ Wednesday, April 1, 2015 2:11 AM
    Friday, March 27, 2015 4:30 PM