locked
Application Error on some application since app-v 5 sp2 (event id 1000) RRS feed

  • Question

  • Hello Everybody

    Since we installed SP2 of App-V 5 we get Application Errors (event id 1000) ond some of our virtualised applications:

    faulty module:

    C:\Program Files\Microsoft Application Virtualization\Client\Subsystems\AppVEntSubsystems32.dll

    Does anybody know this? It's only on the client with SP2.

    Thanks in advance.

    KR,

    lurus

    Wednesday, December 18, 2013 2:14 PM

Answers

All replies

  • Is this happening with many of your applications? Do you have any names of the apps not working?

    PLEASE MARK ANY ANSWERS TO HELP OTHERS Blog: rorymon.com Twitter: @Rorymon

    Wednesday, December 18, 2013 5:55 PM
  • Yes, It's happening with some of our applications. One of them is "Citrix Quick Launch".

    Here's the event (german):

    Name der fehlerhaften Anwendung: wfcrun32.exe, Version: 13.4.0.25, Zeitstempel: 0x50cb8b56

    Name des fehlerhaften Moduls: AppVEntSubsystems32.dll, Version: 5.0.3361.0, Zeitstempel: 0x5278121f

    Ausnahmecode: 0xc0000005

    Fehleroffset: 0x000013b0

    ID des fehlerhaften Prozesses: 0x12c0

    Startzeit der fehlerhaften Anwendung: 0x01cefc7e1890ed8c

    Pfad der fehlerhaften Anwendung: C:\Program Files (x86)\Citrix\ICA Client\wfcrun32.exe

    Pfad des fehlerhaften Moduls: C:\Program Files\Microsoft Application Virtualization\Client\Subsystems\AppVEntSubsystems32.dll

    Berichtskennung: 5779566c-6871-11e3-8be3-005056c00008

    All crashed application named the same faulty module(AppVEntSubsystems32.dll):

    C:\Program Files\Microsoft Application Virtualization\Client\Subsystems\AppVEntSubsystems32.dll

    Thursday, December 19, 2013 5:59 AM
  • Hello,

    do you have any other filter driver / antivirus / monitoring tool installed on the system?


    Nicke Källén | The Knack| Twitter: @Znackattack

    Thursday, December 19, 2013 3:49 PM
  • Hi Nicke,

    I have the same problem as lurus, where some of the application I try to run with the AppV SP2 client fail with the above error, but work perfectly fine with run with the AppV SP1 client.The odd thing is that these applications were sequenced with the SP2 Sequencer.

    I originally thought that it might be related to the new feature in SP2 that handles VC++ runtimes, (as at that point all the applications that failed had VC++ runtimes) so when sequencing the applications I tried with the "Package pre-installed VC runtime dependencies and side-by-side assemblies" enable and disabled - but no joy. This theory what however blown away when another application which has VC++ runtimes worked with no errors.

    I get the same errors/behaviour when running on a vanilla installation of Windows 7 SP1 x86, this contains no GPOs, running with a admin account, no UAC and the only software installed are the pre-regs for the AppV Client and the AppV client itself.

    Regards
    Mickey

    Thursday, January 2, 2014 11:24 PM
  • Hello,

    If you run a Process Monitor when the issue occurs - does that reveal any Access Denied operations?


    Nicke Källén | The Knack| Twitter: @Znackattack

    Wednesday, January 8, 2014 10:35 PM
  • I also get this error in some applications, one of them the Citrix Receiver.

    One application goes a little bit further if I disable Virtual File System in the XML file, but then it might popup some Werfault.exe

    Using App-V 5 SP2 on Windows 8.1

    No Access Denied in ProcMon

    Thursday, January 9, 2014 10:45 AM
  • Hi Mickey,

    I am getting the same error with SAPGUI 720 and Business Explorer 720, which rely on Visual C++ runtimes. The sequences run fine on AppV 5 SP1. I am getting the following detailed error for SAP GUI:

    Problem Event Name:                        APPCRASH

    Application Name:                             saplogon.exe

      Application Version:                           7200.2.6.1062

      Application Timestamp:                     4da7f027

      Fault Module Name:                          AppVEntSubsystems32.dll

      Fault Module Version:                        5.0.3361.0

      Fault Module Timestamp:                  5278121f

      Exception Code:                                  c0000005

      Exception Offset:                                000013b0

      OS Version:                                          6.1.7601.2.1.0.256.4

      Locale ID:                                             2057

      Additional Information 1:                  4c0d

      Additional Information 2:                  4c0d4d78887f76d971d5d00f1f20a433

      Additional Information 3:                  4c0d

      Additional Information 4:                  4c0d4d78887f76d971d5d00f1f20a433

    I sequenced it again in AppV 5 SP2 and am getting the same problem. This is a critical app for us, and yet we want to upgrade to SP2 so that we can provision apps which have a right click context menu...

    Regards

    Zara

    Tuesday, January 14, 2014 12:06 PM
  • Hello,

    If it is a critical application that fails I would raise a support call with Microsoft.

    As the error (like previously one posted) is a generic fault of ACCESS_DENIED, perhaps running Process Monitor could reveal what activity that occurs in the background to allow any additional suggestions?


    Nicke Källén | The Knack| Twitter: @Znackattack

    Tuesday, January 14, 2014 2:23 PM
  • Thanks Nicke - I will do some further investigation using PROCMON as you suggested and post my findings.

    Zara Winters

    Wednesday, January 15, 2014 8:35 AM
  • Wednesday, January 15, 2014 7:40 PM
  • Hi Nicke

    Thanks for that, I will wait for the hotfix to be released.

    The applications that were causing the problem work fine in AppV 5 SP2 BETA - just not on the final release.

    Regards

    Zara

    Thursday, January 16, 2014 8:35 AM