locked
SoftGrid 4.5 Manager Installer Error 25120: "Unable to create required IIS virtual Directory"

    Question

  • (Environment:  Server 2008 running inside a Hyper-V VM.  IIS enabled, SQLExpress installed succesfully.)

     

    On this same server I attempt to install SoftGrid 4.5 Manager using the installer program.  I get all the way through it but it bombs at the end of the installation.

     It returns: "Error 25120. The installation program was unable to create the required IIS Virtual Directory"

     

    I've tried a couple of things in an effort to get it working.

     

    1) I enabled sharing on the content folder per Step 16 (page 15) of the SoftGrid 4.5 Trial Guide.

    Tried to re-install but got the same error.

     

    2) I made sure that Network Service has permissions to Launch by doing the following:

    1. Click Start, point to All Programs, point to Administrative Tools, and then click Component Services.

    2. Expand Component Services, expand Computers, expand My Computer, and then expand DCOM Config.

    3. Right-click IIS W3 Control, and then click Properties.

    4. Click the Security tab.

    5. Under Launch and Activation Permissions, click Edit.

    6. Click Add.

    7. In the Enter the object names to select box, type NETWORK SERVICE , and then click OK.

    8. Click NETWORK SERVICE, and then click to select the Local Activation check box in the Allow column.

    9. Click OK two times.

    (advice from: http://blogs.technet.com/softgrid/archive/2007/11/07/softgrid-error-a-remoting-error-occurred-error-code-0000c824.aspx)

     

    Srill no luck,  Then I went nuts....

    I did the above for just about every group user I could think of as possibly related...Including Local and System, SoftGrid Users... eta l

     

    Still no luck.

     

    Then I went after inetpub.   I shared that directory with all the people mentioned above.

     

    Still the same err:  Error 25120  Te Installation program was unable to create the required IIS virtual directory.

     

    As that last step was essentially grasping at straws.... I am at a dead end here.  Just going to reboot the VM and see if that magically does anything.

     

    Any other ideas?

     

    I tried calling into MS paid support but noone could help me because this is a beta product.

     

    Ken

    Tuesday, February 05, 2008 8:58 PM

Answers

  • according to zarbie:

    You need to install the IIS6 compatibility components for IIS7, including the Management scripts and Tools.

     

    Tuesday, February 05, 2008 11:25 PM

All replies

  • according to zarbie:

    You need to install the IIS6 compatibility components for IIS7, including the Management scripts and Tools.

     

    Tuesday, February 05, 2008 11:25 PM
  • Still having the same problem...although it seems to get further down its install script before bombing out again with the exact same error.

    Here is how I did it:

    To install the IIS 6.0 Management Compatibility Components by using the Windows Server 2008 Server Manager
    1. Click Start, click Administrative Tools and then Server Manager.

    2. In the left navigation pane, expand Roles, and then right-click Web Server (IIS) and select Add Role Services.

    3. On the Select Role Services pane, scroll down to IIS 6 Management Compatibility.

    4. Select the check boxes for IIS 6 Metabase Compatibility and IIS 6 Management Console.

    5. Click Next from the Select Role Services pane, and then click Install at the Confirm Installations Selections pane.

    6. Click Close to leave the Add Role Services wizard.

    reference:  http://technet.microsoft.com/en-us/library/bb397374(EXCHG.80).aspx

    I rebooted the VM tried rerunning the SoftGrid Manager installer and  still got the  same Error25120 message (unable to create the required IIS virtual directory.)

    Any more ideas?
    Wednesday, February 06, 2008 6:17 AM
  • I set up a fresh VM and started from scratch...and did as you suggested  (via Add Roles) .

    Low and behold, it worked!

    Thanks!

    The interesting thing was that before doing it on the fresh vm, I tried it on my old VM and it didn;t work.  Guess all the mucking about  confused it.

    Thanks
    Wednesday, February 06, 2008 9:41 AM
  • I had the same problem installing on 2008 build 6001 sp1, rather than starting over with a clean install I tinkered until I figured out another solution.

    What finally worked for me was to uninstall IIS7 completely… (reboot necessary)

    Then delete the remnants of IIS7  contained in the inetpub folder.  (reboot)

    Reinstall IIS 7 enabling

    IIS 7 management scripts and tools

    Under IIS 6 management Compatibility

    IIS 6 Metabase compatibility

    IIS 6 Management Console


    MSCVAS then installed cleanly with only the MMC 3 error box showing up during the install process.


    Good luck

    Friday, February 29, 2008 3:57 PM
  • Hi,
    I also recieve this error but I'm using a Windows 2003 server.
    Anyone else seen this with a 2003 server?

    Rickard
    Wednesday, July 02, 2008 1:09 PM
  • Please check the following knowledge base article:

     

    http://support.microsoft.com/kb/931625/en-us

     

    Reto

     

    Tuesday, July 08, 2008 7:36 AM
  •  

    Something else I found that fixed my issue:

     

    http://blogs.technet.com/virtualworld/archive/2008/03/26/beta-4-5-application-virtualization-error-25120.aspx

     

     

    Quote from the comments:

     

    Joey Liang said:

    I have comfirmed by two machine that "IIS Management Scripts and Tools" is also required to get rid of E25120. The item is checked in the picture but not mentioned.

    Wednesday, August 06, 2008 3:06 AM
  • I had same problem. Install "Role Services" - "Management Tools" - "IIS Management Script and Tools" . Then install VAPP Server and will be "OK"

    Windows 2008

    VAPP Virt Server 4.5

    Wednesday, September 24, 2008 11:55 AM
  • Found this problem on Windows 2003 Server. Due to the fact there was a permissions problem with IIS being installed prior to joining the server to a domain.

    We removed IIS from the server and reinstalled it after the machine was on the domain, and the instal worked.


    Cheers

    Greg Small

    ICO
    twitter: gregteamico

    Friday, December 05, 2008 5:59 AM
  • Hello, I'm installing the App-V in a Windows 2008 and had the same error message. I tried a lot of thing and I was able to finish the installation after I installed the IIS Management Scripts and Tools. Renato Tognato
    tognato_costa
    Wednesday, May 06, 2009 2:08 PM
  • You need to add these components to IIS

    Add the Web Server (IIS) role with the following role services enabled:

    ·         ASP.NET (and all required role services and features)

    ·         Windows Authentication

    ·         IIS Management Scripts and Tools

    ·         IIS 6 Management Compatibility

    I usede to face the same issue but after adding these components to IIS the installation completed successfully .
    Hope to works woth you

    Tuesday, December 08, 2009 9:00 AM
  • You need to add these components to IIS  

    Add the Web Server (IIS) role with the following role services enabled:

    ·         ASP.NET (and all required role services and features)

    ·         Windows Authentication

    ·         IIS Management Scripts and Tools

    ·         IIS 6 Management Compatibility

    I used to face the same issue but after adding these components to IIS the installation completed successfully .
    Hope to works woth you...

    Tuesday, December 08, 2009 9:03 AM
  • I know it's an old thread, but just in case anyone else is still getting this, I just found that the current (4.5.1.15580) installer generates the 25120 error ("Error 25120.The installation program was unable to create the required IIS virtual directory") if the Default web site is not called "Default Web Site". Have not yet determined source of problem (have proceeded for now with renaming it back to Default), but thought I'd throw it out in case anyone else gets same issue. Cheers, Danny

    Friday, January 08, 2010 1:56 PM
  • You need to add these components to IIS

    Add the Web Server (IIS) role with the following role services enabled:

    ·         ASP.NET (and all required role services and features)

    ·         Windows Authentication

    ·         IIS Management Scripts and Tools

    ·         IIS 6 Management Compatibility

    I usede to face the same issue but after adding these components to IIS the installation completed successfully .
    Hope to works woth you

    That worked, thanks!
    Tuesday, February 23, 2010 3:00 AM
  • You need to add these components to IIS

    Add the Web Server (IIS) role with the following role services enabled:

    ·         ASP.NET (and all required role services and features)

    ·         Windows Authentication

    ·         IIS Management Scripts and Tools

    ·         IIS 6 Management Compatibility

    I usede to face the same issue but after adding these components to IIS the installation completed successfully .
    Hope to works woth you


    Its correct...for me it works :)

    thanks...

     

    Friday, April 09, 2010 5:31 PM
  • Thanks!
    Tuesday, May 25, 2010 11:44 AM
  • Thanks for reply!

     

    Same issue with Windows 2008 R2 and APP-v 4.6

     

     


    MCP Windows XP / MCP ISA 2004 - Não esqueca de avaliar a resposta!
    Wednesday, August 04, 2010 6:37 PM
  • I got this issue with Windows 2008 R2 and App-v 4.6 too

    Wednesday, September 15, 2010 4:45 PM
  • message text in 'The installation program was unable to create the required IIS Virtual Directory' do not specify wich site.

    I solved issue (Windows 2008 R2 and App-v 4.6) by re-creating default web site (was missing).

    setup by default try to create the virtual directory in 'Default Web Site' (ID=1). on same machine I've another site using id=1

    if your 'Default Web Site' is missing, create a new site named 'Default Web Site', set folder to 'C:\inetpub\wwwroot' and ID=1: installation will work fine.

    Thursday, May 24, 2012 3:15 PM
  • BRILLIANT!!! Thanks Paolo! The 'Default Web Site' was causing the issue for our setup. We already had all the tools and scripts and IIS6 compatability installed. Uninstalled, reinstalled, rebooted, etc, etc... Uninstalled DotNet4 too but nothing worked until we added in the default website.

    Somewhere during the installation of MSCVMM, the self service portal took over port 80 and re-wrote the default website and directory settings. So deleting that, resetting it back to default web site and changing the ID to 1 resolved it!

    And the main site is still fine and servicing client requests while this is all happening!

    Happy days!


    anavagudweegend

    Friday, July 06, 2012 8:25 AM