locked
Office 2007 applications hang when opening documents on network share RRS feed

  • Question

  • Problem: in Word and Excel, if I double-click on a document stored on a network drive it will take minutes to open, or sometimes it will hang ("Not Responding"). If I open the same document from within Word/Excel, it *generally* opens okay. If I try to insert a network document as an attachment in Outlook, I get the same result (using the Insert menu).

    I've read other posts (non-Win7) about this problem, with a variety of fixes (e.g., change the location of template files), but none of them has worked for me, so I"m wondering whether the problem could be related to Win7.

    I've seen a lot of posts here about Office applications hanging when *saving* docs, but not when opening them, so it may be something about my system. Thanks in advance for guidance.

    My config: Win7 build 7000, Dell Latitude D630 with nVidia upgrade, 4GB/80GB, dual monitor. Updated daily with Windows Update. Software installed: Office 2007 Enterprise, Front Page 2003, Visio Professional 2007, Project Professional 2007, PDF 995, Adobe Acrobat 7.1.0 Professional, Firefox 3.x, and a variety of lesser-known apps. FWIW, PDF995 is installed because Acrobat 7 won't install a printer object, so I can't print from Acrobat.
    Tuesday, March 31, 2009 2:35 PM

Answers

  • Hi,

     

    According to our bug database, this issue is a known bug on Windows 7. It should be fixed in future version.

     

    Thank you for your understanding.

    Thursday, April 2, 2009 7:04 AM

All replies

  • Hi,

     

    According to our bug database, this issue is a known bug on Windows 7. It should be fixed in future version.

     

    Thank you for your understanding.

    Thursday, April 2, 2009 7:04 AM
  • Hi,

    I posted a similar problem here:

    I am currently using a Nas Drive - Dlink (DNS-323).

    When accessing Microsoft Office 2007 documents (word and excel so far) through the network NAS drive it seems to be quick; but when I map the network drive (to s:/) it opens and saves documents very slowly.

    So far I have tried mapping the NAS drive by browsing the network for the NAS drive which was slow; and secondly, I tried mapping it using the IP address of the NAS drive which was still slow.  Again, accessing the same documents through the Network is fine.

    Any ideas...?


     Are there any updates on the above proposed fix?


    Tuesday, November 10, 2009 3:50 AM
  • I'm experiencing the EXACT issue here (hang on open).  Excel eventually reports that the file is in use by "Unknown User" and asks to open Ready Only.  Word seems to open eventually.  Any updates on a possible fix?
    Tuesday, November 24, 2009 9:29 PM
  • Robinson Zhang,

    This is not a minor bug for our organization. We store all of our office documents on the network and all users need to be able to open office documents across the network. Promising a "future version" fix to an issue that is preventing my user's from being able to complete their jobs is very unprofessional indeed. Does your response represent Microsoft's official response to this issue?

    Thanks,

    Michael
    Monday, December 14, 2009 6:19 PM
  • Hello,

    We are expirencing the same issue. Basically, when opening a document (excel or word) on a network share the program hangs. It does reports downloading in bottom right status bar. Also, explorer seems to go out and discover the share. By that I mean, if you open the shared folder and click on the document, word or excel opens and you get the green status bar in explorer crawling across. (Hope that is clear!) Then after a minute or two (sometimes more) the document will open.

    I wonder if SBS 2008 has anything to do with this. We weren't expirencing this issue when running SBS 2003. All of our workstations are currently running Windows 7 but we did expirence this problem with Vista. Most workstations are running Office 2007. One system is running Office 2010 beta and experiencing the same issue.

    Any update/resolution would be helpful.

    Thanks,

    Jason

    Wednesday, December 16, 2009 3:35 PM
  • This is very much hurting our productivity times as well.  Ever since I upgraded a few users to Office 2007 this has been an issue with any Office documents taking up to 5 minutes to open.  Some users are on Windows 7 & some are on Vista.  Any solution to this yet?  Disabled antivirus both on the end user's pc's as well as the file server and still nothing.  Opening up these docs locally on their pc's works fine.  Just having issues over the network.  PLEASE HELP!!!
    Friday, December 18, 2009 2:34 PM
  • Hey Guys,

    I had the same issue on my network (at home). I tried every fix I could think of..but the documents just seemed to hang. At first thought, I figured it would have been the virus scanner checking the files on the client PC. I chose to ignore that network share for scanning. Still nothing..

    So I attempted to make the file read only on the server. Wham..it opened up right away. So I was thinking why would it open read only? Well because you are not attempting to access the file or change it in any way. So my next thought was check the server. I have a virus scanner on my server. I chose to exclude that file for scanning. Bam..it worked...without read only on.

    So my fix was to configure the virus scanner on the server to my liking so that it would not cause my client PC to lag. My server uses ESET NOD32.

    Good luck to everyone.

    -Scott
    Friday, December 18, 2009 6:32 PM
  • Any updates to this topic yet? We have the exact same situation (Vista Clients, SBS 2008 as a VS, McAfee Total Protection, Office 2007). We never experienced this with our SBS 2003 & XP clients. Migrated to Vista and noticed slight issues every once in a while opening a document. Migrated to SBS 2008 & Windows 7 Pro and issue happens everytime. It looks like a network/file/folder permission issue because once a single document is open there are no more issues unless you walk away from your computer for "Some" length of time. For instance, If I leave my computer for the evening, the next morning I am almost guaranteed to have the issue upon attempting to open my first documents for the day. If you continue to try and open the document it will eventually open (sometimes 6-8 times) unless you get the infamous "document in use - attempt to open a read only copy"! What is very weird is that once a document has been successfully opened from the server, all other files will open without any issue. But . . . . if you leave the computer for a few hours without using it and attempt to open a document, we will get the same issue! Very sporadic. The next finding I have is that if I am having the issue and a computer user next to me is not having the issue - I will ask them to open same file that I am having an issue with and they can open it but I cannot!! Perhaps a time-out because of credentials/authentication? Perhaps sync files issue? Not sure but we are patched to the hilt with every available SBS & Windows 7 update and still have the issue. Our Vista clients on the network experience same issues however no where near as often as our Windows 7 clients. Very Very Strange.
    Thursday, March 11, 2010 11:26 AM
  • Ditto.  What the heck is going on?  Doesn't MS have a fix?
    sT
    Friday, March 12, 2010 4:48 PM
  • Hey Guys, im not sure what system you are using Office 2007 on, (local, terminal services?) ..But i think the issue might have to do with the Office application itself, not so much the network drive aspect.

    But thought id provide this just in case.

    Microsoft JUST released a Hotfix for the Office 2007 suite that corrects the crashing / hanging issues.

    Here is the link with all the information leading up to it...the download link and another article explaining in more depth can be found near the bottom of the posts. But its a good idea to scan all the posts.

    http://serverfault.com/questions/79690/word-2007-crashes-on-server-2008-r2-terminal-services


    Take a look, hope this helps.

    If you find anything else, feel free to email me.

    mrotarius@c3networx.com



    • Proposed as answer by DCas82 Tuesday, June 8, 2010 8:43 AM
    Friday, March 12, 2010 7:54 PM
  • Hello,

    Just to chime in, our issue is IDENTICAL to Jason4101's description.  Any help would be greatly appreciated.  Don't think the KB removal will help as we don't have it.

    Thanks,

    Vance

    Friday, March 12, 2010 10:58 PM
  • Hi Vance,

    I have opened a seperate case on this issue and I'm in the process of uploading some logs for review. I'll let you know if anything useful comes out of it.

    Oh and I didn't have the update installed either.

    Jason
    Monday, March 15, 2010 2:34 PM
  • This latest hotfix hasn't helped our issue.  We still experience funny delays opening Office 2007 documents from network shares (typically Excel, though Word does it too from time to time).  I've tried various methods in an attempt to disable DDE, but this appears to break the double-click Open document functionality completely.  The network on which we have these troubles are both SBS 2008 and Windows 7 + Office 2007 workstations.
    sT
    Wednesday, March 17, 2010 8:22 PM
  • It is actually to the point where it is incredibly disruptive and counter-productive. I can attempt to open a document at least 7-8 times before it will actually open (or I at least get the typical  . . . file in use open a read only copy). We've tried everything under the sun and still no luck. Amazingly though, once a document does get openend . . .even if I close the Microsoft Application - all other files open perfect (unless of course you walk away from your computer for some extended time - like what is happening to me as I type this as I just got to work this morning!!! It is just like clock-work, leave for the evening with no applications opened, come in the morning and can't access my first few documents that I attempt to open from the network!!

    POSSIBLE IMPORTANT NOTE: We redirect our Documents, Favorites, & Desktop to the server. Anyone else have a different configuration? Not sure if this would contribute.

    Thursday, March 25, 2010 10:11 AM
  • Hi, This is the first time I am logging into this forum. I have a Dlink (DNS-321). I too have the issue with opening Word Doc on NAS drive being slow using a mapped drive letter. This started happening only recently. However, as for me, I have found a work around for now. I just go directly to the NAS drive through windows explorer and browse to the folder and open up the file from there.  The speed is the same like I am opening up a local file. Hope this helps someone here.
    Saturday, April 3, 2010 2:59 PM
  • Same problem here...  SBS 2008, Office 2007 on Win7 clients.  First load takes forever, then its fine for awhile, so +1 to what Jason4101 describes

    Any ETA on a fix for this?

    Any work around?

    Has anybody figured out a way to force this to happen?  I have seen it happen, but once something loads fine, all other documents load quick, then it just works again for... X hours... then all of a sudden it takes forever again...  No rhyme or reason.

     

    Thanks!

    • Proposed as answer by SBURLESON Friday, April 16, 2010 1:38 PM
    Friday, April 16, 2010 5:49 AM
  • Ok Ladies & Gentlemen - myself and our internal IT team believe that we have finally determined the cause of all issues. We have tested this in-house for the past 2 weeks and the issue has been fully resolved. No more hanging, no more freezing, no more "file in use read only", etc..... We did some research which led us to a small article about SMB2! When we disabled SMB2 on our Vista & Windows 7 clients as well as our 2008 SBS the issue immediately went away. Here is a quick link to the article which discusses disabling SMB2: http://www.petri.co.il/how-to-disable-smb-2-on-windows-vista-or-server-2008.htm

    Please be aware that if you decide to search on disabling SMB2 or about issues with SMB2 you will see alot of grief out there! A lot of which are related to all of our issues as presented above. Try disabling SMB2 and post your experience!! Good luck all.

    • Proposed as answer by SBURLESON Friday, April 16, 2010 1:44 PM
    Friday, April 16, 2010 1:43 PM
  • Hi, the MS technician I was working with on my forum post told me that I would have to call MS to work on this issue. It wasn't something they could fix through the forum. This was after they had me gather process monitor logs and network monitor logs during the time that the issue occurred. Apparently, there was nothing in the logs that gave them any idea as to what was going on. This is ridiculous. With as many people experiencing the same thing, how can this not be resolved by now?!

    HELLO MICROSOFT WE NEED THIS CORRECTED ASAP!!

    Friday, April 16, 2010 2:04 PM
  • One of our clients is experiencing the same problem.  We have just migrated them to SBS 2008, Win 7 & Office 2007.  The problem seems to only be occuring with office files in non-xml format i.e. .doc, .xls .ppt.  Currently the problem hasn't occured with .docx, .xlsx, .pptx.

    It happens most frequently on the first doc/xls file you first open in a morning.  One strange behaviour is that if you start to open it on a client machine and it hangs, if you open exactly the same file on another client it will open straight away.

    There has to be a fix around shortly, it is causing no end of problems!

    Monday, April 19, 2010 3:45 PM
  • Anybody knows if there is already a fix for this issue?
    Tuesday, May 11, 2010 8:28 AM
  • Has anyone tried the solution that I posted back on April 16th?????? Since disabling SMB2 on our network we have not had one issue with hanging files at all. I am definitely convinced that this is the issue (now we just need a patch from MS so that SMB2 can be active!) Please give some feedback! We spend counteless hours and unproductive time trying to find a solution and finally got an interim solution. So, we know what the issue is but not why it happens.
    Thursday, May 13, 2010 10:35 AM
  • I would like to know if anyone has tried the solution you provided on the 16th as well.  I would like to mention that We are having the same issue.  However, our Vista clients do not experience the issue, as your solution on the 16th implies.  ONLY Windows 7 clients, with Office 2007 or Office 2010, upon first access of a network document.  The vista machines have no issues.  I'm curious, was your problem with the Vista clients as well?  If so, maybe we have different issues?
    Monday, May 17, 2010 3:43 PM
  • YES, the answer proposed on the 16th, disabling smb2, does work.  We only had to disable the smb on the server.  We had to reboot the server, then had to reboot each workstation that was connected to the domain controller.  But results were promising.  We tested this solution and it does the trick.

    Thank you for your help.

    Tuesday, May 18, 2010 3:14 PM
  • I have the same issue, only it includes Word and Excel files on the local disk (According the client ... i havent verified this).  Did any of you have that problem as well?

    I have just implemented the fix on the server - will post results soon

    Thursday, May 20, 2010 2:55 PM
  • Hi,

    I was having the same issue, which was halting our Windows 7 rollout (although it's not urgent).  There are only 2 of us on Windows 7 just now, myself on Professional 32-bit and a colleague on 64-bit Pro, and we both installed a few updates recently, which seems to have resolved this issue.

    Excel and Word files (both 2003 xls and doc formats, as above) had the same 4-5 minute opening and saving times, but have had no issues at all since the updates.  There were two in particular that were Office related:

     

    Update for the 2007 Microsoft Office System (KB981715)

    Update for Microsoft Office Word 2007 (KB974561)

     

    Since it seemed to cure the hanging with both Word and Excel, I suspect the former worked the magic.

    Let us know if applying the updates resolves this patience-testing issue for anyone else.

    Thanks

    IC

    Wednesday, May 26, 2010 2:57 PM
  • Thank goodness that I am not the only one having this issue! I have been going crazy with this error, especially when logs show nothing and it seems to happen randomly. Nothing has worked and I was especially dismayed when switching to Office 2010 did not resolve the error. So far, disabling SMB2 seems to be a solution that works, but my question is what ramifications occur as a result of disabling SMB2 in other areas? Once I determine that I will try that change and report as to whether or not this is the problem. Thanks!

     

    Mike

    Friday, June 4, 2010 3:42 PM
  • How can Microsoft not have a fix for this yet?  This question was posted over a year ago.  I have the same issue since we upgraded our workstations to 64-bit Windows 7/Office 2007.  We made no changes to our Dell server OS, MS Server 2008.  It would make sense that with the upgrade we may have automatically stared using SMB2, which could be at the heart of this problem.  I am looking into disabling SMB2 on our server and workstations, but was hoping MS would have come up with a fix by now.  This was a "known issue" back in April 2009!  Anything???
    Friday, June 4, 2010 8:29 PM
  • Its June 2010 .. What's the June 2010 solution to this problem?  We are having clients left and right having issues opening up the "first document" after being away from the computer for extended period of time or coming in the next morning and opening the first document.
    Sunday, June 6, 2010 5:17 AM
  • Scott,

    I had similar issues on my file servers.  I'm running Symantec Endpoint Protection on clients as well as the server.  I excluded the file shares on the server from anti-virus.  My performance problems with files hanging for an inordanant amount of time went away.  All my files open immediately.

    -Frank

    Sunday, June 6, 2010 5:50 AM
  • I did some poking with the antivirus. I'm running SBS 2008 and a Win 7 system and I have all these same problems. I disabled realtime protection on MS Security Essentials and boom, the files opened right away. I'm not even running Symantec on this system, Microsoft should be ahead of this one! the permanent fix is to exclude the network drive. however that is a security hole!!! but its working
    Monday, June 7, 2010 1:43 AM
  • We are running Trend Micro at most sites including our office and we dont experience the issue.   Do you think disabling SMB 2.0 will resolve the issue?  At one client I completely disabld SMB 2 on the SBS 2008 server and at another client I disabled SMB2 on just one of the Windows 7 x64 workstations and left the other Win 7 x64 computer alone.  Let's see what happens this week.
    Monday, June 7, 2010 4:52 AM
  • Steve, we only had to disable smb2 on the server.  We hoped that would be enough, and it was, keeping the solution very simple.
    Mark Webber
    Monday, June 7, 2010 3:11 PM
  • We disabled smb2 on one of the servers and so far not complaints!  At another client we disabled smb2 on a workstation and left the other workstation alone, should have an answer back tomorrow as to any issues.  I also think disabling smb2 is the solution.
    Tuesday, June 8, 2010 6:49 AM
  • I tried everything in my post among other things and the SMB solution seemed to almost work, however after the first few documents opened the users on the network began experiencing the same issue.  In my situation the clients are running Windows XP Pro SP3.  I also have Endpoint installed, however, I have eliminated that as a factor as disabling it and configuring exclusions as well as disabling auto-protect didn't seem to matter.
    Wednesday, June 9, 2010 4:29 PM
  • So far disabling SMB2 has resolve opening documents and random application timeout issues at two clients.  I'll update everyone if we find out any more information.  For right now, disable SMB2 if your not dependent on any of it's features.

    Thursday, June 10, 2010 6:47 AM
  • Just disabled SMB2 per Petri on Server and workstations, we have not had any problem with hanging apps since.  Why on earth has MS ignored this issue?  What is the benefit of letting your customers dig this up on their own?  I assume SMB2 had some advantages over SMB1 that I am not taking advantage of.  Get with it boys, the days of abusing your customers has to end.
    Wednesday, June 23, 2010 10:30 PM
  • We too are suffering from this issue. I have been looking for almost a year now. Windows 7 Clients / Server 2008 Enterprise / Office 2007.  Like what SBURLESON said all other Excel files open fine after passing the first file. All other XP stations open fine, even those that have Office 2007. Excel files that are local opens fine, only the ones on the network drive takes forever to open. This is definitely not an Anti-Virus issue.


    You have to disable SMB2 on both the client and server to make this work. Remember to reboot the client and server after disabling. This is a temporary fix for now.. . .. .. . .. .. . ..

    Thursday, June 24, 2010 3:05 PM
  • gigarange,

    You do not need to disable on the client.  After you disable on the server, restart the server, restart the workstation, and you will not experience the issue.


    Mark Webber
    Friday, June 25, 2010 12:40 AM
  • I would also like to report the same issue.

    Brand new equipment and network with SBS 2008 and Win 7 Desktops all very good spec and gigabit lan.

    Its is slow to open Office docs from the shared drive and slow to attach office docs in Outlook.

    Im going to try the SMBv2 fix but surely there has to be a proper MS solution soon.

    Thursday, July 1, 2010 4:15 PM
  • We are having the same issues with Word opening slowly or not at all.  I just disabled SMB2 on the server so we'll see what happens.  Main reason for posting was to help make this thread longer and voice my disgust with Microsoft, SBS2008 and Office 2007/2010.  Churn out ____ after ____ after ____ and expect us to eat it.  Meh.
    Thursday, July 1, 2010 6:56 PM
  • I am having the same issue with any PC running Office 2007 or higher. All users are running XP-Pro and all of the users running Office 2003 have no problems at all.

    All the 2007 users have to copy a document off the NAS device, modify & save it on the local drive and then copy it back with explorer.

    If I create a .TXT document on the NAS device and open it with Notebook - no problems, but if I try and open it with Word or Excel 2007 the file is "in Use" and cannot be opened.

    The delay in a fix from Micro$oft is simply unacceptable. This thread has been running for over a year and a Office 2010 has been released with the same problem.

    Maybe Open Office would be the way to go....

    Wednesday, July 7, 2010 5:52 AM
  • We do have same issue with shared excel sheet (placed in network drive - SAN), previously we were using the same file with office 2003 without any issues.

    The problem reported after upgraded (clean installation) office 2007 with sp2

    I would appreciate Microsoft have any update/hot fix for this issue immediately

     

    Friday, July 9, 2010 9:56 AM
  • I've been dealing with a similar if not identical problem.  I will look at the SMB2 solution, but I found another work-around (seems all we can do since MS won't fix their problems themselves).  I found on non-MS boards that Office is using a feature called "DDE".  I downloaded a tool called DDESpy.  When you open an office document with dde enabled, there is a slew of messaging going on until the thing times out after 40-60 seconds and the document opens.  If you open the document from within an Office Program nothing happens.  The hang only occurs when you double-click on the document to launch the program and open the file.

    A temp fix was to disable DDE in the file types .doc, .docx, .xls, .xlsx, and .pdf.  But office will eventually catch on and repair the fix (turning dde back on).  In all this time, I still don't know what DDE is trying to do.  Microsoft will not offer any advice as to how to stop the DDE for good, only that there is an underlying problem that is causing this problem...typical.

    Anyway, if you want to see if your having a problem related to the DDE, here are disabling instructions:  http://www.dslreports.com/forum/r20492291-

    Friday, July 9, 2010 6:50 PM
  • Add me to the list of having the same issue.  Redirected user folders and file server file access issues.  Windows 7 clients (all Office 2007 Small Business) seem to be the only ones affected.  Server is Small Business 2008 x64.

    I'll try disabling SMB2, but that is not a solution, just a work around.

    Tuesday, July 13, 2010 2:58 PM
  • Been fighting this problem as well with a Win7 Ultimate laptop connecting to a network share on a SBS 2003 domain. After the machine has been up for awhile, attempting to browse the network share with explorer will result in the above described behavior. (green bar that never finishes) Attempts to access the share from within an application usually results in locking the application. Only way to reconnect with the server is to reboot, which seems to resolve the problem for a short time. No other clients on this network (XP Pro SP3) ever have this problem.

    Also have another issue that I suspect is related: If the above happens, doing a shut-down will usually result in what I call "perma-logoff", where the screen will say "logging off" indefinitely. You gracefully escape this. The only way to escape this is to pull the power and then remove the battery. Upon reboot, and are admonished for a unclean shutdown, and then offered safe mode.

    As an IT consultant, I am halting all proposed Win7 deployments for all my clients until this is definitively resolved.  This is a serious problem.

    Wednesday, July 21, 2010 2:37 AM
  • Office 2007 or Office 2003?

    Have you done wireshark to see what's going on?  I have Win7 on 2k3 and now 2k8 and not seen issues.  I do have SMB signing off but I have not disable SMBv2

    Tuesday, July 27, 2010 2:53 AM
    Answerer
  • I've been dealing with a similar if not identical problem.  I will look at the SMB2 solution, but I found another work-around (seems all we can do since MS won't fix their problems themselves).  I found on non-MS boards that Office is using a feature called "DDE".  I downloaded a tool called DDESpy.  When you open an office document with dde enabled, there is a slew of messaging going on until the thing times out after 40-60 seconds and the document opens.  If you open the document from within an Office Program nothing happens.  The hang only occurs when you double-click on the document to launch the program and open the file.

    A temp fix was to disable DDE in the file types .doc, .docx, .xls, .xlsx, and .pdf.  But office will eventually catch on and repair the fix (turning dde back on).  In all this time, I still don't know what DDE is trying to do.  Microsoft will not offer any advice as to how to stop the DDE for good, only that there is an underlying problem that is causing this problem...typical.

    Anyway, if you want to see if your having a problem related to the DDE, here are disabling instructions:  http://www.dslreports.com/forum/r20492291-

    This worked for my client.  Applied it about 2 weeks ago and no issues related since.  The SMBv2 thing did not work for me, but the disabling of DDE did.
    • Proposed as answer by konggg Tuesday, November 16, 2010 5:00 PM
    Friday, July 30, 2010 6:48 PM
  • try adding the network file server as a trusted location.  

     

    options, trust center, trusted locations.  check option to "Allow Trusted Locations on my network"   then add the new network location.  voila

     

     

    • Proposed as answer by TechZupportAbq Thursday, November 18, 2010 12:41 AM
    Tuesday, November 16, 2010 5:02 PM
  • Thanks konggg, your solution/workaround worked for me.
    (have shutdown, restarted, hibernated and sleep, all worked multiple times)

    Windows 7, 64bit, Office 2007, SP2 + updates, Lenovo T510
    SBS 2008, Networked "My Documents"
    Word/Excel was freezing, Laptop would not shutdown + high disk activity

    --
    I tried the Firewire powersaving setting, it worked once.

    Tried repair install of 2007, and uninstall/reinstall + sp2 + updates. - froze first time trying to shutdown.
    --

    At this network, there is also a pending issue of the Autodiscover (for outlook) having a different hostname than the physical server, causing some users to get an occasional prompt for username/pass when using Outlook. I believe the hostname might not get resolved because it doesn't exist. This might throw the shutdown into a loop.. Maybe you have a similar issue in your network? Maybe resolving that issue would keep this from happening?

    Whatever the case, THANK YOU (and the rest of your brave souls!)

    UPDATE:
    I did not enter a location the first time, I simply enable the checkbox to allow.
    To test, I added the server location and the shutdown freeze returned... ???!!!
    Removed the new location and left check mark checked = successful shutdown..
    Go figure.

    • Proposed as answer by trubbelsjoeter Thursday, January 20, 2011 11:04 AM
    Thursday, November 18, 2010 12:49 AM
  • Hello,

    it's 2011 already and i discovered 2 solutions that helped in a few cases solve network issues that are similar to what 's discussed here.

    Tried these on Office 2003, 2007 and 2010 on XP, Vista 32/64 and Windows 7 32/64.

    - stop all running applications and make sure you have local Administrator privileges

    - stop windows-update from automatically install updates (do it by hand in the future)

    - open Add/Remove Software Controlpanel. - show all updates

    - find KB2412171 and remove it!

    - open the dialog for Add/Remove Windows Components (same controlpanel Add/Remove softw.)

    - remove check for Remote differential compression (takes some time)

    Hope this will help you also.

    Thursday, January 20, 2011 11:26 AM
  • I have the exact issues discussed by some of these others.  Lawyers office word 2007 locs when opening network docs.  There's also a 3rd party plugin called Snapdone that could be in play?  But anyways.  I will try the above suggestions tonight and see.

    Thanks for all the info!

    Thursday, February 3, 2011 9:42 PM
  • I have a very similar problem with Word. Some of the posts below are even closer to my problem. (Word hangs when I save to my NAS.)

    However I was able to find a work around.

    I started using Open Office.

    Problem solved!

    • Proposed as answer by YvetteW Thursday, September 8, 2011 2:50 PM
    • Unproposed as answer by YvetteW Thursday, September 8, 2011 2:51 PM
    Monday, March 21, 2011 3:06 AM
  • I started using Open Office.

    Problem solved!


    Not a fix for most of us in corporate enviroments.

     

    Have the same issue here with Office 2010 (on Win7) users opening files from a Samba server and not being able to save changes back.

    Office 2000, XP and 2003 users on Windows 2000 and XP do not have the same problem.

    It seems very intermittant, users have taken to hammering the save button until it eventually works(!).

    Tuesday, August 23, 2011 1:41 PM
  • What is Open Office? We purchased all this new software from Microsoft and our production time is down due to this Not Responding error. Microsoft wants $259.00 to see if they can detect the problem.
    Thursday, September 8, 2011 2:52 PM
  • Also check out this KB article from MS, this has helped some people in our organization though others still have delays opening:
    http://support.microsoft.com/default.aspx?scid=kb;en-US;2501584

    When opening documents on network drives it takes a very long time or does not load at all. They may get an error about an OLE Action is waiting to process.

    This is because of the Office File Validation (OFV) Add-in for Office 2003:
    <small>See Microsoft KB 2501584 (http://support.microsoft.com/default.aspx?scid=kb;en-US;2501584)</small>

      • Workbooks stored in a network location open slower over the network in Excel 2003 than they did without the OFV installed. The decrease in performance depends on the size of the workbook and bandwidth of the network and in some scenarios can seem to hang Excel.

      Cause:
      The OFV reads the file to determine whether the file is trustworthy before it opens the file. When this is done over the network it reduces performance because of the network traffic when reading in the parts of the workbook.

    • You can also use the EnableOnLoad registry entry to configure how you want Excel to handle opening workbooks for the OFV. By default, the EnableOnLoad entry is not present in the Windows registry. To add the EnableOnLoad entry to the Windows registry:
    1. Exit Excel.
    2. Click Start, click Run, type regedit, and then click OK.
    3. Locate and then click to select the following registry key: HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\
    4. After you select the key that is specified in step 3, point to New on the Edit menu, and then click Key.
    5. Type Excel, and then press ENTER.
    6. Select Excel, point to New on the Edit menu, and then click Key.
    7. Type Security, and then press ENTER.
    8. Select Security, point to New on the Edit menu, and then click Key.
    9. Type FileValidation, and then press ENTER.
    10. Select FileValidation, point to New on the Edit menu, and then click DWORD Value.
    11. Type EnableOnLoad, and then press ENTER. Note: The default value is 0 which disables the validation.
    12. On the File menu, click Exit to quit Registry Editor.
    • Edited by AMills357 Thursday, September 20, 2012 2:43 PM Update
    Thursday, September 20, 2012 2:41 PM