locked
People search box - my custom properties don't show up. RRS feed

  • Question

  • I am trying to add custom mapped properties to my people search box.  When I modify the people search box, under miscellaneous there is a field called properties.  It already has things like skills, responsibility, etc but those don't show on the page at all.  I also added my own, but they don't show either.  I just see a single box.  If I click on "Search Options" (not in the web part properties, but on the web part when rendered), I see Find People By.. (Last Name, First Name, Job Title, and Person Keywords).  These don't come from those properties either.  How can I modify the people search control to add custom properties?
    Wednesday, April 6, 2011 4:14 PM

Answers

  • SharePoint has a bug in it's people search box.  If the XML is not valid, the web part will ignore it.

    The default xml is invalid.  It has a closing property tag "</Property>", but there is never one that is open.  All Property tags close themselves.  Remove this, and it starts to work.

     

     

    • Marked as answer by jaredmill Wednesday, April 6, 2011 9:22 PM
    Wednesday, April 6, 2011 9:19 PM

All replies

  • SharePoint has a bug in it's people search box.  If the XML is not valid, the web part will ignore it.

    The default xml is invalid.  It has a closing property tag "</Property>", but there is never one that is open.  All Property tags close themselves.  Remove this, and it starts to work.

     

     

    • Marked as answer by jaredmill Wednesday, April 6, 2011 9:22 PM
    Wednesday, April 6, 2011 9:19 PM
  • Hey Jared, did you speak to MS Support about this?  Is this fixed in any CU that you have installed?  I have February CU installed and I tried to delete the last </Property> tag and it would not let me.  I just wonder if this was fixed in a hotfix.
    Tuesday, May 24, 2011 10:22 PM
  • That might not be related.

     

    Check to see if there is a checkbox that says something like "use default", "localization", .... and make sure it is unchecked.  Most of these web parts allow you to use your own xml/xslt if you uncheck a box.  If you mess up, you can recheck the box and save and the defaults will be restored.  Look for a customize option.

    Thursday, May 26, 2011 11:24 PM