none
Block auto forward transport rule not working

    Question

  • Hello all, I'm struggling with something that seems to be quite easy to achieve. I want specific user to be blocked from creating rules in outlook that can lead to forward all emails to external address.

    I followed the guide here:

    https://blogs.technet.microsoft.com/exchange/2017/12/22/the-many-ways-to-block-automatic-email-forwarding-in-exchange-online/

    but neither Transport Rule nor Remote Domain work. I have created a transport rule excactly as stated in the above guide and all messages sent from domainA to domainB(with exchange) are successfully forwarded to domainC. As I got this - this should be blocked completely.

    Tuesday, May 22, 2018 9:50 AM

All replies

  • There's no way of doing that per user that I'm aware of.  You can block all automatic forwarding outside your domain or to specific domains.

    Set-RemoteDomain -AutoForwardEnabled

    https://docs.microsoft.com/en-us/powershell/module/exchange/mail-flow/set-remotedomain?view=exchange-ps


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!


    Tuesday, May 22, 2018 10:36 PM
  • Hello Ed, thank you for your reply. Unfortunately I already tried doing that from the Web GUI I guess in remote domain section but this setting doesn't not seem to work, nor creating transport rules makes any difference. 

    I tried to disable this for all domains or for specific domain but forward set in outlook worked correctly.

    I also tried setting up transport rule to cover that(one for specific user, and the other for all) but they didn't work. All forwarding worked correctly despite setting this in GUI. I found some old thread from 2017 that for some tenants this setting does not work correctly. Can this be the case here?

    Wednesday, May 23, 2018 7:00 AM
  • Please tell us exactly what you've done and in complete detail if you want help with it.  I can't guess what it is you've configured to attempt to help.

    To block all automatic forwards to everywhere, create a remote domain for "*" and set the block there.  If you have any specific remote domains defined, also set the block on them if desired.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!

    Wednesday, May 23, 2018 9:16 PM
  • Ok so first I followed the Transport Rule method as described here:

    https://blogs.technet.microsoft.com/exchange/2017/12/22/the-many-ways-to-block-automatic-email-forwarding-in-exchange-online/

    in Transport Rule Section. I set up everything exactly the same apart mine Instance is in Polish - not english

    This didn't stop forwarding all messages to outside providers from my test mailbox

    Secondly I followed the Remote Domain method by unchecking "Allow Automatic Forwarding" option - no luck - messages are still forwarded to my external mailbox(on live.com domain)

    Additionally I created the RBAC rule to disable Automatic Forward option for test user's mailbox in outlook and this worked. 

    I found similar thread back from 2017 at:

    https://community.spiceworks.com/topic/2042259-block-external-auto-forward-using-transport-rule-in-o365-not-working?page=1#entry-7202202

    stating that Transport Rule might not work for some tenants and would like to know if this was fixed already and if I'm affected. 

    My goal is to have users informed that the automatic forwarding is not permitted.

    Friday, May 25, 2018 9:02 AM
  • You told us what you followed, not exactly what you did.  I'm not going to go read those articles and try to guess what it was you did.

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!

    Friday, May 25, 2018 4:26 PM
  • Hey Ed, thanks for replying. I thought it was clear but you're right. What I did:

    screenshots of my current setup that IMO should work but somehow doesn't. Please kindyl review it and share some ideas, please.

    After setting up below options I am still allowed to configure forwarding(rbac is not applied to my which is alright) and successfully forward message according to below:

    sent from milosz@mycustomdomain

    to milosz.engel@mycompanymail(forwarding enabled in outlook/OWA)

    is forwarded to milosz@anotherexternaladdress.com(live.com)

    Messages are forwarded without any problems or notifications.

    My setup below

    transport rule:

    and default domain:

    like I mentioned earlier - disabling forward option in users mailbox worked correctly.

    Many thanks in advance for helping!

    Monday, May 28, 2018 6:17 AM
  • In your lower picture, clear "Allow automatic replies" and then click Save.

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!

    Tuesday, May 29, 2018 4:49 PM
  • I did it but once done, I lost the possibility to forward messages to different recipient within the same organisation when mail comes from the outside. For example someone@outside.com sends to person1@inside.com and person1 has forwarding set to person2@inside.com - like in out of office scenario. 

    I had to revert the change.

    Anyway I would like to have the notification sent to the users when they try to set the outside forwarding not just drop the emails. Would you have any other ideas what would help achieving that?

    Sunday, June 10, 2018 8:27 PM
  • Hi Milo,

    You are a patient man. I was reading this and couldn't believe the responses.

    Ed, you're a jerk. Plain and simple. If you're not going to be helpful, don't reply to messages. Those of us that ask for help don't need condescending dismissive attitudes attached to the replies. Milo posted the links to the articles. Read them or don't bother attempting to help if you don't have the time.

    Finally, you didn't address the transport rule issue which I am having the same problem with so your last response was, again, dismissive and condescending.

    So, back to the original question. Does anyone (NOT you Ed because clearly, you don't know) know if the Auto-forward transport rule will be fixed or is it going to remain a bug forever?

    Any help (except from Ed) will be greatly appreciated.

    Mb

    Friday, July 6, 2018 2:04 PM