locked
Prevent the default gateway to be added to the DNS forwarders RRS feed

  • Question

  • My SBS 2011 Essentials server is connected via an old router (ASUS WL-500g). It seems to have some problems with requests coming from my server. When I request DNS information of some domains, it fails with error 5501. I can disable EDNS, but then I'll get error 5504 instead and the DNS result is incomplete.

    I thought to be smart and remove the nameserver of my router from the DNS forwarders and use my ISP nameserver instead. This works fine and the errors are gone, but when I reboot the server then the default gateway (my old router) is the primary forwarder again. The old router will be replaced soon, but does anyone know why the default gateway is added to the DNS configuration after a reboot? When the DNS server is restarted, then the default gateway is not added.

    Wednesday, May 2, 2012 8:48 PM

Answers

  • I just put this together a a blog post.

    http://titlerequired.com/2012/05/04/quick-fix-dns-forwarders-sbs-2011-essentials/


    Robert Pearman SBS MVP (2011) | www.titlerequired.com | www.itauthority.co.uk

    Friday, May 4, 2012 12:29 PM

All replies

  • The Basics of Local DNS for Small Business Server 2011 Essentials, Sean Daniel
    http://sbs.seandaniel.com/2011/06/basics-of-local-dns-for-small-business.html

    .

    Quoted from the above link:

    "So how is SBS 2011 Essentials Different?
    SBS 2011 Essentials doesn’t assign itself a static IP address, and it doesn’t
    have a Connect to the Internet Wizard. Essentials will automatically connect to
    the Internet just like any client computer, using the DHCP assigned address. It
    does however use its local DNS server to resolve both local and Internet based
    names by overriding the DHCP assigned IP address to 127.0.0.1 (localhost). If
    you dig into the DNS settings, you’ll notice that the DNS Server picks up the
    routers IP as a forwarder."

    .

    My suggestion is to disable DHCP on the router, and set a static IP on the SBS.

    Running DHCP Server on SBS 2011 Essentials With a Static IP
    SBS Bloggers, [MSFT] 22 Sep 2011 10:35 AM , [Moloy Tandon and Wayne Gordon McIntyre from Commercial Technical Support]
    http://blogs.technet.com/b/sbs/archive/2011/09/22/running-dhcp-server-on-sbs-2011-essentials-with-a-static-ip.aspx

    .

    I believe this question is better suited for the SBS forum, where those folks may have more specifics to offer regarding SBS 2011 Essentials' wizards, behavior, etc.

    Technet SBS Forum:
    http://social.technet.microsoft.com/Forums/en-US/smallbusinessserver/threads

    .


    Ace Fekay
    MVP, MCT, MCITP EA, MCTS Windows 2008/R2, Exchange 2007 & Exchange 2010, Exchange 2010 EA, MCSE & MCSA 2003/2000, MCSA Messaging 2003
    Microsoft Certified Trainer
    Microsoft MVP - Directory Services
    Complete List of Technical Blogs: http://www.delawarecountycomputerconsulting.com/technicalblogs.php

    This post is provided AS-IS with no warranties or guarantees and confers no rights.

    FaceBookTwitterLinkedIn


    Thursday, May 3, 2012 3:20 AM
  • You can run this command as a scheduled task.

    dnscmd /resetforwarders <ip address>

    This will keep the forwarding IP as the one you wish to use.


    Robert Pearman SBS MVP (2011) | www.titlerequired.com | www.itauthority.co.uk

    Friday, May 4, 2012 8:51 AM
  • My SBS 2011 server already uses a static IP address (192.168.10.2) and DHCP is disabled on my router (192.168.10.1). Still the DNS server picks up the router's IP address as a forwarder. The router's DNS forwards all requests to my ISP, so normally this shouldn't be a problem. But I found some DNS errors in my eventlog and it seems that my router cannot handle the EDNS requests from SBS 2011. Disabling EDNS helps a bit, but rather I don't want to use the router's DNS anymore.

    I think that replacing the router with a proper one is the best solution. Thanks for your effort. At least I know why the router IP is used as a forwarder.

    Friday, May 4, 2012 9:46 AM
  • I just put this together a a blog post.

    http://titlerequired.com/2012/05/04/quick-fix-dns-forwarders-sbs-2011-essentials/


    Robert Pearman SBS MVP (2011) | www.titlerequired.com | www.itauthority.co.uk

    Friday, May 4, 2012 12:29 PM
  • It would have been nice if Microsoft adds an advanced option "Use default gateway as default forwarder" that can be disabled :-)
    Friday, May 4, 2012 12:32 PM