none
Same rule crated in Outlook 2016 and OWA (Exchange 2013) handled differently

    Question

  • Rules created via Outlook 2016 have terms with punctuation enclosed in double quotes, whereas the same rule created via OWA has such terms in single quotes. One example is a rule to move to a folder email in which the sender's address contains .us (e.g. as a way to handle all email from the .us top-level domain). If the rule is created in Outlook, the rules shows the term as ".us" (enclosed in double quotes) but if created in OWA, the term shows as '.us' (single quotes). The rule created in Outlook does NOT work, yet the rule created in OWA does work.

    1. Why the difference in how the rules are displayed (single vs double quoted)? Was it just an arbitrary choice? Maybe Exchange and Outlook developers don't talk to each other? :-)

    2. Why does a single-quoted term trigger the rule action as expected, but the double-quoted version does not?

    If the rule created in OWA is viewed in Outlook, the single quotes are preserved around the search term. So it seems the Outlook 2016 desktop client is at fault for double-quoting the search term during rule creation, but it's still not clear why the terms are treated differently. (Which raises an interesting aside: is there an escape character or some other convention to allow quotes themselves as part of a search term?)

    Thanks,
    John.


    -dofzin

    Monday, March 27, 2017 6:52 PM

All replies

  • Hi John,

    Generally, either the rule created in Outlook or created in OWA, they should be all working.

    For the rule condition "with specific words in Sender's address", both the specific word shown as ".us" (enclosed in double quotes) in Outlook or '.us' (single quotes) in OWA are resolved as .us in sender's email address. The function is the same.

    As for the rule created in Outlook does not work issue, please try the following method to do further troubleshooting: 

    Remove the rule created in OWA, then recreate it in Outlook. Go to File > Account Settings > Account Settings, double-click the Exchange account, uncheck the option "Use Cached Exchange mode". Restart Outlook in Online mode, confirm if the Inbox rule is working in Online mode.


    Regards,

    Winnie Liang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, March 28, 2017 9:14 AM
    Moderator