locked
Can't get auto-logon to work... RRS feed

  • Question

  •  

    Automatic Logon Doesn't Work.

     

    I cannot get automatic logon to work under Windows 7. I ran “control userpasswords2” and changed my account to not require a password. I clicked “Apply” and entered my password and confirmed it. I restarted Windows and it still required me to log in. I ran “control userpasswords2” again and the settings were there. Why is it still asking me to login? Also, before anybody brings up “netplwiz,” it opens the same exact dialog application as “control userpasswords2.” I ran “regedit” and checked “HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon” which used to have all of the automatic logon settings. The “AutoAdminLogon” entry is set to “1.” The “DefaultUsername” entry has my username. I don't want to add a “DefaultPassword” setting because I don't really like having my password unencrypted in the registry. Any ideas why it's failing? I really need this so that I don't need to get somebody to log me in every tine I reboot. In the registry I noticed a key called “HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\AutoLogonChecked.” It only contains the “(Default)” entry.

     

    Thanks for any help in advance.

     

    Sean

     

    • Moved by Ronnie VernonMVP Tuesday, July 28, 2009 12:39 PM Focus (From:Windows 7 Installation, Setup, and Deployment)
    Tuesday, July 28, 2009 9:32 AM

All replies

  • Summary "table" of known logon methods: http://www.logonexpert.com/freeautologon.html and paid software tool is also located at this site
    Thursday, July 30, 2009 12:34 PM
  • Summary "table" of known logon methods: http://www.logonexpert.com/freeautologon.html and paid software tool is also located at this site
    This was interesting, but didn't help me fix my problem. I did get the lsasafe.exe program and learn from it that Windows does store the DefaultPassword for autologon in the LSASAFE key. As stated above, DefaultUsername is still set in the WinLogon key. That's how it gets set using “control userpasswords2." This doesn't work for me. I can force it to work by adding DefaultPassword to the WinLogon key, but that's not secure at all, and I know that it's not the proper method. I haven't tried puttting DefaultUsername in LSASAFE yet. I think that lsasafe.exe can do that.

    Sean
    Friday, July 31, 2009 1:07 PM
  • Vista and 7 both work the same way as XP:

    After entering "control userpasswords2" into the Run dialog box, you need to uncheck the box that says "Users must enter a username and password to use this computer." Then click "apply" and Windows will ask you which user you want to be the default user, and prompt you for the user password.


    Saturday, January 9, 2010 4:08 PM
  • There is a good tutorial at:

    http://www.sevenforums.com/tutorials/377-log-automatically-startup.html

    Another option is to use Systernal's Autologon for Windows:

    http://technet.microsoft.com/en-us/sysinternals/bb963905.aspx

    Hope this helps.

    Saturday, November 27, 2010 8:03 AM
  • Its way more simple:

    Add these string values to the HKLM\Software\Microsoft\Windows NT\CurrentVersion\Winlogon\ key:

    AutoAdminLogon = 1

    DefaultDomainName = "YOURdomainname"

    DefaultPassword = "YOURpassword"

    DefaultUserName = "YOURusername"

     

    Remove the "" from the values.

     

    Cheers!

    Friday, September 16, 2011 1:29 PM
  • The benefit of using the Autologon tool (http://technet.microsoft.com/en-us/sysinternals/bb963905.aspx) is that it encrypts the password, whereas the method above stores it in plain text. See http://technet.microsoft.com/en-us/library/gg241187(v=ws.10).aspx for more information.

    Tuesday, March 13, 2012 8:54 PM
  • Its way more simple:

    Add these string values to the HKLM\Software\Microsoft\Windows NT\CurrentVersion\Winlogon\ key:

    AutoAdminLogon = 1

    DefaultDomainName = "YOURdomainname"

    DefaultPassword = "YOURpassword"

    DefaultUserName = "YOURusername"

     

    Remove the "" from the values.

     

    Cheers!


    Also add: ForceAutoLogon and set it to 1. That did the trick for me! No need to add DefaultPassword now.
    Saturday, February 23, 2013 8:30 AM