none
Big problem upgrading EVAL to Retail please help RRS feed

  • Question

  • I am in the same predictiment as what is mentioned in this post

    http://social.technet.microsoft.com/Forums/en-US/dpmsetup/thread/1fe2c4a0-eb5e-4017-9388-9e6d20980743

    except that my eval licenses expired so I cannot get the eval database to startup and get the backup, the error log says

    Log Name:      Application
    Source:        Report Server Windows Service (MSDPM2010EVAL)
    Date:          11/3/2010 9:21:07 AM
    Event ID:      136
    Task Category: Activation
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      Description:
    The evaluation period for this instance of Microsoft SQL Server Reporting Services has expired.  A license is now required.
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Report Server Windows Service (MSDPM2010EVAL)" />
        <EventID Qualifiers="0">136</EventID>
        <Level>2</Level>
        <Task>8</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2010-11-03T15:21:07.000Z" />
        <EventRecordID>144984</EventRecordID>
        <Channel>Application</Channel>
        <Computer></Computer>
        <Security />
      </System>
      <EventData>
      </EventData>
    </Event>

    Am i able to reinstall, obviously without the database backup and manually attach the database file(.mdf & .ldf)?

    NEED HELP please !

    Wednesday, November 3, 2010 3:33 PM

Answers

  • I did manage to get this back to a working state.

    I grabbed the .mdf & .ldf files from the DPM server.

    Attached this to another working sql server / got a backup(.bak file)

    Uninstalled everything on the DPM server- DPM(retain data)  & SQL server

    Reinstalled  using Retail Disc

    Added storage pool volumes to the storage pool.

    Ran the following commands

    Dpmsync –RestoreDB –DbLoc <path to the dpmdb.bak file>

    Run Dpmsync -sync

    Things seem to be working now.

    • Marked as answer by bensler Monday, November 8, 2010 4:30 PM
    Monday, November 8, 2010 4:30 PM