locked
Monitoring Exchange 2010 Autodiscover errors. RRS feed

  • Question

  • I am getting below errors on a daily basis, testing with www.testexchangeconnectivity.com shows no problem. So I guess its some small config problem.

    How to fix?? 

     

    An exception occurred while the cmdlet was running. This often indicates the test environment isn't prepared correctly. The administrator needs to examine the configuration. Exception details: Microsoft.Exchange.Monitoring.FatalAutodiscoverException: Fatal Autodiscover failure EXPR = <Null>.

    at Microsoft.Exchange.Monitoring.AutodiscoverTask.AutodiscoverEnd(IAsyncResult asyncResult)

    at System.Net.LazyAsyncResult.Complete(IntPtr userToken)

    at System.Net.ContextAwareResult.CaptureOrComplete(ExecutionContext& cachedContext, Boolean returnContext)

    at System.Net.ContextAwareResult.FinishPostingAsyncOp()

    at System.Net.HttpWebRequest.BeginGetResponse(AsyncCallback callback, Object state)

    at Microsoft.Exchange.Management.SystemConfigurationTasks.AutoDiscoverClient.<>c__DisplayClass6.<>c__DisplayClass8.<BeginInvoke>b__5(ICredentials credentials)

    at Microsoft.Exchange.Management.SystemConfigurationTasks.CredentialsImpersonator.Impersonate(ImpersonateDelegate impersonateDelegate)

    at Microsoft.Exchange.Management.SystemConfigurationTasks.AutoDiscoverClient.<>c__DisplayClass6.<BeginInvoke>b__4()

    at Microsoft.Exchange.Management.SystemConfigurationTasks.AutoDiscoverClient.ExecuteAndReportErrors[T](Func`1 func)

    at Microsoft.Exchange.Management.SystemConfigurationTasks.TestOutlookWebServices.InternalDiscover(String componentId, List`1 endpoints, String emailAddress, AsyncCallback asyncCallback, String[] optionalHeaders)

    at Microsoft.Exchange.Monitoring.AutodiscoverTask.AutodiscoverBegin(AsyncResult`1 result)

    at Microsoft.Exchange.Monitoring.AutodiscoverTask.<BuildTransactions>d__2.MoveNext()

    at Microsoft.Exchange.Monitoring.OutlookConnectivityBase.<BuildTransactionHelper>d__0.MoveNext()

    at Microsoft.Exchange.Monitoring.TestOutlookConnectivityTask.RunTasksWithTimeout(ExDateTime expireTime, IEnumerable`1 task)

    at Microsoft.Exchange.Monitoring.TestOutlookConnectivityTask.InternalProcessRecord()

    Diagnostic command: "Test-OutlookConnectivity -Protocol:Http -TrustAnySSLCert:$true -MonitoringContext:$true"

    TimeWindowStart: 2011-11-03T08:54:18.2558290+01:00

    TimeWindowEnd: 2011-11-03T09:07:38.2558289+01:00

    TimeFirst: 2011-11-03T08:54:18.2558290+01:00

    TimeLast: 2011-11-03T08:59:24.8836565+01:00

    Count: 2

    EventSourceName: MSExchange Monitoring OutlookConnectivity End To End

    Thursday, November 3, 2011 9:22 AM

Answers

  • Hi Ruben,

    Per your information, it seems you are using the MOM or other monitoring system, it seems caused Outlook Anywhere no enable casing URL to have null value.
    You could Ignore / disable Test Rules that is related to Outlook Anywhere on MOM or other monitoring system.
    If I misundertand your issue, please feel free let us know.

    Regards!
    Gavin

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Marked as answer by Gavin-Zhang Monday, November 28, 2011 2:31 AM
    Friday, November 4, 2011 9:03 AM

All replies

  • Is it logging in Event logs ? then what is the event id. Pls post the complete event here.

    run test-outlook test-outlookwebservices command in Exchange powershell and let us know if it reports any errors in powershell / Application event logs.


    SudhirBidye. ____________________________________________________________Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, November 3, 2011 2:03 PM
  • Hi Ruben,

    Per your information, it seems you are using the MOM or other monitoring system, it seems caused Outlook Anywhere no enable casing URL to have null value.
    You could Ignore / disable Test Rules that is related to Outlook Anywhere on MOM or other monitoring system.
    If I misundertand your issue, please feel free let us know.

    Regards!
    Gavin

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Marked as answer by Gavin-Zhang Monday, November 28, 2011 2:31 AM
    Friday, November 4, 2011 9:03 AM
  • Hi Ruben,

    Any update for your issue?

    Regards!
    Gavin
    TechNet Subscriber Support in forum
    If you have any feedback on our support, please contact tngfb@microsoft.com
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Monday, November 7, 2011 8:16 AM