locked
Configuring DirectAccess in Windows Server 2012 Essentials RRS feed

  • Question

  • I am configuring Direct Access using http://technet.microsoft.com/en-us/library/jj204618

    When I am in Powershell in step 3a.  I get this error:

    I substituted “www.contoso.com” with my external RWW URL: remote.mytestdomain.com  

    Running this for the 1st time, I am a clueless nube.  Any ideas?  TIA,


    Scott



    • Edited by scott.buchanan Sunday, September 30, 2012 5:25 PM more info
    Saturday, September 29, 2012 11:59 PM

Answers

  • The Configure DirectAccess in Windows Server 2012 Essentials directions just changed.  I will start over using the new directions.

    Scott

    Thursday, October 11, 2012 6:35 AM

All replies

  • Do you have te certificate configured properly?

    Check what is in the variables that you run. ie $nlscert.  And the Adapter variable. If they are empty it will fail.

    Can it resolve the FQDN  remote.mytestdomain.copm (or what you use)?


    Monday, October 1, 2012 7:34 AM
  • Hi,

    The article you mentioned is correct to configure Direct Access on Windows Server 2012 Essentials. There are 9 steps included, please make sure that you have followed the Step 1 & 2 properly before moving forward to Step 3.

    At the same time, if you followed the Step 1 & 2 according to the link you mentioned, please add the following parameter at the end of the Windows PowerShell command:

    -Verbose

    Install-RemoteAccess -NoPrerequisite  -DAInstallType FullInstall  -InternetInterface $Adapter  -InternalInterface $Adapter -ConnectToAddress "www.contoso.com" -nlscertificate $nlscert –force -Verbose

    Then post back the result you get.

    Regards,

    James


    James Xiong

    TechNet Community Support


    • Edited by James Xiong Monday, October 1, 2012 7:51 AM
    Monday, October 1, 2012 7:50 AM
  • Thanks for the responses.

    The Godday cert is installed and RWW works https://remote.geexxxxxx.com  (domain name is masked).

    Steps one and two are done, I will rerun those steps.

    I may not understand the network location server part.

    My server name is server.gee.local

    Do I use the same server name server.gee.local or use DirectAccess-NLS.gee.local for the network location server in step 2?

    Step 3a, do I use the internal server name server.gee.local or the external name remote.geexxx.com?

    I


    Scott

    Monday, October 1, 2012 8:28 PM
  • In step 2 i used DirectAccess-NLS.gee.local. Its just for detecting if the client on the local network or not.

    In step 3a you use the public FQDN. In your case remote.geexxx.com

    //Magnus

    Tuesday, October 2, 2012 10:42 AM
  • Thanks for the clarification. 

    Started over and get this is step 3a:

    Windows PowerShell
    Copyright (C) 2012 Microsoft Corporation. All rights reserved.

    PS C:\Windows\system32> $Adapter = (Get-WmiObject -Class Win32_NetworkAdapter -Filter "NetEnabled=$true").NetConnectionI
    d
    PS C:\Windows\system32> $Certs = dir cert:\LocalMachine\My
    PS C:\Windows\system32> $nlscert = $certs | Where-Object{$_.Subject –like “*CN=DirectAccess-NLS*”}
    PS C:\Windows\system32>
    PS C:\Windows\system32> #Install DirectAccess. Replace the “www.contoso.com” below with the FQDN for the server
    PS C:\Windows\system32> Install-RemoteAccess -NoPrerequisite  -DAInstallType FullInstall  -InternetInterface $Adapter  -
    InternalInterface $Adapter -ConnectToAddress remote.geewizwally.com -nlscertificate $nlscert –force$Adapter = (Get-WmiOb
    ject -Class Win32_NetworkAdapter -Filter "NetEnabled=$true").NetConnectionId
    Install-RemoteAccess : A parameter cannot be found that matches parameter name 'force$Adapter'.
    At line:1 char:190
    + ... icate $nlscert –force$Adapter = (Get-WmiObject -Class Win32_NetworkAdapter -Filt ...
    +                    ~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidArgument: (:) [Install-RemoteAccess], ParameterBindingException
        + FullyQualifiedErrorId : NamedParameterNotFound,Install-RemoteAccess

    PS C:\Windows\system32> $Certs = dir cert:\LocalMachine\My
    PS C:\Windows\system32> $nlscert = $certs | Where-Object{$_.Subject –like “*CN=DirectAccess-NLS*”}
    PS C:\Windows\system32>
    PS C:\Windows\system32> #Install DirectAccess. Replace the “www.contoso.com” below with the FQDN for the server
    PS C:\Windows\system32> Install-RemoteAccess -NoPrerequisite  -DAInstallType FullInstall  -InternetInterface $Adapter  -
    InternalInterface $Adapter -ConnectToAddress remote.geewizwally.com -nlscertificate $nlscert –force

    Not sure what this means.

    TIA,

    Scott


    Wednesday, October 3, 2012 2:54 PM
  • I added replaced the last line with

    Install-RemoteAccess -NoPrerequisite  -DAInstallType FullInstall  -InternetInterface $Adapter  -InternalInterface $Adapter -ConnectToAddress remote.geewizwally.com -nlscertificate $nlscert –force -Verbose

    as James suggested and got this:

    Windows PowerShell
    Copyright (C) 2012 Microsoft Corporation. All rights reserved.

    PS C:\Windows\system32> $Adapter = (Get-WmiObject -Class Win32_NetworkAdapter -Filter "NetEnabled=$true").NetConnectionI
    d
    PS C:\Windows\system32> $Certs = dir cert:\LocalMachine\My
    PS C:\Windows\system32> $nlscert = $certs | Where-Object{$_.Subject –like “*CN=DirectAccess-NLS*”}
    PS C:\Windows\system32>
    PS C:\Windows\system32> #Install DirectAccess. Replace the “www.contoso.com” below with the FQDN for the server
    PS C:\Windows\system32> Install-RemoteAccess -NoPrerequisite  -DAInstallType FullInstall  -InternetInterface $Adapter  -
    InternalInterface $Adapter -ConnectToAddress remote.geewizwally.com -nlscertificate $nlscert –force -Verbose$Adapter = (
    Get-WmiObject -Class Win32_NetworkAdapter -Filter "NetEnabled=$true").NetConnectionId
    Install-RemoteAccess : A parameter cannot be found that matches parameter name 'Verbose$Adapter'.
    At line:1 char:197
    + ... nlscert –force -Verbose$Adapter = (Get-WmiObject -Class Win32_NetworkAdapter -Fi ...
    +                    ~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidArgument: (:) [Install-RemoteAccess], ParameterBindingException
        + FullyQualifiedErrorId : NamedParameterNotFound,Install-RemoteAccess

    PS C:\Windows\system32> $Certs = dir cert:\LocalMachine\My
    PS C:\Windows\system32> $nlscert = $certs | Where-Object{$_.Subject –like “*CN=DirectAccess-NLS*”}
    PS C:\Windows\system32>
    PS C:\Windows\system32> #Install DirectAccess. Replace the “www.contoso.com” below with the FQDN for the server
    PS C:\Windows\system32> Install-RemoteAccess -NoPrerequisite  -DAInstallType FullInstall  -InternetInterface $Adapter  -
    InternalInterface $Adapter -ConnectToAddress remote.geewizwally.com -nlscertificate $nlscert –force -Verbose

    TIA,


    Scott

    Wednesday, October 3, 2012 3:13 PM
  • I put a space after -verbose:

    $Adapter = (Get-WmiObject -Class Win32_NetworkAdapter -Filter "NetEnabled=$true").NetConnectionId
    $Certs = dir cert:\LocalMachine\My
    $nlscert = $certs | Where-Object{$_.Subject –like “*CN=DirectAccess-NLS*”}

    #Install DirectAccess. Replace the “www.contoso.com” below with the FQDN for the server
    Install-RemoteAccess -NoPrerequisite  -DAInstallType FullInstall  -InternetInterface $Adapter  -InternalInterface $Adapter -ConnectToAddress remote.geewizwally.com -nlscertificate $nlscert –force -Verbose

    and I get this:

    Windows PowerShell
    Copyright (C) 2012 Microsoft Corporation. All rights reserved.

    PS C:\Windows\system32> $Adapter = (Get-WmiObject -Class Win32_NetworkAdapter -Filter "NetEnabled=$true").NetConnectionI
    d
    PS C:\Windows\system32> $Certs = dir cert:\LocalMachine\My
    PS C:\Windows\system32> $nlscert = $certs | Where-Object{$_.Subject –like “*CN=DirectAccess-NLS*”}
    PS C:\Windows\system32>
    PS C:\Windows\system32> #Install DirectAccess. Replace the “www.contoso.com” below with the FQDN for the server
    PS C:\Windows\system32> Install-RemoteAccess -NoPrerequisite  -DAInstallType FullInstall  -InternetInterface $Adapter  -
    InternalInterface $Adapter -ConnectToAddress remote.geewizwally.com -nlscertificate $nlscert –force -Verbose
    VERBOSE: Retrieving server GPO details...
    Install-RemoteAccess : The Remote Access role is not installed on server localhost.
    At line:1 char:1
    + Install-RemoteAccess -NoPrerequisite  -DAInstallType FullInstall  -InternetInter ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : NotSpecified: (PS_RemoteAccess:root/Microsoft/...PS_RemoteAccess) [Install-RemoteAccess]
       , CimException
        + FullyQualifiedErrorId : REMOTEACCESS 126,Install-RemoteAccess

    PS C:\Windows\system32>

    TIA,


    Scott

    Wednesday, October 3, 2012 3:20 PM
  • Is there a demo video or slides that shows me a successful Direct Access Install? I have not experienced this, so I have a difficult time with this.


    Scott

    Saturday, October 6, 2012 8:28 PM
  • Is there any error in the eventlog?

    Is there anything more special with your installation?

    Check the parameters. that there is valid information in them.

    $Adapter

    Should contain "Ethernet"

    $Certs Should contain all Certs installed on the computer.

    $nlscert Should contain your Cert that you created for Remote Access in previous steps.

    If you named the certificate to anything else then "DirectAccess-NLS" you should change the line

    $nlscert = $certs | Where-Object{$_.Subject –like “*CN=DirectAccess-NLS*”}

    To represent what you named it.

    Regards

    //Magnus

    Monday, October 8, 2012 9:15 AM
  • The Configure DirectAccess in Windows Server 2012 Essentials directions just changed.  I will start over using the new directions.

    Scott

    Thursday, October 11, 2012 6:35 AM
  • Did you ever fix this? What resources did you use to find what was causing the problem?

    thank you

    Mark


    Mark R Bracking

    Tuesday, December 4, 2012 3:35 AM
  • I tried:

    http://titlerequired.com/2012/10/15/enable-directaccess-on-windows-server-2012-essentials/

    Workstation backup now fails and the DriectAccess laptop cannot connect to Direct Access, and not while in the LAN I cannot get a domain network profile, just private.

    It would be a joy to experience a working direct access network to get that experience.  Or configure something that works so I know what to expect.


    Scott

    Friday, December 7, 2012 4:28 AM