locked
Access Denied when saving as HTML to Network Drive when a pound sign is uses RRS feed

  • Question

  • Hi

    I have an odd issue which I am wondering why it is happening.  If I have a word doc (.DOC) which in its name is the pound sign (#) and try to save as an HTM or HTML file on a network drive I receive an "Access Denied" error.  The folder that is created to hold the image files and such seems to be cut off right where the pound sign is so I figured that was the cause.  If I do the same thing locally I have no issues and I am told that on previous editions others have not had this issue.  The computers are Office 2010 running on Windows 7 Professional and the server is Server 2008 R2.  If anyone can explain this behavior it will make it much easier for me to inform users as to why they cannot use the # sign when creating their HTML files any more.

     

    Thanks

    Monday, December 5, 2011 8:05 PM

Answers

  • This behavior is by design because the # used within urls or .html based documents  denote anchors within a web site.  The number sign # can be masked or encoded using %23 in an XML file, but this does not work with hyperlinks or html file names in Office files.

    Here is a support article that discusses some of this, although it deals with a hyperlink, the premise is the same:

    202261        You cannot use a pound character in a file name for a hyperlink in an Office program
    http://support.microsoft.com/default.aspx?scid=kb;EN-US;202261

    As per the link http://www.blooberry.com/indexdot/html/topics/urlencoding.htm 

    Character Code
    Points
    (Hex) Code
    Points
    (Dec) Why encode?
    'Pound' character ("#") 23 35 This is used in URLs to indicate where a fragment identifier (bookmarks/anchors in HTML) begins.

    We have seen this issue with other persons in the past and always suggested not to use # character in “folder and filename” for the links or html based file names used within an Office application. Pound ‘#’ is a reserved character for hyperlinks.

     

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Thanks! Adrian Microsoft Online Community Support
    • Marked as answer by Max Meng Wednesday, December 14, 2011 6:52 AM
    Friday, December 9, 2011 5:55 PM

All replies

  • I failed to reproduce it on my test environment - Office 2010 + Windows 7 + Windows Server 2008 R2 + shared folder with full permission + document named as #.doc, and I could save it as #.htm to the shared folder, although with the error message: Word did not save the document. But the document still would get saved to the folder as expected.

    Could you tell us the folder permission setting? So I could try to reproduce it.

    On the other side, if you save the document to the other folder with full permission, will you get the "Access Denied" error?

    Sincerely,

    Max Meng
    Forum Support


    Come back and mark the replies as answers if they help and unmark them if they provide no help.
    If you have any feedback on our support, please contact tnmff@microsoft.com.

    • Edited by Max Meng Wednesday, December 7, 2011 9:25 AM
    Wednesday, December 7, 2011 9:25 AM
  • I was able to reproduce this in two environments.  The original environment where the issue originally happened was Office 2010 + Windows 7 Pro + Server 2008 R2 Standard and the shared folder has full permission to the security group that uses it.  The second environment I confirmed the issue with is Office 2010 + Windows 7 Enterprise + Server 2008 R2 Enterprise and the share gives all domain users Modify rights (All rights except the full rights are checked)  I am able in all other respects able to create directories including ones with pound signs in the name.  The original file name is "NY2-#654321-v2-ELN_321_Buffered_Bullish_linked_to_SPX-final (2).Doc" and when converting the file to HTML the directory created is "NY2-" but when the pound sign is removed the directory correctly creates as "NY2-654321-v2-ELN_321_Buffered_Bullish_linked_to_SPX-final (2)". 
    Wednesday, December 7, 2011 6:22 PM
  • Thanks for the feedback, I am trying to involve someone familiar with this topic to further look at this issue.

    Max Meng

    TechNet Community Support

    Friday, December 9, 2011 8:20 AM
  • This behavior is by design because the # used within urls or .html based documents  denote anchors within a web site.  The number sign # can be masked or encoded using %23 in an XML file, but this does not work with hyperlinks or html file names in Office files.

    Here is a support article that discusses some of this, although it deals with a hyperlink, the premise is the same:

    202261        You cannot use a pound character in a file name for a hyperlink in an Office program
    http://support.microsoft.com/default.aspx?scid=kb;EN-US;202261

    As per the link http://www.blooberry.com/indexdot/html/topics/urlencoding.htm 

    Character Code
    Points
    (Hex) Code
    Points
    (Dec) Why encode?
    'Pound' character ("#") 23 35 This is used in URLs to indicate where a fragment identifier (bookmarks/anchors in HTML) begins.

    We have seen this issue with other persons in the past and always suggested not to use # character in “folder and filename” for the links or html based file names used within an Office application. Pound ‘#’ is a reserved character for hyperlinks.

     

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Thanks! Adrian Microsoft Online Community Support
    • Marked as answer by Max Meng Wednesday, December 14, 2011 6:52 AM
    Friday, December 9, 2011 5:55 PM
  • Hi GrahamGoldenTech,

    Just checking in to see if the information was helpful. Please let us know if you would like further assistance.


    Max Meng

    TechNet Community Support

    Monday, December 12, 2011 9:16 AM
  • Hi,

    I'm marking the reply as answer as there has been no update for a couple of days.

    If you come back to find it doesn't work for you, please reply to us and unmark the answer.


    Max Meng

    TechNet Community Support

    Wednesday, December 14, 2011 6:52 AM