none
Timesheet error (Only for one user on one task): This Web Part was unable to load RRS feed

  • Question

  • Hi,

    We have a weird problem with Project server 2013.
    We are on the latest March CU 2015 update on MS Project and Project server.

    Problem:

    A resource(user) is being assigned to a task. When opening the Project with the MS Project client, you can see that the resource is effectively assigned.->OK

    The real problem is when the user goes to his timesheets. He don’t see this task anymore. Other users that are assigned to the same task can see this task in the Timesheets and can open it.

    When the user go back to a timesheet on a period where the task was working and visible, and he open that timesheets, he get an error: “This Web Part was unable to load”

    ULS log:

    [bucketHash:F0949503] There was an error while loading statusing information in the task details webpart for the specified project/assignment - Project UID: 231d4fab-e08b-44fb-8d49-04f7deff207d Assignment UID: 55e2c540-c8ae-42fa-8458-c1c6e98d98f8. This could be caused by an out-of-date link to the task details page, specifying invalid information, or it could indicate a potential problem with the project or assignment. Exception details follow. Type: 'Microsoft.Office.Project.PWA.StatusingLib.StatusingException', message: 'StatusingDataAccess.GetProjData could not find pre-cached data.  Attempted to load Guid - 231d4fab-e08b-44fb-8d49-04f7deff207d' and stack trace:    at Microsoft.Office.Project.PWA.StatusingLib.StatusingDataAccess.GetProjData(Guid docGuid)     at Microsoft.Office.ProjectDataEdit.Document.SvrDoc..ctor(Guid docGuid, ISvrDataAccess dataAccess, SvrDoc entDoc, SvrDoc resourcePool, Boolean bUseProjectResources)     at Microsoft.Office.Project.PWA.StatusingLib.StatusingDataEdit.InitSvrEditForDoc(Guid docGuid)     at Microsoft.Office.Project.PWA.CommonControls.TaskDetails.QueryData().

    [bucketHash:D7120B28] Webpart TaskDetailsPart failed in CreateChildControls. Unique ID: efbaf89c-01a5-e078-a033-bc18fe4d431c Microsoft.SharePoint.SPException: The Project and/or Assignment unique ID refers to a missing or invalid object.     at Microsoft.Office.Project.PWA.CommonControls.TaskDetails.QueryData()     at Microsoft.Office.Project.PWA.CommonControls.TaskDetails.OnLoad(EventArgs e)     at System.Web.UI.Control.LoadRecursive()     at System.Web.UI.Control.AddedControl(Control control, Int32 index)     at Microsoft.Office.Project.PWA.WebParts.PWAResiliencyPart.CreateChildControls() StackTrace:  at Microsoft.Office.Project.Server.Native.dll: (sig=ad0ca0fd-3c62-4564-9144-b6fd1f587187|2|microsoft.office.project.server.native.pdb, offset=3C16) at Microsoft.Office.Project.Server.Native.dll: (offset=1265D)

    We tried already to republish the whole project with the ‘Save for Sharing’ workaround  without success.

    Someone any idea?

    Since we are migrated to Project 2013, we have a lot of problems with Project Server. Too late to go back L

    Thanks in advance,

    Johan

    Friday, April 3, 2015 8:49 PM

Answers

  • Hi Johan,

    The assignment of this user on the given task might be corrupted. Try to remove the resource from the task, publish the project, assign the resource again and publish again the project. If it is not working, try to unpublish the task (column "publish") and publih it again.


    Hope this helps,


    Guillaume Rouyre, MBA, MVP, P-Seller |

    • Marked as answer by FeytensJ Wednesday, April 8, 2015 11:14 AM
    Tuesday, April 7, 2015 7:21 AM
    Moderator

All replies

  • Hi Johan,

    The assignment of this user on the given task might be corrupted. Try to remove the resource from the task, publish the project, assign the resource again and publish again the project. If it is not working, try to unpublish the task (column "publish") and publih it again.


    Hope this helps,


    Guillaume Rouyre, MBA, MVP, P-Seller |

    • Marked as answer by FeytensJ Wednesday, April 8, 2015 11:14 AM
    Tuesday, April 7, 2015 7:21 AM
    Moderator
  • Hi Guillaume,

    Unpublish the task (column "publish") and publish it again solved my problem.
    Any idea what causes this problem?

    Thank you!

    Johan

    Wednesday, April 8, 2015 11:14 AM
  • You're welcome Johan.

    Assignment corruption might have a clear cause or not. It could be due for example to a connection lost during the project publish.


    Hope this helps,


    Guillaume Rouyre, MBA, MVP, P-Seller |

    Wednesday, April 8, 2015 11:17 AM
    Moderator