locked
Calendar date using Time filter RRS feed

  • Question

  • Calendar date filter returning following value with Member Unique Name rather than date

    [dimDate].[CloseDate].[02579e79-0c81-452d-b637-b8158284a39d]


    RaghuM
    • Edited by MSRN Thursday, October 13, 2011 1:06 AM
    Wednesday, October 12, 2011 10:01 PM

Answers

  • That is strange. What environment are you using?

    Try re-opening the dashboard designer. Also verify if you have properly set up the Time tab in your data source.

    Moreover in your filter link formula, where you connect the filter with another dashboard artefact, try specifying "Day" (without quotes) as a formula.


    http://dailyitsolutions.blogspot.com/
    • Marked as answer by MSRN Thursday, October 13, 2011 9:06 PM
    Thursday, October 13, 2011 8:35 PM

All replies

  • You would have to go back to your Analysis Services solution and verify how you have set up your dimDate dimension. I would assume you have IDs as GUIDs for the underlying dimDate table.

    Either you can change your KeyColumn to a unique date column or change NameColumn to a date column OR use Display name instead of MemberUniqueName.


    http://dailyitsolutions.blogspot.com/
    Thursday, October 13, 2011 3:02 PM
  • I have tried with Display name earlier but no use.

    The Dimension is created on top of View so there is no concept of GUIDs. View pulls Date, Year, Quarter and Month from required table.

    Any other suggestions/alternates?

     

     


    RaghuM
    • Edited by MSRN Thursday, October 13, 2011 4:47 PM
    Thursday, October 13, 2011 4:46 PM
  • Run this query on your SQL Server Management Studio MDX query editor and paste column headers:

     

    SELECT [dimDate].[CloseDate].members on 0
    from [yourCube]


     


    http://dailyitsolutions.blogspot.com/
    Thursday, October 13, 2011 6:13 PM
  • Here is the result by running the query. if possible, please let me know your contact details. my id is raghu.mylavaram@gmail.com

     


    RaghuM
    • Edited by MSRN Thursday, October 13, 2011 6:30 PM
    Thursday, October 13, 2011 6:30 PM
  • That is strange. What environment are you using?

    Try re-opening the dashboard designer. Also verify if you have properly set up the Time tab in your data source.

    Moreover in your filter link formula, where you connect the filter with another dashboard artefact, try specifying "Day" (without quotes) as a formula.


    http://dailyitsolutions.blogspot.com/
    • Marked as answer by MSRN Thursday, October 13, 2011 9:06 PM
    Thursday, October 13, 2011 8:35 PM
  • I had specified the connection as Member Unique Name and the conneciton formula as Day.
    RaghuM
    Thursday, October 13, 2011 9:01 PM
  • I have cross checked the Time database and it was pointing to different data source. My bad. Thanks now its working.


    RaghuM
    Thursday, October 13, 2011 9:06 PM
  • I am getting wrong date with calendar. i think I am taking some wrong step. could you guide me to set date to "Begin the year" and "Reference Date"?

     

     


    RaghuM
    Thursday, October 13, 2011 9:17 PM
  • Both "Begin the year" and "Reference Date" should match for the calendar control to show correct dates. In your case set both the dates to a single date.


    http://dailyitsolutions.blogspot.com/
    Friday, October 14, 2011 3:51 PM