none
FIM pre-requisites for SharePoint 2013 - unable to set compatiblility level as it is a readonly property RRS feed

  • General discussion

  • I am having a problem setting the compatibility level for SharePoint, prior to installing FIM.
    The property is read-only. Is there are registry entry that will complete this?

    Here is the environment:

    Freshly installed VM with Windows 2012 Std. Server is named: FIMS.
    It is domain joined with .Net 3.5 installed.
    It also have SQL 2012 Std installed including full-text search.

    It has SharePoint 2013 installed...
    Configure SQL Server 2012 for SharePoint 2013
    http://sharepointpromag.com/sql-server-2012/configure-sql-server-2012-sharepoint-2013

    I am stuck at step 1 in the following article to prepare SharePoint for the FIM install.

    Installing FIM 2010 R2 on SharePoint Foundation 2013
    https://technet.microsoft.com/en-us/library/jj863242(v=ws.10).aspx
    Violating any of the above conditions will be caught by the setup prerequisite checks and will block the installation of the portal.

    1. The SharePoint 2013 site collection runs in 2010      experience mode.
          
           To verify, in the SharePoint 2013 Management command-line shell, enter the following commands and verify that the return value is 14:
       
      • $spSite = SpSite("http://www.contoso.com");
      • $spSite.CompatibilityLevel

    When I run the command it reports the value is read-only. Advice on how to set this via registry or other mean, is much appreciated.


    PS C:\> $spSite = SpSite("http://fims")
    PS C:\> $spSite.CompatibilityLevel
    15
    PS C:\> $spSite.CompatibilityLevel = 14
    'CompatibilityLevel' is a ReadOnly property.
    At line:1 char:1
    + $spSite.CompatibilityLevel = 14
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidOperation: (:) [], RuntimeException
        + FullyQualifiedErrorId : PropertyAssignmentException

    Thank you

    Wednesday, August 5, 2015 1:07 PM

All replies

  • It would appear that using the SharePoint Wizard to create my first farm setup, is responsible for the read only property. Other web sources indicate that it needs to be deleted and to use powershell to re-create it.

    So we will abandon FIM entirely and use a third party tool.

    Microsoft has excellent documentation, but not for this product.

    Might I suggest that someone at MS actually documents an install of FIM on a 2012 Std server, including its dependencies.

    Thursday, August 6, 2015 2:53 PM