locked
Windows 7 BSOD 0x0000007B and what NOT to do RRS feed

  • General discussion

  • Hi all, I have had an interesting weekend ( or not so interesting depending on how you look at it)

    I thought I was going to replace my keyboard, which shouldn't take more than 5 minutes. But I was in for a ride taking all weekend. And I just want to share my story and what NOT to do when you face this issue. Because I made mistake after mistake. I'm very lucky.. or I'm hoping I am, if I get my system back up. It is currently restoring...

    How it all began

    So, the problem started after the keyboard change. The computer got a blue screen afterwards. The new keyboard was without backlights, and I was worried that was the culprit. I had foolishly bought the wrong type. So i changed back the keyboard again, but the damage was done. The computer would not start...

    Running manufacturer diagnostics it said the issue was cmos battery not detected. So I bought and replaced the cmos battery. OK but now I got the 0x0000007B BSOD.

    what I did

    I did all the things suggested by this article and more:

    - Boot into last known good configuration

    - resetting bios to factory default and set the time.

    - Change SATA configuration to AHCI (Mistake!)

    - Run automatic windows Repair (Mistake!)

    - run sfcnow

    - run chkdsk

    - rebuild boot setup (Mistake!)

    - replace classpnp.sys

    All of the above are recommended remedies if you search the net, often in one long article.

    They are a shot in the dark type of remedies. None of them checks any log, because there isn't any, so these are all suggestions what could have gone wrong. The error simply means it cannot access that file. That can happen for a number of reasons.

    My first mistake was to blindly change the SATA configuration to AHCI from the default IRRT Intel Rapid Restore Technology. It didn't help. Except SATA Configuration WAS the issue in my case. So since it did not help I continued on with auto repair. What auto repair did was copying the windows folder, users, program files to a different folder and recreated them. I would come to find out later this had happened and all the programs stopped working. It created a big mess. Except I was still unaware of all this. I continued on down the list and tried more and more things that caused more and more trouble for me.

    I followed the instructions to change the boot setup, the mbr. You see, before all this, I didn't really need my repair disk, because windows would give me an option to do repair. But after I did the boot stuff that possibility vanished. It would not give me that option anymore, because I had overwritten the boot entries... what was worse, when I inserted my windows DVD, that too, would not start. somehow I messed up the boot really bad with the given commands. So for a while, my last resort to reinstall windows was gone too. Fortunately, my repair disk was still working, and after a bootsect command, my windows dvd started responding again as well.

    I also remembered I had a system image backup. If I just could restore that. Maybe that would work... well... My backup bay and dvd RW were using same slot, so when I used the cd, the bios would not recognize the external hd. And since I didn't have the boot up recovery option anymore, I got this brilliant (or not!) idea of recreating a recovery partition. Or at least look for the one that was there. I could not find it. So I shrank the existing C: and created a new partition. (What this just did was making my system image to not restore anymore! Of course I did not know that EITHER !!!) So I continued...

    I gave up and thought, OK I create a recovery USB instead. I copied the files from the CD to a USB.. but then when I tried to use it I got \boot\bcd Error 0xc0000225. Great, after a lot of searching, I found out the problem likely was either my usb stick, or the fact that I had used a quick format. When I formatted the usb with all bits written, then copied over all files, it worked! and that was kind of a turning point!!

    Resolution

    Except.. I still had that BSOD to deal with. But now I had sensed the wind of change. I went into bios and figured, OK all is lost anyways, let's change the Sata configuration to IDE, and Voila! 

    I restarted and got past the windows splash screen. YES!! except it got stuck in a black screen and nothing. Then I figured it could be the usb, removed the usb and got all the way into windows, but nothing worked, a lot of errors. So then I tried the system image and found it would give me a now third error:  The system image restore failed – Parameter incorrect (0x80070057)

    As a last attempt and pure luck, removing the partition I had created, allowed the system restore to continue. 

    And now... I have got my system back... 

    Happy Halloween everyone, hope at least you had fun reading about it..

    The missing recovery option by the way turned out to be a parameter on the single entry in bcd, recoveryenabled=yes


    Christmas spirit all year long Please remember to vote on useful replies. Mark answers. Help to answer questions of others while you are visting the forums. Thank you.












    Monday, October 29, 2018 5:46 AM

All replies

  • Hi, 

    Happy Halloween to you!

    Also thank you for your sharing your experience and your persistent effort on this issue. It would be more helpful for others who encounter same issue with you. 

    Bests, 

    Joy.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, October 30, 2018 3:46 AM